• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Anyone have this issue ?

Joined
Jan 29, 2012
Messages
4,877 (2.09/day)
Likes
4,273
Location
Florida
System Name natr0n-PC
Processor Xeon E3-1290 / Phenom II X6 1100T / Dual Xeon X5675's
Motherboard Asus Sabertooth Z77 / MSI 970 Gaming / GIGABYTE GA-7TESM
Cooling Deep Cool Assassin / TRUE 120 / Stock
Memory Gskill Ripjaws X - 16GB DDR3 / Samsung Reg - 24GB DDR3 Hexa-Channel
Video Card(s) EVGA GTX 980 Superclocked/ MSI 7970
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Audio Device(s) X-Fi Extreme Music / X-Fi Titanium
Power Supply Corsair TX650 v1/ EVGA SuperNOVA 750
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#1

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,883 (5.46/day)
Likes
6,483
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Jan 29, 2012
Messages
4,877 (2.09/day)
Likes
4,273
Location
Florida
System Name natr0n-PC
Processor Xeon E3-1290 / Phenom II X6 1100T / Dual Xeon X5675's
Motherboard Asus Sabertooth Z77 / MSI 970 Gaming / GIGABYTE GA-7TESM
Cooling Deep Cool Assassin / TRUE 120 / Stock
Memory Gskill Ripjaws X - 16GB DDR3 / Samsung Reg - 24GB DDR3 Hexa-Channel
Video Card(s) EVGA GTX 980 Superclocked/ MSI 7970
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Audio Device(s) X-Fi Extreme Music / X-Fi Titanium
Power Supply Corsair TX650 v1/ EVGA SuperNOVA 750
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#3
Is it continuous flicker? Are you using overdrive?
Yeah continuous flicker till i disable overclock. I was having issues with msi AB dropping clocks to 150/300 something when trying to oc.

I uninstalled msi ab and tested with amd overdrive currently.

With older drivers and msi ab i never had these issues.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,883 (5.46/day)
Likes
6,483
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#4
Yeah continuous flicker till i disable overclock. I was having issues with msi AB dropping clocks to 150/300 something when trying to oc.

I uninstalled msi ab and tested with amd overdrive currently.

With older drivers and msi ab i never had these issues.

Id use the older driver for now, or completely remove the gpu driver and completely remove AB. Use DDU on the driver, for MSI AB, restore defaults, remove it, find all traces of it and delete it all, install fresh chipset driver and then gpu driver, leave OD off and install latest AB. Make sure to save, if necessary go in advanced settings too. AB can be wonky too, I had a advanced setting enabled and it wasn't allowing the PEG slot to jump to 2.0 even though the card was OCD.

Of course I'd make System restore points with proper labeling before each removal and before each installation, to avoid requiring a total system format.

Report Findings to MSI.

By the way have you physically swapped monitors between eachother to isolate the issue?
 

Norton

Moderator & WCG-TPU Captain
Staff member
Joined
Dec 21, 2011
Messages
13,407 (5.65/day)
Likes
38,532
Location
USA
System Name My Fortress/Trish (WCG)/Julia (WCG)/Ella (WCG)/Junior(WCG)/Cruncher 1 & 2/Kreij (WCG)
Processor Ryzen 1700X/i7-970/2600K/i7-980X/Ryzen 1700/Opteron 6168x4/Ryzen 1800X/FX-8350
Motherboard X370 Taichi/ ASUS R3E/Asus P8P67 Pro/EVGA X58 SLI 3/B350 M/SuperMicro 4P/AB350 K4/ASUS 990X
Cooling NH-D14/Phanteks/NH-U14S/H70/Scythe Mugen5/CM 212+ (x4)/NH-U14S/Xig DK Nighthawk
Memory 16GB GSkill TridentZ-3200 (1700X), 16GB GSkill FlareX-2400 (1800X),... various...., 4P- 16x1GB
Video Card(s) RX 580/HD 4670/HD 7770/HD 7870/HD 7770/onboard/HD 7770/GTX 1080
Storage WD 500GB SSD/Seagate 2TB SSHD, everything else is Western Digital (mostly)
Display(s) Dual Dell Ultrasharp U2414H
Case Silverstone FT01B/Source 530/Corsair 230T/Define XL R2/Silverstone FT05/Define R4/custom/Tt P3 open
Audio Device(s) on board (All)
Power Supply Corsair HX850/TX650/CS650M/X Gold 750/EVGA P2 850/X Gold 1050/HX650/M12 II 750
Mouse Logitech G300s
Keyboard Thermaltake Challenger Prime (Great for $30!!!)
Software Win 10 Pro (Fortress), Win 7 Pro (Ella), Ubuntu for everything else
Benchmark Scores Why sit on the Bench when you can get in the game and Crunch!!!
#5
My 7870 used to do things similar to that occasionally with some of the older drivers- was trouble free for at least the last 3 yrs or so.

Note that I stuck with the first or second set of drivers that came out after the issue went away... probably a 2015 driver set the last time I updated
 
Last edited:
Joined
Jan 29, 2012
Messages
4,877 (2.09/day)
Likes
4,273
Location
Florida
System Name natr0n-PC
Processor Xeon E3-1290 / Phenom II X6 1100T / Dual Xeon X5675's
Motherboard Asus Sabertooth Z77 / MSI 970 Gaming / GIGABYTE GA-7TESM
Cooling Deep Cool Assassin / TRUE 120 / Stock
Memory Gskill Ripjaws X - 16GB DDR3 / Samsung Reg - 24GB DDR3 Hexa-Channel
Video Card(s) EVGA GTX 980 Superclocked/ MSI 7970
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Audio Device(s) X-Fi Extreme Music / X-Fi Titanium
Power Supply Corsair TX650 v1/ EVGA SuperNOVA 750
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#6
Id use the older driver for now, or completely remove the gpu driver and completely remove AB. Use DDU on the driver, for MSI AB, restore defaults, remove it, find all traces of it and delete it all, install fresh chipset driver and then gpu driver, leave OD off and install latest AB. Make sure to save, if necessary go in advanced settings too. AB can be wonky too, I had a advanced setting enabled and it wasn't allowing the PEG slot to jump to 2.0 even though the card was OCD.

Of course I'd make System restore points with proper labeling before each removal and before each installation, to avoid requiring a total system format.

Report Findings to MSI.

By the way have you physically swapped monitors between eachother to isolate the issue?

I need to find a dvi cable laying around. I have main dvi cable to hdmi adapter and 2nd screen vga cable to dvi adapter. This is a fresh install btw. I stay away from DDU it bricked my system/os in the past 3 times.

Stock this card runs 1050/1375. I bump it too 1100/1500. My card has dual bios maybe later on ill mod that on there.

For now ill just leave things alone. haha
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,883 (5.46/day)
Likes
6,483
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#7
I need to find a dvi cable laying around. I have main dvi cable to hdmi adapter and 2nd screen vga cable to dvi adapter. This is a fresh install btw. I stay away from DDU it bricked my system/os in the past 3 times.

Stock this card runs 1050/1375. I bump it too 1100/1500. My card has dual bios maybe later on ill mod that on there.

For now ill just leave things alone. haha

I found out the easiest way to cause issues with drivers and system restore backup is to completely remove AMD directory that'll cause some issues when you try to use system restore
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,721 (2.55/day)
Likes
3,516
System Name Vanguard (RTG) Test Rig
Processor I7-7700K 4.8/5.2 24/7 depending on conditions.
Motherboard Asus Z270 Maximus IX Code
Cooling Custom water 240MM OCool 45mm plus 240 EK Radiator cooler
Memory Corsair Vengeance LED Red 4x8GB 32GB 3200MHz kit C-14
Video Card(s) 2 x Reference MSI RX Vega 56
Storage 960 Pro M.2 nvme 250GB, Samsumg 860 Evo 1TB / WD 1TB blue storage drive for my gal ^I^
Display(s) Nexius 32" freesync 2 HDR2 1440P
Case Corsair Obsidion 650D
Audio Device(s) Onboard
Power Supply EVGA Supernova G2 1300W
Mouse Mionix Naos 7000
Keyboard G15
Software Windows 10 Pro
Benchmark Scores Yeah lets talk about that shall we!
#8
Joined
Jan 29, 2012
Messages
4,877 (2.09/day)
Likes
4,273
Location
Florida
System Name natr0n-PC
Processor Xeon E3-1290 / Phenom II X6 1100T / Dual Xeon X5675's
Motherboard Asus Sabertooth Z77 / MSI 970 Gaming / GIGABYTE GA-7TESM
Cooling Deep Cool Assassin / TRUE 120 / Stock
Memory Gskill Ripjaws X - 16GB DDR3 / Samsung Reg - 24GB DDR3 Hexa-Channel
Video Card(s) EVGA GTX 980 Superclocked/ MSI 7970
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Audio Device(s) X-Fi Extreme Music / X-Fi Titanium
Power Supply Corsair TX650 v1/ EVGA SuperNOVA 750
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#9
Did you disable Freesync? I assume your on a freesync monitor>>? If not do it and the flicker should go away.
I don't have a freesync monitor sadly.
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,721 (2.55/day)
Likes
3,516
System Name Vanguard (RTG) Test Rig
Processor I7-7700K 4.8/5.2 24/7 depending on conditions.
Motherboard Asus Z270 Maximus IX Code
Cooling Custom water 240MM OCool 45mm plus 240 EK Radiator cooler
Memory Corsair Vengeance LED Red 4x8GB 32GB 3200MHz kit C-14
Video Card(s) 2 x Reference MSI RX Vega 56
Storage 960 Pro M.2 nvme 250GB, Samsumg 860 Evo 1TB / WD 1TB blue storage drive for my gal ^I^
Display(s) Nexius 32" freesync 2 HDR2 1440P
Case Corsair Obsidion 650D
Audio Device(s) Onboard
Power Supply EVGA Supernova G2 1300W
Mouse Mionix Naos 7000
Keyboard G15
Software Windows 10 Pro
Benchmark Scores Yeah lets talk about that shall we!
#10
I'll ask tomorrow about it and let you know.
@natr0n what driver are you on?
 
Last edited:
Joined
Jan 29, 2012
Messages
4,877 (2.09/day)
Likes
4,273
Location
Florida
System Name natr0n-PC
Processor Xeon E3-1290 / Phenom II X6 1100T / Dual Xeon X5675's
Motherboard Asus Sabertooth Z77 / MSI 970 Gaming / GIGABYTE GA-7TESM
Cooling Deep Cool Assassin / TRUE 120 / Stock
Memory Gskill Ripjaws X - 16GB DDR3 / Samsung Reg - 24GB DDR3 Hexa-Channel
Video Card(s) EVGA GTX 980 Superclocked/ MSI 7970
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Audio Device(s) X-Fi Extreme Music / X-Fi Titanium
Power Supply Corsair TX650 v1/ EVGA SuperNOVA 750
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#11
Solved the issues somewhat.

First dumped bios modified the 3d clocks to 1100/1500 flashed.
I played wolfenstein 2 NC with newest drivers worked flawless.

From my findings no matter what clocks are entered for other 2d modes the driver will force highest memory clock when dual monitors are used.

I'm using 1 monitor for now and idles 300/150 instead of 500/1500 previously 500/1375

I plan to get a usb display adapter since I only use 2nd screen monitoring software. I like these lower temps my room is actually cooler by 5 degrees. :D
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,883 (5.46/day)
Likes
6,483
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#12
Solved the issues somewhat.

First dumped bios modified the 3d clocks to 1100/1500 flashed.
I played wolfenstein 2 NC with newest drivers worked flawless.

From my findings no matter what clocks are entered for other 2d modes the driver will force highest memory clock when dual monitors are used.

I'm using 1 monitor for now and idles 300/150 instead of 500/1500 previously 500/1375

I plan to get a usb display adapter since I only use 2nd screen monitoring software. I like these lower temps my room is actually cooler by 5 degrees. :D
Yeah its common for gpus to up the ante for multimonitor...
 
Joined
Mar 18, 2008
Messages
4,642 (1.24/day)
Likes
1,122
Location
Australia
System Name Night Rider | Mini LAN PC | Workhorse
Processor AMD FX 8350 | i7 2600 | i7 970
Motherboard GA-990FXA-UD3 AM3+ | GA-H77M-D3H | Gigabyte EX58-UD5
Cooling AMD Wraith cooler| Coolermaster Gemini with Noctua 3000RPM Fan | Big shairkan B
Memory 4x2GB DDR3 G.Skill 1600 6-8-6-24| 2x4GB Corsair 1600 | 6x2GB DDR3 1300 Corsair
Video Card(s) ASUS GTX 970 OC in Sli | Gainward GTX 650 TI GS | ASUS 7970 Matrix
Storage 250GB Plextor SSD Por 5 /1TB WD Black | 500GB WD ES/WD Black | WD 320/Seagate 320
Display(s) LG 27" 1440P| Samsung 20" S20C300L/DELL 15" | 22" DELL/19"DELL
Case LIAN LI PC-18 | Mini ATX Case (custom) | Atrix C4 9001
Audio Device(s) Onboard | Onbaord | Onboard
Power Supply Silverstone 750 | Silverstone Mini 450W | Corsair CX-750
Mouse Gigabyte aivia krypton gaming mouse | Rapoo V900 | Gigabyte 6850X
Keyboard MAX Keyboard Nighthawk X8 | Creative Fatal1ty eluminx | Some POS Logitech
Software Windows 7 Pro 64 | Windows 7 Pro 64 | Windows 7 Pro 64/Windows 10 Home
#13
I've have flickering on my second monitor with my 7970 on W7 and W10 until a update for W10 came along the problem went away but sadly is still there on W7.
 
Top