• We've upgraded our forums. Please post any issues/requests in this thread.

Anyone have this issue ?

Joined
Jan 29, 2012
Messages
4,480 (2.09/day)
Likes
3,637
Location
Boca Raton, Florida
System Name natr0n-PC
Processor Phenom II X6 1100T @ 3.7 GHz - NB 3.0 GHz | Xeon E3-1290
Motherboard MSI 970 Gaming | Asus Sabertooth Z77
Cooling TRUE 120 |Deep Cool Assassin
Memory Gskill Ripjaws X - 16GB DDR3 (4x4GB)
Video Card(s) MSI 7970 Twin Frozr III BE OC - 1100/1500
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Case Sunbeam Transformer Silver - frame is built like a tank
Audio Device(s) X-Fi Extreme Music | X-Fi Titanium - Bookshelf system
Power Supply Corsair TX650 v1
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#1

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,197 (5.03/day)
Likes
4,797
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#2
Joined
Jan 29, 2012
Messages
4,480 (2.09/day)
Likes
3,637
Location
Boca Raton, Florida
System Name natr0n-PC
Processor Phenom II X6 1100T @ 3.7 GHz - NB 3.0 GHz | Xeon E3-1290
Motherboard MSI 970 Gaming | Asus Sabertooth Z77
Cooling TRUE 120 |Deep Cool Assassin
Memory Gskill Ripjaws X - 16GB DDR3 (4x4GB)
Video Card(s) MSI 7970 Twin Frozr III BE OC - 1100/1500
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Case Sunbeam Transformer Silver - frame is built like a tank
Audio Device(s) X-Fi Extreme Music | X-Fi Titanium - Bookshelf system
Power Supply Corsair TX650 v1
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#3
Is it continuous flicker? Are you using overdrive?
Yeah continuous flicker till i disable overclock. I was having issues with msi AB dropping clocks to 150/300 something when trying to oc.

I uninstalled msi ab and tested with amd overdrive currently.

With older drivers and msi ab i never had these issues.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,197 (5.03/day)
Likes
4,797
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#4
Yeah continuous flicker till i disable overclock. I was having issues with msi AB dropping clocks to 150/300 something when trying to oc.

I uninstalled msi ab and tested with amd overdrive currently.

With older drivers and msi ab i never had these issues.

Id use the older driver for now, or completely remove the gpu driver and completely remove AB. Use DDU on the driver, for MSI AB, restore defaults, remove it, find all traces of it and delete it all, install fresh chipset driver and then gpu driver, leave OD off and install latest AB. Make sure to save, if necessary go in advanced settings too. AB can be wonky too, I had a advanced setting enabled and it wasn't allowing the PEG slot to jump to 2.0 even though the card was OCD.

Of course I'd make System restore points with proper labeling before each removal and before each installation, to avoid requiring a total system format.

Report Findings to MSI.

By the way have you physically swapped monitors between eachother to isolate the issue?
 

Norton

Moderator & WCG-TPU Captain
Staff member
Joined
Dec 21, 2011
Messages
12,672 (5.80/day)
Likes
36,218
Location
USA
System Name My Fortress/Trish (WCG)/Julia (WCG)/Ella (WCG)/Junior(WCG)/Cruncher 1 & 2/Kreij (WCG)
Processor Ryzen 1700X/i7-970/2600K/i7-980X/3930k/Opteron 6168x4/Ryzen 1600X/FX-8350
Motherboard X370 Taichi/ ASUS R3E/Asus P8P67 Pro/P9X79 Pro/EVGA X58 SLI 3/SuperMicro 4P
Cooling NH-D14/Phanteks/NH-U14S/H70/DeepCool/CM 212+ (x4)/NH-U14S/CM212
Memory 16GB GSkill TridentZ-3200 (1700X), 16GB GSkill FlareX-2400 (1600X),... various...., 4P- 16x1GB
Video Card(s) RX 580/HD 4670/HD 7770/HD 7770/HD 7770/onboard/HD 7770/onboard
Storage WD 500GB SSD/Seagate 2TB SSHD, everything else is Western Digital (mostly)
Display(s) Dell U2414H & 2409W / Dell 2208WFP (shared)
Case Silverstone FT01B/Source 530/Corsair 230T/Define XL R2/Silverstone FT05/Define R4/custom
Audio Device(s) on board (All)
Power Supply Corsair HX850/TX650/CS650M/X Gold 750/EVGA P2 850/X Gold 1050/HX650
Mouse Logitech G300s
Keyboard Thermaltake Challenger Prime (Great for $30!!!)
Software Win 7 Home 64 (Win 10 Pro 64)/Win Pro 64 or Ubuntu 12.04 LTS/14.04 LTS/17.04
Benchmark Scores Why sit on the Bench when you can get in the game and Crunch!!!
#5
My 7870 used to do things similar to that occasionally with some of the older drivers- was trouble free for at least the last 3 yrs or so.

Note that I stuck with the first or second set of drivers that came out after the issue went away... probably a 2015 driver set the last time I updated
 
Last edited:
Joined
Jan 29, 2012
Messages
4,480 (2.09/day)
Likes
3,637
Location
Boca Raton, Florida
System Name natr0n-PC
Processor Phenom II X6 1100T @ 3.7 GHz - NB 3.0 GHz | Xeon E3-1290
Motherboard MSI 970 Gaming | Asus Sabertooth Z77
Cooling TRUE 120 |Deep Cool Assassin
Memory Gskill Ripjaws X - 16GB DDR3 (4x4GB)
Video Card(s) MSI 7970 Twin Frozr III BE OC - 1100/1500
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Case Sunbeam Transformer Silver - frame is built like a tank
Audio Device(s) X-Fi Extreme Music | X-Fi Titanium - Bookshelf system
Power Supply Corsair TX650 v1
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#6
Id use the older driver for now, or completely remove the gpu driver and completely remove AB. Use DDU on the driver, for MSI AB, restore defaults, remove it, find all traces of it and delete it all, install fresh chipset driver and then gpu driver, leave OD off and install latest AB. Make sure to save, if necessary go in advanced settings too. AB can be wonky too, I had a advanced setting enabled and it wasn't allowing the PEG slot to jump to 2.0 even though the card was OCD.

Of course I'd make System restore points with proper labeling before each removal and before each installation, to avoid requiring a total system format.

Report Findings to MSI.

By the way have you physically swapped monitors between eachother to isolate the issue?

I need to find a dvi cable laying around. I have main dvi cable to hdmi adapter and 2nd screen vga cable to dvi adapter. This is a fresh install btw. I stay away from DDU it bricked my system/os in the past 3 times.

Stock this card runs 1050/1375. I bump it too 1100/1500. My card has dual bios maybe later on ill mod that on there.

For now ill just leave things alone. haha
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,197 (5.03/day)
Likes
4,797
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#7
I need to find a dvi cable laying around. I have main dvi cable to hdmi adapter and 2nd screen vga cable to dvi adapter. This is a fresh install btw. I stay away from DDU it bricked my system/os in the past 3 times.

Stock this card runs 1050/1375. I bump it too 1100/1500. My card has dual bios maybe later on ill mod that on there.

For now ill just leave things alone. haha

I found out the easiest way to cause issues with drivers and system restore backup is to completely remove AMD directory that'll cause some issues when you try to use system restore
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,603 (2.65/day)
Likes
3,361
Processor I7-7700K
Motherboard Asus Z270 Maximus IX Code
Cooling Custom water plus another cooler
Memory Corsair Vengeance LED Red 4x8GB 32GB 3200MHz kit
Video Card(s) 2 x MSI RX Vega 56 and a single MSI RX Vega 64 in test rig
Storage 960 EVO/960 Pro M.2 nvme 250/1TB, Samsumg 850 evo 256/ WD 1TB blue
Display(s) Nexius 32" freesync 2 HDR
Case Corsair Obsidion 650D/ cardboard box
Audio Device(s) Onboard
Power Supply EVGA Supernova G2 1300W
Mouse Mionix Naos 7000
Keyboard G15
Software Windows 10 Home
#8
Joined
Jan 29, 2012
Messages
4,480 (2.09/day)
Likes
3,637
Location
Boca Raton, Florida
System Name natr0n-PC
Processor Phenom II X6 1100T @ 3.7 GHz - NB 3.0 GHz | Xeon E3-1290
Motherboard MSI 970 Gaming | Asus Sabertooth Z77
Cooling TRUE 120 |Deep Cool Assassin
Memory Gskill Ripjaws X - 16GB DDR3 (4x4GB)
Video Card(s) MSI 7970 Twin Frozr III BE OC - 1100/1500
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Case Sunbeam Transformer Silver - frame is built like a tank
Audio Device(s) X-Fi Extreme Music | X-Fi Titanium - Bookshelf system
Power Supply Corsair TX650 v1
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#9
Did you disable Freesync? I assume your on a freesync monitor>>? If not do it and the flicker should go away.
I don't have a freesync monitor sadly.
 

fullinfusion

Vanguard Beta Tester
Joined
Jan 11, 2008
Messages
9,603 (2.65/day)
Likes
3,361
Processor I7-7700K
Motherboard Asus Z270 Maximus IX Code
Cooling Custom water plus another cooler
Memory Corsair Vengeance LED Red 4x8GB 32GB 3200MHz kit
Video Card(s) 2 x MSI RX Vega 56 and a single MSI RX Vega 64 in test rig
Storage 960 EVO/960 Pro M.2 nvme 250/1TB, Samsumg 850 evo 256/ WD 1TB blue
Display(s) Nexius 32" freesync 2 HDR
Case Corsair Obsidion 650D/ cardboard box
Audio Device(s) Onboard
Power Supply EVGA Supernova G2 1300W
Mouse Mionix Naos 7000
Keyboard G15
Software Windows 10 Home
#10
I'll ask tomorrow about it and let you know.
@natr0n what driver are you on?
 
Last edited:
Joined
Jan 29, 2012
Messages
4,480 (2.09/day)
Likes
3,637
Location
Boca Raton, Florida
System Name natr0n-PC
Processor Phenom II X6 1100T @ 3.7 GHz - NB 3.0 GHz | Xeon E3-1290
Motherboard MSI 970 Gaming | Asus Sabertooth Z77
Cooling TRUE 120 |Deep Cool Assassin
Memory Gskill Ripjaws X - 16GB DDR3 (4x4GB)
Video Card(s) MSI 7970 Twin Frozr III BE OC - 1100/1500
Storage Crucial MX300 525GB + Multiple Mechs
Display(s) SyncMaster 2343BWX 23" 2048x1152 / Dell 1909W 19" 1440x900
Case Sunbeam Transformer Silver - frame is built like a tank
Audio Device(s) X-Fi Extreme Music | X-Fi Titanium - Bookshelf system
Power Supply Corsair TX650 v1
Software Windows XP/7/8.1/10
Benchmark Scores Xeon E3-1290 cpuz world record
#11
Solved the issues somewhat.

First dumped bios modified the 3d clocks to 1100/1500 flashed.
I played wolfenstein 2 NC with newest drivers worked flawless.

From my findings no matter what clocks are entered for other 2d modes the driver will force highest memory clock when dual monitors are used.

I'm using 1 monitor for now and idles 300/150 instead of 500/1500 previously 500/1375

I plan to get a usb display adapter since I only use 2nd screen monitoring software. I like these lower temps my room is actually cooler by 5 degrees. :D
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,197 (5.03/day)
Likes
4,797
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#12
Solved the issues somewhat.

First dumped bios modified the 3d clocks to 1100/1500 flashed.
I played wolfenstein 2 NC with newest drivers worked flawless.

From my findings no matter what clocks are entered for other 2d modes the driver will force highest memory clock when dual monitors are used.

I'm using 1 monitor for now and idles 300/150 instead of 500/1500 previously 500/1375

I plan to get a usb display adapter since I only use 2nd screen monitoring software. I like these lower temps my room is actually cooler by 5 degrees. :D
Yeah its common for gpus to up the ante for multimonitor...
 
Joined
Mar 18, 2008
Messages
4,475 (1.26/day)
Likes
1,025
Location
Australia
System Name Night Rider | Mini LAN PC | Workhorse
Processor AMD FX 8350 | i7 2600 | i7 970
Motherboard GA-990FXA-UD3 AM3+ | GA-H77M-D3H | Gigabyte EX58-UD5
Cooling AMD Wraith cooler| Coolermaster Gemini with Noctua 3000RPM Fan | Big shairkan B
Memory 4x2GB DDR3 G.Skill 1600 6-8-6-24| 2x4GB Corsair 1600 | 6x2GB DDR3 1300 Corsair
Video Card(s) ASUS GTX 970 OC in Sli | Gainward GTX 650 TI GS | ASUS 7970 Matrix
Storage 250GB Plextor SSD Por 5 /1TB WD Black | 500GB WD ES/WD Black | WD 320/Seagate 320
Display(s) Samsung 2494hs 24" 1080P| Samsung 20" S20C300L/DELL 15" | 22" DELL/19"DELL
Case LIAN LI PC-18 | Mini ATX Case (custom) | Atrix C4 9001
Audio Device(s) Onboard | Onbaord | Onboard
Power Supply Silverstone 750 | Silverstone Mini 450W | Corsair CX-750
Mouse Gigabyte aivia krypton gaming mouse | Rapoo V900 | Gigabyte 6850X
Keyboard MAX Keyboard Nighthawk X8 | Creative Fatal1ty eluminx | Some POS Logitech
Software Windows 7 Pro 64 | Windows 7 Pro 64 | Windows 7 Pro 64/Windows 10 Home
#13
I've have flickering on my second monitor with my 7970 on W7 and W10 until a update for W10 came along the problem went away but sadly is still there on W7.