• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asmedia 1061 Controller/Driver not working


New Member
Jan 1, 2013
1 (0.00/day)

This is my first post here, and I am not sure if this is the proper forum.

I shal also post this in one other forum.

I just installed a new ASUS P9X79 Deluxe motherboard.

The Asmedia 1061 controller is apparently not working.

The 2 eSATA rear ports are completely dead.

I am using two (2) Seagate ST2000DL003 Barracuda Green 2TB Hard Drive - 5900 RPM, 64MB, SATA-6Gb/s on the rear eSATA ports.

I have updated to ASUS BIOS 3203.

I have Windows 7 x64 Ultimate with all updates and service packs.

My main drive is a Western Digital WD Black WD2002FAEX 2TB 7200 RPM 64MB Cache SATA 6.0Gb/s

I have CORSAIR Vengeance 64GB (8 x 8GB) 240-Pin DDR3 SDRAM DDR3 1866 Desktop Memory Model CMZ64GX3M8A1866C9

I have an Intel Core i7-3820 Sandy Bridge-E 3.6GHz (3.8GHz Turbo Boost) LGA 2011 130W Quad-Core Desktop Processor BX80619i73820

There is no Asmedia 1061 driver on my P9X79 Deluxe CD vM1884.

I had to download it from the ASUS site.

I tried reinstalling the v1.3.4 asmedia 1061 driver 3 times, and have restarted the computer each time.

I went to the Asmedia drivers page and updated my Asmedia 1061 driver to v and restarted my computer.

That did not work either.

I also found an Asmedia 1061 firmware update v0951 on the Asmedia driver page, but the .exe file just creates a .bin file in the same folder where the .exe file is.

There is no Readme file to tell me how to update the 1061 firmware, so I was not able to update the 1061 firmware to v0951.

The Asmedia 1061 Readme file says:

To use this readme effectively, you will need to know what
mode your system is in. The easiest way to determine the
mode is to identify how the Serial ATA controller is
presented within the Device Manager. The following
procedure will guide you through determining the mode.

1. On the Start menu, select Control Panel.

2. Open on the 'System' applet (you may first
have to select 'Switch to Classic View').

3. Select the 'Hardware' tab.

4. Select the 'Device Manager' button.

5. From the Device Manager, look for an entry named
'SCSI/RAID Controllers'.
If this entry is present, expand it and look for one of
the following controllers:

- 'Asmedia 106x SATA Controller'
If the Controller above is present, no further action
is required.

- If neither of the controllers above are shown, then
the system is not running in RAID mode and you should
continue with step 6 below.

6. From the Device Manager, look for an entry named
'IDE ATA/ATAPI controllers'.
If this entry is present, expand it and look for one of
the following controllers:

- 'Asmedia 106x SATA Controller'
If the Controller above is present, no further action
is required.

- If this controller is not present, then your system
is not in AHCI mode. No other modes are supported by
the Asmedia 106x SATA Host Controller Drive software and you
should continue with step 7 below.

7. Your system does not appear to be running in RAID or
AHCI mode. If you feel that your system is running in
RAID or AHCI mode and you do not see any of the
controllers listed above, you may choose to contact
your system manufacturer or place of purchase for

Unfortunately, there is no 'SCSI/RAID Controllers' entry in my Device Manager.

Unfortunately, there is no 'IDE ATA/ATAPI controllers' entry in my Device Manager.

My ASUS advanced BIOS setting shows the Asmedia 1061 controller set to AHCI mode, so why does the Asmedia 1061 controller not appear anywhere in my Device Manager?

The Asmedia 1061 Readme file also says:

5.1 General Installation Notes

1. If you are installing the operating system on a system
configured for RAID or AHCI mode, you must pre-install
the Asmedia 106x SATA Host Controller Drive driver using the
F6 installation method described in section 5.3;

However, Section 5.3 is apparently meant only for Windows XP and Windows Vista:

5.3 Pre-Installation Using the F6 Method.

Note: These methods are applicable to systems configured for
RAID or AHCI mode.

1. Extract all driver files from the installation package.
See section 7.2 for instructions on extracting the

2. Create a floppy* containing the following files in the root
for XP, Server2003:
asahxp32.inf, asahxp32.cat, asahxp32.sys, txtSetup.oem

for XP x64 edition, Server2003 x64 edition:
asahxp64.inf, asahxp64.cat, asahxp64.sys, txtSetup.oem

for Vista, Server2008, Win7:
asahci32.inf, asahci32.cat, asahci32.sys

for Vista x64 edition, Server2008 x64 edition, Win7 x64 edition:
asahci64.inf, asahci64.cat, asahci64.sys

*Note: For Windows Vista you can use Floppy, CD/DVD or USB.

3. For Windows XP or later operating systems:

-At the beginning of the operating system installation,
press F6 to install a third party SCSI or RAID driver.

-When prompted, select 'S' to Specify Additional Device.

-continue to step 5.

4. For Windows Vista:

-During the Operating system installation, after selecting the
location to install Vista click on "load Driver" button to
install a third party SCSI or RAID driver.

-Continue to step 5.

5. When prompted, insert the floppy disk or media (Floppy, CD/DVD
or USB) you created in step 2 and press Enter.

6. At this point you should be presented with a selection
for one of the following depending on your hardware
version and configuration:

- Asmedia 106x SATA Controller

7. Highlight the selection that is appropriate for the
hardware in your system and press Enter.

8. Press Enter again to continue. Leave the floppy disk in
the system until the next reboot as the software will
need to be copied from the floppy disk again when setup
is copying files.

I have seen other similar threads about similar problems with the Asmedia 1061 controller, but none of them had a resolution for this particular version of the problem.

Also, many of the responses to those threads seem to discuss the issue that the rear eSATA ports apparently only put out 5V, and not 12V (which is apparently what is needed to power 3.5" drives).

I do not understand that issue anyway, since I think the eSATA ports on the ASUS P9X79 Deluxe are for data only and not power.

However, some of the responders claim they fixed the problem using 5V/12V Power Over eSATA cable with SATA HDD Adapter such as these: http://www.amazon.com/Power-Over-eSA...32?ref=prid-20&tag=tec06d-20

That solution seems to be applicable to eSATA HDDs

That is not the issue here because both my new Seagate HDDs are mounted internally in the Lian-Li PC-6o case, and both use the standard SATA power conectors direct from the PSU.

I connect the rear eSATA ports to the new Seagate HDD data ports using eSATA-to-SATA cables such as these: StarTech Model SATA2ESATA6 6 ft. Shielded eSATA to....

I already have four computers with ASUS P5WD2 Premium motherboards, and the ASUS P5WD2 Premiums each have one rear eSATA port.

In all those four computers I already have exactly the same Seagate HDDs installed internally in the Lian-Li PC-60 cases, using those same eSATA-to-SATA cables, and SATA power connectors direct from the PSUs.

In all four of those computers, those same Seagate HDDs already work perfectly with that setup.

Just to verify that the issue here is not DOA new Seagate HDDs, I attached each of the 2 new Seagate HDDs to the eSATA-to-SATA cable on one of my existing ASUS P5WD2 Premiums, and connected the Seagate HDD to an SATA power connector direct from the PSU.

Sure enough, each of the new Seagate HDDs worked perfectly running off the rear eSATA port of the ASUS P5WD2 Premium motherboard.

Thus, each of the new Seagate HDDs is functioning properly, and the 5V output from the eSATA port of the ASUS P9X79 Deluxe is not the issue (since the Seagate HDDs on the ASUS P9X79 Deluxe are connected internally to SATA power connectors directly from the PSU).

So, how do I get the Asmedia 1061 controller to show up in my Device Manager and also make the 2 rear eSATA ports of the ASUS P9X79 Deluxe work properly?

Is there any way in Windows 7 Ultimate x64 to do an F6 installation using a USB thumb drive without having to do an entire new clean installation of Windows 7 Ultimate x64?

I wish ASUS had said somewhere that the Asmedia 1061 controller driver had to be installed using only F6 during a clean installation.

Oddly, as I indicated above, my ASUS ASUS P9X79 Deluxe driver CD M1884 does not have any Asmedia 1061 driver to install.

I had to download the Asmedia 1061 driver from the ASUS P9X79 Deluxe download page, and that was only v1.3.4.0.

Even v1.3.8.0 which I just got directly from the Asmedia download page - http://www.station-drivers.com/page/asmedia.htm - does not seem to solve this problem.

My existing Windows 7 Ultimate x64 instalation seems to be very fast and stable other than this one Asmedia 1061 controller issue, and I would hate to have to wipe it out just to install the Asmedia 1061 driver with F6 during a new clean install.

I have not yet activated my Windows 7 Ultimate x64 installation, so I guess I could do an F6 clean install again just for the Asmedia 1061 driver, but it would be better if there was some other way.

I think that the Asmedia 1061 driver must already be installed, or else why would it show up in the ASUS advanced BIOS settings?

I just cannot figure out why the Asmedia 1061 controller does not show up anywhere in my Device Manager, and how to get it to work the 2 rear eSATA ports on my ASUS P9X79 Deluxe motherboard.

Thank you in advance for any advice you can render.

Oct 13, 2007
7,693 (2.05/day)
System Name DarkStar
Processor i5 3570K 4.4Ghz
Motherboard Asrock Z77 Extreme 3
Cooling Apogee HD White/XSPC Razer blocks
Memory 8GB Samsung Green 1600
Video Card(s) 2 x GTX 670 4GB
Storage 2 x 120GB Samsung 830
Display(s) 27" QNIX
Case Enthoo Pro
Power Supply Seasonic Platinum 760
Mouse Steelseries Sensei
Keyboard Ducky Pro MX Black
Software Windows 8.1 x64
Wow. This is like a novel but it's good to be thorough. Firstly, I assume this controller is enabled in the bios. For my P55's Marvell onboard, for example, the bios option to enable was called "eSATA boot".

I can tell you that F6 driver at install would do nothing for you; that is only needed if Windows does not see the controller and thus the drives you are trying to install it to at that time. A clean install itself may help; maybe not. Don't have enough info at this point (somehow lol).

Personally have not used an onboard 1061 but have one on a PCI-e card and had no problems with 7 x64 detecting it or the driver install. One way to test this hardware and a "clean install" would be to boot a linux live cd and check if the eSATA ports work. Or reinstall Win 7 to another free disk as a test.