• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ASRock b450 steel legend in bootloop. No beeps, no post.


New Member
Jan 28, 2023
4 (0.07/day)
I have bought the b450 steel legend in combination with the AMD Ryzen 5 5600G.
Including two memory sticks of 8GB each i had the build working.
To prepare the system for windows 11 i only had to enable the secure boot.
After some reading i tried the option 'enable EUFI boot' and i was playing around with 'fast boot'.
Now, after saving the settings i rebooted the system and thats when nothing worked anymore.
The fans on my MB, and green leds do work, but nothing anymore.
After trying to enter the BIOS i figured i'd do a reset, since i expected the system to go to the state i initially received.
After reading, i did the following to reset the BIOS:
1. Remove any cables form the computer (power, HDMI, etc)
2. Connect the jumper switch (part 19 on the design overview)
3. Hold the power button for 30 seconds
4. Remove the CMOS battery
5. Wait for 5 minutes (tried a couple of times, wating 10 minutes and 12 hours)
6. Inserted battery
7. Removed jumper connection
8. Restarted system
Now after that, the system doesnt do anything, except for fans that run and lights that shine.
There is no display on screen, not over MB not over GFX.
Using a GFX card, or have none installed, no difference.
I have two 8GB RAM cards, tried in any combination over the slots, nothing
Used only one card, tried all slots, nothing. Not even with the other memory card.
I tried the debug speaker, but no sound there. After i did a faulty installation of the RAM, the 3 beeps as expected worked. There was no other signal after correctly installing the RAM.
I am out of options.
One thing i now feel bad about, is that jumping the system (resetting the bios), affected the BIOS version, so the CPU is not supported anymore? I know this is a very far stretch, but i have no clue for any other options.

How can i get out of this boot issue? Especially when everything worked fine before i tried playing with EUFI en fastboot?

Thank you so much for your help!


New Member
Jan 21, 2022
29 (0.07/day)
Have you tried unplugging and replugging all your power cables inside the case?
Jan 8, 2017
7,687 (3.38/day)
System Name Good enough
Processor AMD Ryzen R9 7900
Motherboard ASRock B650 Pro RS
Cooling Deepcool Gammaxx L240 V2
Memory 32GB - FURY Beast RGB 5600 Mhz
Video Card(s) Sapphire RX 7900 XT
Storage 1x Kingston A2000 NVMe 1TB, 1x Samsung 850 EVO 250GB , 1x Samsung 860 EVO 500GB
Display(s) LG UltraGear 32GN650-B + 4K Samsung TV
Case Deepcool Matrexx 70
Power Supply GPS-750C
It's most likely the memory.

It not clear to me if you tried different kinds of RAM sticks or they were all the same ?


New Member
Jan 28, 2023
4 (0.07/day)
I tried reconnecting all power cables multiple times.
I used different RAM version,s but the RAM has no problem, since defective RAM immediatly triggers the debug sound over the case speaker.
Any other suggestions?


Staff member
Sep 4, 2008
2,038 (0.38/day)
What I gather is you did stuff in the BIOS, got a black screen, reset the BIOS (Clear CMOS) and now you still get nothing?
Nov 11, 2010
311 (0.07/day)
System Name Uzuki Toune
Processor AMD RYZEN 7 7700X (ASUS PBO 90C Mode)
Motherboard Asus ROG Strix X670E-E Gaming WIFI
Cooling Thermalright Frostspirit 140 White V3 ARGB
Memory 32GB DDR6000 CL36 Kingston (EXPO)(16GBx2)
Video Card(s) Zotac GTX 1050TI
Storage 2TB Kingston KC3000 + 1TB Crucial P2 + 480GB Samsung Evo 850 + 480GB Kingston A400
Display(s) Dell U2723QE + Philips 221V8 (Portrait)
Case NZXT H510
Audio Device(s) Auzen X-FI Forte + Onboard Realtek 4080 -> Creative Gigaworks T40II
Power Supply EVGA G+ 650W
Mouse Logitech MX Master 3 (Work) & G103 (Play)
Keyboard iRocks K71M
Software Windows 11 Professional
is it possible for the function of bios reset is faulty and the bios didnt reset upon doing the steps to reset the bios?


New Member
Jan 28, 2023
4 (0.07/day)
i have no idea to find it out. If the vendor can upgrade the bios, sounds to me like they can access it, as this type of board requires access to the bios to update...
Feb 29, 2016
445 (0.17/day)
System Name Fran
Processor AMD Ryzen 7 5700X
Motherboard ROG Strix B550-F GAMING WIFI II
Cooling Hyper 212 Turbo ARGB
Memory 32GB DDR4 3600MHz
Video Card(s) XFX RX 6700 10GB
Storage Samsung 970 EVO Plus 1TB, Kingston A1000 480GB
Display(s) Lenovo G27q-20 (1440p, 165Hz)
Case NZXT H510
Audio Device(s) MOONDROP Aria SE
Power Supply SuperFlower Leadex Gold III 850W
Mouse Logitech G302
Keyboard Akko ACR67
I had a similar issue with my board on earlier BIOS versions (like back in 2019) when doing memory OC. I had to remove the CMOS battery and power cycle the computer enough times for the automatic emergency recovery mode on the UEFI to engage.

No amount of clearing CMOS would fix it for me, this is what did it. Dunno if your board has this emergency thing, but you can trigger it by turning it on without CMOS and shutting it down inmediatly using the PSU... a few times. Luck have you if you manage to get to a text screen saying an incorrect system configuration was found and settings were reset or something similar.

Yep, I did suffer trying to fix it!