• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asrock Challenger RX 5700 XT problem

Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
I'm having problems with my ASRock RX5700 XT Challenger D OC, i flashed the latest bios from ASRock, but I still have the same problem.
I do not have video output from the card, windows reports a code 43, GPUZ shows the card correctly, but under pixel fillrate, texture fillrate, bus width and bandwidth, it shows "unknown".
I have tried different drivers(I have DDU'd the old ones everytime).
I also have an MSI RX 5700 XT that is working great, the problems are just with this one card.
 

Attachments

Joined
Sep 6, 2019
Messages
1,119 (6.70/day)
System Name just ordinary potato system, but dont understimate potato..
Processor ryzen raven ridge 2200g, ryzen 2600 upgrade:)
Motherboard msi b350 pc mate, biostars a320, asrock ab350m micro
Cooling x2 cheap china handmade, i got plenty aigo/fantech rgb fans now heh
Memory klevv dual channel 8gb 3000mhz, trident 16gb 3600mhz, random ddr2 stick
Video Card(s) back to square, using vega 56 now:D
Storage wd green ssd 240gb, 3tb seagate expnasion, random laptop hdd x4, 1tb 3.5
Display(s) acer vgo 22inch fullhd 75hz
Case cheap segotep/dazumba mid atx, alcatroz mini atx
Audio Device(s) genius retro wood style, harman kardon stick iii
Power Supply be quite system power9, powerlogic standar, voltron 300fx, thermaltake smart 1200w
Mouse rexus, genius ps/2, powerlogic ps/2 ball tracking
Keyboard rexus, random china product x3
Software talking abt best software, autodesk/unity3d/notepad yes notepad!!
Benchmark Scores theres nothing to brag abt potato, but it can run decent 30fps fullhd with good setting:)
maybe a failure becouse of unstable bios, have you make a backup? try to reflash back to previous worked bios
this person can help @eidairaman1
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
Yes, i did make a backup using ati flash, this all started with random black screens and now nothing.
I flashed the bios to a newer version, then it wouldnt boot at all with the card in, finally got back into windows and flashed my backup back into it.
then i found an updated bios on ASRocks website, downloaded and flashed it, still the same, no video and the fans dont run at all, the used to spin up on boot, now nothing.
 

Tatty_One

Senior Moder@tor
Staff member
Joined
Jan 18, 2006
Messages
22,113 (4.30/day)
Location
Worcestershire, UK
System Name The Grey
Processor Skylake i7 6700k @ 4.6gig - 1.35V
Motherboard MSI Z170A Tomahawk
Cooling Cooler Master Seidon 240V AIO/Viper140's
Memory 16GB Corsair Vengeance LPX3000 @ 3200mhz CL15 1T
Video Card(s) Palit 8GB GTX 1070 GameRock OC Edition
Storage SkHynix SL308 120GB/CrucialM4 64GB/1TB WD Black
Display(s) LG 29inch 2560x1080 Curved Ultrawide IPS
Case Phanteks Enthoo Pro M Windowed - Gunmetal
Audio Device(s) SB Xifi Elite Pro 7.1through VideoLogic ZXR550's
Power Supply XFX Pro Black Edition 750W Gold modular
Mouse Coolermaster Storm Octane wired
Keyboard Element Gaming Carbon Mk2 Tournament Mech
Software Win 10 Home x64
Welcome, in order to understand any wider hardware factors that might be involved, could you let us know your system specs please, if you click on your account details you will see a list on the left where system specs are shown, clicking on that will give you the opportunity to fill in your hardware, remember to check the "show system specs" box.
 
Joined
May 4, 2011
Messages
499 (0.16/day)
System Name Smooth-Operator
Processor AMD Ryzen 7 3800x
Motherboard Asrock x570 Taichi
Cooling AMD Wraith Prism
Memory 2x16GB 3200MHz CL16 DDR4
Video Card(s) Sapphire Radeon RX 580 8GB NITRO+
Storage JBOD: 2+1+1TB 7200RPM HDD
Display(s) Samsung S24E370DL 24" IPS Freesync 75Hz
Case Fractal Design Focus G Window Blue
Audio Device(s) Creative X-Fi Titanium PCIe x1
Power Supply Corsair HX850 80+ Platinum
Mouse Gigabyte Aorus M3
Keyboard Zalman ZM-K300M
Software Windows 10 x64 Enterprise/Ubuntu Budgie amd64
Seems like gpu is just faulty, otherwise readings would be proper. To make sure it is not driver or OS related issue boot linux and there read info about your card as well. If such readings will be similar to what you see on windows then card is for sure faulty and there is no way to fix except sending it on RMA.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Rma the card, bios flashimg doesnt fix hardware faults
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
I was hoping for a quick fix, but I figured it was hardware related to start with.
ASRock tech support requested that I update the bios, so I did as they requested, this is the second time I've had to deal with their customer service and I have not been very impressed, I think in the future I will be sticking with MSI, XFX and ASUS, I've had really positive experiences with their product support.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I was hoping for a quick fix, but I figured it was hardware related to start with.
ASRock tech support requested that I update the bios, so I did as they requested, this is the second time I've had to deal with their customer service and I have not been very impressed, I think in the future I will be sticking with MSI, XFX and ASUS, I've had really positive experiences with their product support.
Tell them it didn't work. Also its certain people. Ive seen msi and asus be failures even
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
I've repaired some older cards, but I don't see the benefit of trying to repair a card that has warranty on it, not to mention, I don"t have any way to re-ball the Navi GPU if that's what is wrong, I have done a lot of CPU re-balling back when the XBOX 360 was still around, but none since then.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I've repaired some older cards, but I don't see the benefit of trying to repair a card that has warranty on it, not to mention, I don"t have any way to re-ball the Navi GPU if that's what is wrong, I have done a lot of CPU re-balling back when the XBOX 360 was still around, but none since then.
I never said repair the card, rma it and move forward

I've repaired some older cards, but I don't see the benefit of trying to repair a card that has warranty on it, not to mention, I don"t have any way to re-ball the Navi GPU if that's what is wrong, I have done a lot of CPU re-balling back when the XBOX 360 was still around, but none since then.
Also it could be another component, trace, solder joint or the chip itself. So you know what to do.
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
I knew what you were saying, I was just weighing my options when this whole process started, knowing the way the interactions with ASRock's customer support has gone previously and they way it's started off this time.
I am trying to get them to work with me, if not, I may have to bite the bullet and go buy another one, but if I do, it wont be another ASRock.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I knew what you were saying, I was just weighing my options when this whole process started, knowing the way the interactions with ASRock's customer support has gone previously and they way it's started off this time.
I am trying to get them to work with me, if not, I may have to bite the bullet and go buy another one, but if I do, it wont be another ASRock.
Report that it doesnt work, or send it back from where you got it from.

Go to their social media pages and make a complaint
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
The local computer store that I purchased the ASRock from closed it's doors just before Christmas, when I bought this card, neither of the local Best Buys had any 5700 XT's in stock, so I found this one at a mom and pop shop, I never thought I would need their help, or that they would close up.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
And they didnt go online only, i remember directron having a storefront but they seem to have gone online only
 
Joined
Jan 17, 2020
Messages
10 (0.29/day)
Location
Odessa, Tx
System Name 1 of 2
Processor AMD Ryzen 5 3600 (both)
Motherboard Asus ROG Strix B450-F / MSI Tomahawk B450
Cooling Wraith Prism, 6 - Corsair LL120 fans / Wraith Prism
Memory 16GB PNY Anarchy X 3200 / 32GB Corsair Vengeance LPX 3000
Video Card(s) ASRock Challenger RX 5700 XT D OC / MSI Mech OC RX 5700 XT
Storage 1TB Seagate, 500GB WD SSD, 500GB Hitachi / 256GB M.2 NVMe, PNY 480GB SSD
Display(s) Sharp Aquas 55" 120hz / 32" Sharp 4k
Case Lian Li Lancool II / iBuyPower Snowblind Element
Audio Device(s) onboard (both)
Power Supply Corsair CX750M / Thermaltake SMART 700W
Mouse Logitech (both)
Keyboard Corsair K55 / Logitech
Software Win 10 64 (both)
I never thought about their social media pages, that is a good idea, but I'm going to give them the benefit of doubt and see what direction this goes before I do that. I have jumped the gun in the past and regretted it after the fact, its been a long road and I'm finally learning a little restraint, goes a long way in certain situations. Now that I've said that, I will probably go home to find an email from ASRock that will cause me to blow up their FB page...lol
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,499 (6.39/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I never thought about their social media pages, that is a good idea, but I'm going to give them the benefit of doubt and see what direction this goes before I do that. I have jumped the gun in the past and regretted it after the fact, its been a long road and I'm finally learning a little restraint, goes a long way in certain situations. Now that I've said that, I will probably go home to find an email from ASRock that will cause me to blow up their FB page...lol
Take snapshots and post them, message them too
 
Top