• We've upgraded our forums. Please post any issues/requests in this thread.

Asus HD 7850 DirectCU II TOP V2 Bricked! Help!!

Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#1
Hello everybody,

I know I know, not nice for a first post but I really am desperate!!!

To make it simple, yesterday I downloaded GPUZ to do a copy of my graphic card BIOS (Asus HD 7850 DirectCU II V2) and suddenly the screen went black and the fan of my graphic card started to turn at max % of use!

After a reboot, windows refused to boot (screen frozen at windows logo). I tried to boot from integrated graphic and it worked, so it appears to me that the BIOS got corrupted and that the card is bricked.

Looking at following thread, it seems that 2 people encountered the same issue and reaction from using GPUZ with Asus Tweak running in the same time:

http://forums.overclockers.co.uk/showthread.php?t=18389760&page=88

The thing is I am looking to get either the original BIOS of my card (SN: 113AD41100-103) which is the following one:

http://www.techpowerup.com/gpudb/b1682/ASUS_HD_7850_DirectCU_II_V2.html

or to get whatever BIOS that will give back life to my card :(.

I already tried the two following BIOS:

http://www.techpowerup.com/vgabios/119197/Asus.HD7850.2048.120306_1.html

http://www.techpowerup.com/vgabios/117881/Asus.HD7850.2048.120301.html

...using atiflash booting from DOS. I successfully flashed my card but without solving the issue (It has booted once but then same error after a second reboot, freezing at windows logo > then even if I reflash, It does not work even does not boot at least once!).

I think it is related to the fact that my card is a V2 with 2 DVI plugs and those BIOS are for V1. So I would be very very grateful if someone could give me a correct BIOS to flash my card (a V2 BIOS, or even a TOP V2 card just to try, or whatever BIOS that someone used when facing a similar issue). Unfortunately, I did not find such a BIOS on Internet.

The worst in this story is that I did not want to flash my card but just to do a backup of my BIOS and to protect my PC just in case I could encounter a problem in the future and I just got my BIOS corrupted by the tool used for backuping my BIOS :( :(.

I hope that someone will be able to help me... By the way sorry for my bad english, I am french speaking.

Thank you,

J.
 
Last edited:
Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#2
No one with an Asus 7850 v2 (normal or TOP?)

Thanks for the people who did take time to read my post...

I am surprise that no one has this Asus card (7850 v2). Maybe someone knows a friend who could provide this BIOS or knows another forum where I can ask?

I am not able to use my card anymore, no other BIOS work... No more tomb raider 2013 :cry::cry::cry:
 

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
17,026 (3.43/day)
Likes
17,891
Processor Core i7-4790K
Memory 16 GB
Video Card(s) GTX 1080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 7
#3
re-check the bios collection, i just added a few more V2 bioses
 
Joined
Jan 25, 2011
Messages
497 (0.20/day)
Likes
114
#4
Uninstall those ATI drivers too if you can. Once had the drivers go on a bluescreen loop after a game crash and reinstall cured it so it might help?
 

erocker

Senior Moderator
Staff member
Joined
Jul 19, 2006
Messages
42,369 (10.18/day)
Likes
18,018
Processor Intel i7 8700k
Motherboard Gigabyte z370 AORUS Gaming 7
Cooling Water
Memory 16gb G.Skill 4000 MHz DDR4
Video Card(s) Evga GTX 1080
Storage 3 x Samsung Evo 850 500GB, 1 x 250GB, 2 x 2TB HDD
Display(s) Nixeus EDG27
Case Thermaltake X5
Power Supply Corsair HX1000i
Mouse Zowie EC1-B
Software Windows 10
#6
Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#7
Thanks Thanks Thanks and Thanks :) :) :)

Ouuuuaaahhhhhhh Thank you soooo much for posting the exact BIOS I needed:

http://www.techpowerup.com/vgabios/index.php?did=1002-6819-1043-042c

I flashed and my graphic card is now back again :) :) :).
As explained, I needed to use following ATI utility to delete all AMD driver components before flashing again the BIOS (otherwise it did not changed at first: was still blocked to windows logo):
http://sites.amd.com/us/game/downloa...l-utility.aspx

Many thanks to all of you and especially to W1zzard!

I want also to thank dr.noob for his help ;).

Techpowerup rules!

Ps: I edited my original post because there was a mistake, my card is a V2 not V2 TOP
Ps2: This post will also help Yungboss22 who was waiting since December of this BIOS (discussing with him the BIOS proposed in december did not help)!
http://www.techpowerup.com/forums/showthread.php?p=2815092