• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asus M5A78L-M Usb3 Repair

Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
So, a friend of mine gifted me this faulty motherboard, it just spins the fans indefenetly and doesnt boot, with a speaker didnt throw any beeps.
I tryed giving it a good clean just in case it had some liquid damage or whatever and while removing the NB cooler i scratched some traces: (Dumb me ik)
1626898161871.png

looks like the furthest down trace is broken and now when turning on the mb spins the fans for half a second and stops not giving any beeps.
I know it isnt worth to repair as it is an old cheap motherboard but i just want to learn.
So, could the trace made it spin the fans for half second and not work, other than not working before?
What could be the first broken thing in the Mobo (where it spins the fans but doesnt give post nor beeps)
Thx for your Time guys! :)

Ah yes, i forgot, when turning it on, neither the cpu or NB heats up, not even a bit, im guessing that could be power issue, or maybe a faulty bios chip?
 
Joined
Apr 22, 2021
Messages
78 (0.49/day)
Location
The Netherlands
System Name C₂H₅OH
Processor AMD Ryzen 5 5900X Monoblock
Motherboard Gigabyte X570 Aorus Master Rev 1.0
Cooling Custom loop - MO-RA3 420 Pro - Heatkiller 200 D5 pump/res combo
Memory G.Skill Trident-Z 4x8GB B-die 3800-14-15-15-15-34-1T 260 TRFC
Video Card(s) Gigabyte RTX 3080 Ti Aorus Master EK block
Storage Samsung 980 Pro 1TB - Intel 660 Pro 2TB
Display(s) Gigabyte Aorus FV43U
Case Streacom BC1 Silver
Audio Device(s) Topping DX7Pro - Topping A90 - Hifiman Ananda - Focal Elear - Audeze LCD-XC - Adam A5X & Adam Sub 7
Power Supply Corsair AX850 Titanium
Mouse Logitech G Pro Wireless
Keyboard Ducky One 2 SF White MX Speed Silver
Software Windows 10 Pro
Well it not giving you any information via beeps or whatever indicates (as far as I know) that it doesn't complete the POST. That could indicate the BIOS being corrupt. IF I'm correct, that motherboard has a DIP-8 socketed BIOS chip so it can be replaced. Have you tried to reset the BIOS completely? No PSU, no CMOS battery, then shorting the power on pins in the front panel header? I've had some seemingly dead Gigabyte boards, did the above and left the alone for a few days and they worked :p

Those traces are a bit difficult. You can repair them with some thin jumper wire by scraping of the solder masking and soldering the wire between both points. However, that takes a bit of skill and a half decent soldering iron. A small microscope might help. I've done it multiple times with success.
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
I tought so on the bios being corrupt, already tryed clearing cmos but didn't work out.
Maybe i buy a bios programmer in Aliexpress and try to reprogram the bios chip.
The tracers i might be able to repair dont find it that dificult just nice and steady wrist. Thx for your help :)

Okey so, i checked continuity on the traces and they all have continuity, no one is bridged or shorted so i sealed them with clear nail polisher.
I also checked if the bios chip had voltage and it recives voltage normally
I tryed removing the bios chip and turning the pc on, and it does the same thing, fans spin for 0.5 seconds and thats it, so im guessing that the bios chip is dead.
Can anyone confirm it to me so i buy a bios chip and a programer?
Thx again :)
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
So, After receiving the Ch341a, an extra BIOS chip (just in case the other one was fully dead). I reprogrammed Both Bios chips with the latest bios and kept the old version just in case. I also bought a new psu for my main rig, so got the old one to do some testing.
With the old bios chip programmed and the new psu, motherboard turned on, fans spun and cpu got warm. With the new Bios chip did exactly the same, and also with my old testing psu.
Still no beeps from the board, but that confirms to me that the Bios was corrupted and that might be the main failure of the motherboard (might be another one). Maybe i need some ram or working cpu for it to beep.
I still dont know if the cpu works but i can get both a cpu and ram to test the motherboard and so i'll know if the cpu is dead or not.
This might become my HTPC if it works out finally so lets pray!
 

engiblas38

New Member
Joined
Aug 2, 2021
Messages
11 (0.20/day)
So, After receiving the Ch341a, an extra BIOS chip (just in case the other one was fully dead). I reprogrammed Both Bios chips with the latest bios and kept the old version just in case. I also bought a new psu for my main rig, so got the old one to do some testing.
With the old bios chip programmed and the new psu, motherboard turned on, fans spun and cpu got warm. With the new Bios chip did exactly the same, and also with my old testing psu.
Still no beeps from the board, but that confirms to me that the Bios was corrupted and that might be the main failure of the motherboard (might be another one). Maybe i need some ram or working cpu for it to beep.
I still dont know if the cpu works but i can get both a cpu and ram to test the motherboard and so i'll know if the cpu is dead or not.
This might become my HTPC if it works out finally so lets pray!
Check the clock generator, which is responsible for sending the different frequencies to the components. If the components do not have the proper frequencies, the mobo will not work.
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
i've seen you got the same mb, does it beep without ram and cpu?
How do i check the clock generator? thx :)
 

engiblas38

New Member
Joined
Aug 2, 2021
Messages
11 (0.20/day)
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
yeah, i've seen the response but does your mb beep even without cpu and ram?
want to know before spending some time searching for shorts on the mb.

because that would confirm that there is a short in somewhere i assume. In that case i guess the short make the bios corrupt so it wouldnt even make the fans spin.
 

engiblas38

New Member
Joined
Aug 2, 2021
Messages
11 (0.20/day)
yeah, i've seen the response but does your mb beep even without cpu and ram?
want to know before spending some time searching for shorts on the mb.

because that would confirm that there is a short in somewhere i assume. In that case i guess the short make the bios corrupt so it wouldnt even make the fans spin.
It didn't do any beeb and just turned on the cpu fan. So when you played the integrated it felt too hot. So the alcohol test is only to validate that you are short.
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
So you are sayin that when repaired and working fine, without a cpu and ram it wont beep, or are you saying that with the sb shorted it doesn beep.
Anyways im going to check the sb capacitors

Southbridge capacitors are all fine. None of them shorted alltho i find quite interesting that there were like 5 of them in the 800ohm range if im correct. Seemed a bit weird to me but idk.
Im going to try the boardviewer and check voltages
 

engiblas38

New Member
Joined
Aug 2, 2021
Messages
11 (0.20/day)
many times it is that one of the many internal sources is damaged and the necessary current does not reach the components. Get carried away by schematic to verify those sources. (Memory, CPU and GPU).

If you think it is very complicated, you can get the rebuilt mobo on ebay or amazon
 
Joined
Mar 25, 2020
Messages
17 (0.03/day)
Location
Spain
System Name Warthog
Processor Ryzen 5 2600 4Ghz 1.3v
Motherboard Gigabyte b450 Aorus Elite
Cooling AMD Wraith Max Cooler
Memory 16gb Hyper X Predator 3200 Cl16
Video Card(s) Oem Gtx960 1500Mhz overclock.
Storage 120Gb ssd + 2Tb 7200rpm Toshiba drive
Display(s) Samsung s22d300 75Hz Overclock + Acer shit second monitor.
Case Nox Hummer ZX Zero
Audio Device(s) Superlux HD668b, Logitech G432, G430
Power Supply EVGA B5 650W 80+ bronze Fully Modular
Mouse Steelseries Rival 300, Hyper X Pulsefire Core
Keyboard Ozone AlphaStrike Outemu Red
Software Windows 10 Pro 64-bit
Benchmark Scores Cinebench r15 1372Cb Unigine heaven 4.0 Extreme presset: 1354
Yep, that looks hard af. I tryed to but there is A LOT to check. Tryed looking at a tutorial but couldn't find any decent one that explained what to check.
If you know a video where is explained how to check and what to check i'll try it.
I guess i'll try to get a known good cpu and some ram to see if it boots.
 
Top