• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asus P5K-Premium O.S. Install Problems w/ ICH9R SATA Controller


New Member
Aug 16, 2007
8 (0.00/day)
I just built a new Quad Core system built around an Asus P5K-Premium mobo and I could not for the life of me install WinXP onto my Samsung 500GB SATA2 HD501LJ drive. I tried numerous times with different cables, ports and settings. Problems that I experienced include the drive not being detected in the BIOS sometimes but being detected other times, BSOD's while installing XP, and Windows setup not being able to format the drive and saying that the drive could be damaged. This drive worked fine in my previous system. So I eventually decided to try my older Hitachi 160GB SATA HDD and WinXP installed perfectly with no issues. So thinking that my Samsung had died and that I would have to RMA it, I went out to a brick & mortar store and bought another HD501LJ and that drive had the same exact problems. So I went to Asus's site & forums and found that many people are experiencing the same exact problems with many different brands of drives. I also went to NewEgg to check reviews for the mobo and found that many people were reporting similar problems there. The general idea is that there are issues with the new ICH9R's SATA controller/driver. I have the latest BIOS from Asus (2.04 I think). I wanted to spread the word on this problem and try to search for cures. ANY IDEAS on what to do or try?