• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asus P8Z77-V iGPU always enabled

Joined
Nov 16, 2004
Messages
450 (0.09/day)
Likes
5
Location
Pilipinas!
System Name MIGHTYNITO | MIGHTY_MINI
Processor Intel Core i5 3570K | Intel Core i3 3220
Motherboard Asus P8Z77-I Deluxe | Gigabyte H77N-WIFI
Cooling Deep Cool Gamer Storm Gabriel | Intel Stock HSF
Memory Crucial Ballistix Tactical Tracer 1866 8GB (4x2) | G.Skill Ares 1600 8GB (4x2)
Video Card(s) Zotac GT 640 Synergy Edition | Palit GeForce GT 640
Storage Intel 330 180GB + WD Scorpio Blue 1TB | Seagate Barracuda 500GB
Display(s) Samsung P2250 | Samsung S19A100N
Case Jonsbo U1 | Coolermaster Elite 120
Audio Device(s) On-Board Realtek ALC898 + Sound Blaster X-Fi MB3 | On-Board Realtek ALC892
Power Supply Silverstone ST45SF-G | Silverstone ST50F-ES
Software Windows 7 Home Premium 64 Bit SP1
#1
I just noticed it recently that the iGPU is still enabled and is still eating a chunk of my system memory even if I had my discrete GPU set on Primary display (PCIe) in the BIOS.

2 weeks ago I removed my discrete GPU (660Ti) and sold it... used iGPU since then and today I got a new discrete GPU (660 no Ti), did all I usually do to use it as primary but somehow, iGPU is still enabled. :wtf:

I already disabled Render Standby and Multi Monitor support in the BIOS... also uninstalled Intel Graphics driver from Device Manager... Virtu was not installed... Restarted several times and yet it is still showing in Device Manager... Manually disabled it in Device Manager for now...

But this is rather odd, I didn't had this issue before... what the heck did I do wrong?
 
Joined
Nov 16, 2004
Messages
450 (0.09/day)
Likes
5
Location
Pilipinas!
System Name MIGHTYNITO | MIGHTY_MINI
Processor Intel Core i5 3570K | Intel Core i3 3220
Motherboard Asus P8Z77-I Deluxe | Gigabyte H77N-WIFI
Cooling Deep Cool Gamer Storm Gabriel | Intel Stock HSF
Memory Crucial Ballistix Tactical Tracer 1866 8GB (4x2) | G.Skill Ares 1600 8GB (4x2)
Video Card(s) Zotac GT 640 Synergy Edition | Palit GeForce GT 640
Storage Intel 330 180GB + WD Scorpio Blue 1TB | Seagate Barracuda 500GB
Display(s) Samsung P2250 | Samsung S19A100N
Case Jonsbo U1 | Coolermaster Elite 120
Audio Device(s) On-Board Realtek ALC898 + Sound Blaster X-Fi MB3 | On-Board Realtek ALC892
Power Supply Silverstone ST45SF-G | Silverstone ST50F-ES
Software Windows 7 Home Premium 64 Bit SP1
#2
Rolled back to an older BIOS... Issue resolved...

This will be my last Asus mobo... nothin' but headaches...
 

Vuldrine

New Member
Joined
Feb 17, 2013
Messages
1 (0.00/day)
Likes
1
#3
Hello,

I have the same motherboard and can't disable the igpu, which bios version did you flash to resolved the problem ?

Thank you
 
Joined
Sep 25, 2012
Messages
1,614 (0.83/day)
Likes
650
Location
Jacksonhole Florida
System Name DEVIL'S ABYSS
Processor i7-4790K@4.6 GHz
Motherboard Asus Z97-Deluxe
Cooling Corsair H110 (2 x 140mm)(3 x 140mm case fans)
Memory 16GB Adata XPG V2 2400MHz
Video Card(s) EVGA 780 Ti Classified
Storage Intel 750 Series 400GB (AIC), Plextor M6e 256GB (M.2), 13 TB storage
Display(s) Crossover 27QW (27"@ 2560x1440)
Case Corsair Obsidian 750D Airflow
Audio Device(s) Realtek ALC1150
Power Supply Cooler Master V1000
Mouse Ttsports Talon Blu
Keyboard Logitech G510
Software Windows 10 Pro x64 version 1709
Benchmark Scores Passmark CPU score = 13080
#4
Asus P8Z77-V Bios

Hey guys, I too have the same board, and sometimes I have issues with my overclock settings. The multiplier will stay the same through several reboots even though I change it each time. I'm using BIOS v. 1805, running Windows 8 Pro x64. Other Asus problems; the wireless software doesn't work (has to be constantly disabled/enabled to get connectivity back), the AI Suite II has many bugs (bogus sensor warnings, temps way out of range, etc.), can't uninstall AI Suite or components thereof (hangs system). Seems like some of these problems didn't exist a while back (before last BIOS update to 1805). I guess I'll try flashing 1708 again, unless one of you guys had a problem with it.