• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ASUS RX 470 Strix - bring back stock bios with factory settings

Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I have bought an used ASUS STRIX-RX470-O4G-GAMING which has be used for mining before. Unfortunately it seems that the previous owner had installed a custom Bios. The card gives a 4K signal to my display but in Win 10 it is only recognized as "Microsoft Basic Display Adapter" and GPU-Z shows GPU Clock 0 MHz. When I want to install Radeon Drivers it only works until "searching for new drivers" but then after a few seconds the computer freezes and I have to restart.

I have searched through many forums, but I didn't found a solution. This user of Techpowerup had a similar problem:


I have flashed Bios Versions from www.techpowerup.com with AMD/ATI ATIFlash but the problem is still the same. I have also tried the pixel clock patcher but it does not work properly. I am not a Miner, I just want to use the card for office and normal gaming. Does anyone know how to bring the stock bios with factory settings back to the card? Thank you
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Give me a moment

So is the card able to power your monitor correctly?
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
Thank you. I have allready tried all Strix-Versions from this site:


but I have flashed in windows before. I have now downloaded the flash package but with atiflash -i I receive the message "adapter not found"
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
give me some time to resolve the problem, i will tag you back into the thread, do not abandon these forums i will help you as soon as I can, thanks
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
Thank you. It seems you are a real professional.

Give me a moment

So is the card able to power your monitor correctly?
In Windows the picture seems normal. The only noticeable thing is that the windows night mode does not work (warmer white balance)

interesting - i started windows again and it seems that since i have removed the heatspread and mounted the card again it is recognized in Windows as Radeon (TM) RX 470 Graphics. GPU-Z shows now the GPU Clock (1250 MHz) but the Memory is 0 MHz. But the driver issue is the same, windows is freezing when I try to install the drivers.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Thank you. It seems you are a real professional.


In Windows the picture seems normal. The only noticeable thing is that the windows night mode does not work (warmer white balance)

interesting - i started windows again and it seems that since i have removed the heatspread and mounted the card again it is recognized in Windows as Radeon (TM) RX 470 Graphics. GPU-Z shows now the GPU Clock (1250 MHz) but the Memory is 0 MHz. But the driver issue is the same, windows is freezing when I try to install the drivers.
I want you to pull the card and inspect the PCI Express connector Edge and clean those pins on the graphics card.

Also blow out any dust in the PCI Express slot itself on the motherboard

Use isopropyl alcohol on the pins and Ensure the card is dry before you put it back in the system
 
Last edited:
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I have cleaned the card (with alcohol) and the pcie-slot (giottos Rocket Air Blower) now, unfortunately the result is the same - driver installation freezing and adapter not wound with atiflash. This is strange because under windows I received no error message when I flashed the card. Is there any difference between ATI Winflash and AMD/ATI ATIflash? I have used AMD/ATI ATIflash.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Use the latest flash utility on the card

Receipt that video card and I mean press hard on it make sure that squared in fully into the slot
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I have tried to flash once more under windows, but now the card has also problems under windows. It's now 23.16. I will try it again tomorrow - thank you!
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I will look for some files

Here is the latest bios

Heres others




Here are more but you must verify they have hynix contained in the memory table


Use this tool to flash.

 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
Back again. Thank you. I think the card is bricked. After the last bios flash under Windows Windows hangs up at the start screen and under DOS I get still "adapter not found". It is noticeable that the backplate of the card seems to turn relatively hot after a few minutes. I don't know if this is normal.

To be exactly at the windows login screen the picture is shown but when I press any button or the mouse the display turns black and I have to reset.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Listen don't run the flash program I provided in Dos.

run in windows

Back again. Thank you. I think the card is bricked. After the last bios flash under Windows Windows hangs up at the start screen and under DOS I get still "adapter not found". It is noticeable that the backplate of the card seems to turn relatively hot after a few minutes. I don't know if this is normal.

To be exactly at the windows login screen the picture is shown but when I press any button or the mouse the display turns black and I have to reset.
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
The problem is that meanwhile I can't start windows. Windos starts until the login screen and after I press any keyboard or mouse button the screen turns black and the system hangs up. Is there any possibility to check if the card is physically damaged?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Remove your rx480, put in the rx470, hook your monitor up to your motherboard (not the rx470 or rx480)
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I have also tried the rx470 with a third computer and the result was the same (hang up at startup) so I assume that the card is damaged. It is frustrating at the moment. The card will be replaced by a used GTX 1060 I have allready ordered. I have upgraded all my computers in the last two weeks and I am not ready yet. When everything is done I will start a new attempt with the rx470. I will report here. Thank you very much for your help. In the past I have posted such problems at the german ComputerBase forum. They are good but the level is really higher here. I'll be back. You are much better than any manufacturer support!
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Did you put the monitor on the 6700?

Also remove the amd gpu driver.
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
Please be patient. At the moment I am happy that the main computer fully works. I am awaiting a new computer case and the GTX 1060 in the next few days. Then I will make some changes with the computers and test the RX470. If I don't succeed the RX470 will receive a place on the wall beside my Geforce 2 GTS ;-)
 

Attachments

Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I now had another try but I still think, the card is bricked. I have tried it with the ASUS Z270F Board. The card worked about half a minute then the screen turned black. Before I switched off the computer I could feel the card turning relatively hot within seconds on the backplate at the position of the processor. So it could be an overheating issue.

Before I tested the card again I have removed the heatsink and put new thermal paste on the chip.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Are you gonna put the monitor on the motherboard video outputs or what?

I need your cooperation otherwise i will drop this thread.

I now had another try but I still think, the card is bricked. I have tried it with the ASUS Z270F Board. The card worked about half a minute then the screen turned black. Before I switched off the computer I could feel the card turning relatively hot within seconds on the backplate at the position of the processor. So it could be an overheating issue.

Before I tested the card again I have removed the heatsink and put new thermal paste on the chip.
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
I have connected the monitor with the RX 470
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
When I do so and start atiflash via cmd, i receive an error message that this version of ATI flash is not compatible with the 64bit Version of Windows. When I start the windows version I receive a blue screen.

blue screen error is "THREAD_STUCK_IN_DEVICE_DRIVER"
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Make sure monitor is hooked up to motherboard not the rx470.

Sounds like a windows problem.


Remove the amd gpu driver totally.
Open command prompt in Windows with administrator rights. Make sure it is latest version from here

Then follow this command.


Amdvbflash.exe -unlockrom 0


2, brush into the BIOS

Amdvbflash -f -p 0 XXXX .rom

Note: XXXX is the name of the VBIOS file you downloaded. You can also change the downloaded file name to a simple name.

When I do so and start atiflash via cmd, i receive an error message that this version of ATI flash is not compatible with the 64bit Version of Windows. When I start the windows version I receive a blue screen.

blue screen error is "THREAD_STUCK_IN_DEVICE_DRIVER"
 
Joined
Nov 18, 2019
Messages
22 (0.88/day)
Location
Europe - Austria
System Name Main computer
Processor i7-6700K
Motherboard ASUS Z270F
Cooling Alpenföhn Ben Nevis
Memory 32GB Corsair
Video Card(s) ASUS RX 480 ROG STRIX 8GB
Storage Samsung M.2 SSD 960 Evo
Display(s) AOC 32" 4K and LG 27" 4K
Case Fractal Design Focus G grey
Audio Device(s) SoundBlaster ZXR
Power Supply Bequiet Straight Power 11 650W
Mouse Logitech M570 Trackball
Keyboard DBPOWER USB Gaming
Software Windows 10 x64 Pro
Where can I download Amdvbflash? I can only find atiflash.

Ok, found it!


Amdvbflash.exe -unlockrom 0 produces a bluescreem. I think it is not a windows problem, it's a hardware problem
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,369 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Put windows into safe mode and run command prompt there.
 
Top