• We've upgraded our forums. Please post any issues/requests in this thread.

atitool doesnt work after i flash my HIS x1800gto with sapphire x1800xl bios

Joined
Sep 14, 2006
Messages
9 (0.00/day)
Likes
0
Location
Bronx, NY
#1
hey naturally ive been trying to unlock the 4 pipes everyone seems to have had major success with. anyways atitool now doesnt see anything, in terms type of card, speed, memory, nuffin. i just used ati winflash to change the bios or hoped to but i received a p/n mismatch message after i tried the sapphire x1800xl bios. i dont think anything changed in terms of bios or pipes. this is what ccc tells me about my card -

Graphics Card Manufacturer Powered by ATI
Graphics Chipset Radeon X1800 GTO
Device ID 710A
Vendor 1002

Subsystem ID 0B12
Subsystem Vendor ID 17AF

Bus Type PCI Express
Current Bus Setting PCI Express

BIOS Version 009.012.004.002
BIOS Part Number 113-AA93100-100-HT
BIOS Date 2006/03/29

Memory Size 256 MB
Memory Type DDR3

Core Clock in MHz 520 MHz
Memory Clock in MHz 495 MHz

Primary Display Yes


now i dont know if the bios version has anything to do with how many pipes should be running, because a quick look around her on techpowerup forums and i noticed all the people that posted it had the x1800xt. ehh. i have to use winflash because i dont have a floppy drive and i do have vpu recover on on ccc.

system specs are:
core 2 duo 6700
2gig ddr2 800
320 sata2 and 80 ata
asus p5w dh deluxe
using on board audio for now
dvd burner
 

JC316

Knows what makes you tick
Joined
Jan 24, 2006
Messages
9,370 (2.16/day)
Likes
981
System Name Budget Gaming
Processor AMD FX6300
Motherboard Gigabyte 880GMA-USB3
Cooling Coolermaster Hyper 212+
Memory 8GB Ripjaws DDR3 1600
Video Card(s) HD7850 1GB
Storage 1TB Sata2
Display(s) Acer 24" LED
Case Generic black
Audio Device(s) Stock onboard
Power Supply FSP Aurum Gold 650W
Software Windows 7 Home Premium 64bit
#2
Try a different Ati tool. Beta 14, 15 and 16. I would say 16 would be the best bet.
 
Joined
Apr 3, 2005
Messages
471 (0.10/day)
Likes
27
Location
Surrey, England
System Name The Beast
Processor Core i5 2500K
Motherboard Asus P8Z77-V
Cooling Custom Water Cooling
Memory 2x2Gb Gskill Ripjaw X @ 2133mhz 9-11-9-28 1T
Video Card(s) Sapphire HD6950 2Gb no unlock :-(
Storage 3x500Gb 1x80Gb
Display(s) LG W2486L 24" LED Backlit 1920x1080
Case Hiper custom Osiris mid tower
Power Supply Hi-power modular 900W
Software Win 7 Home Premium 64 bit
#3
I have the exact same card successfully flashed with 16 pipes. I suggest you dont use winflash but instead make a bootable cd because of not having a floppy, as i do.
I've just checked ccc for the data u provided and mine are exactly the same except for the device id, 710A is what the card was origonally but mine is now 7109.

Ive attached below the origonal bios but modified to 16 pipes, no clock changes or XL bios here. Just remember to unzip the file first and rename to something simple such as x180016p.bin - Your device id should stay the same at 710A.
Also after flash make sure to reinstall display driver and recommend use atitool 0.25b14.
Good luck and post back results. :)
 

Attachments

Joined
Sep 14, 2006
Messages
9 (0.00/day)
Likes
0
Location
Bronx, NY
#4
ace80, thank you very much my dude. that was amazing, i have to go to work right now, but when i get back i will do it and post up.
 

dolf

New Member
Joined
Mar 16, 2005
Messages
2,058 (0.44/day)
Likes
30
#5
It is a Device ID MISH-MASH. Reflashing back to the original should solve your problem.
 
Joined
Sep 14, 2006
Messages
9 (0.00/day)
Likes
0
Location
Bronx, NY
#7
sorry for the 2 month hiatus, but yes, the bootable cds wouldnt work for reasons unknown, i created like 5 of them, none would really get working so i jsut caved in and attatched a floppy drive. created one with atiflash, didnt work, reasons unknown, maybe because its a HIS ICEQ3 x1800gto so i used flashrom240, 237 and 16p. none worked. the same problems would come up-

device 0 not found
ati adapter not found
error 0FL01

obviously the card is there and is working fine. before this a while back and as recently as a few hours ago i attempted atiwinflash or winflash or whatever the f*ck its called but it never worked, sure it may have just worked enought to royally screw sh*t up but i dont think it ever really did much, a problem of unmatching or something would come up and it never did anything. ive been trying to flash the bios ACE80 was kind enough to give me but without getting device 0 to be recognized im pretty much screwed.

just solved it. edited my own bios just like ace did for his, for some reason the one i have on mine edited worked but aces on mine didnt. very strange but im happy as a clam about my 16 pipes. thanks ace again for providing me with your bios and jc316 for the advice.
 
Last edited: