• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Blinking Display Port Cables

Joined
Oct 21, 2005
Messages
4,500 (0.95/day)
Likes
2,215
Location
USA
System Name Small ATX Desktop
Processor Intel i5 8600K
Motherboard Asrock Z370 Taichi
Cooling Phanteks PH-TC14PE, Fans: 2xThermalright TY143 / 2xCorsair SP-120L / 1xYate Loon D14BH-12
Memory G-Skill TridentZ 2X8GB DDR4 3200 CL14 F4-3200C14D-16GTZ
Video Card(s) Zotac 1060 6GB Mini ZT-P10600A-10L
Storage Seagate 600 240GB SSD + 2xWD Caviar Blue WD10EZEX 1TB Data
Display(s) Asus PB258Q 2560x1440 25" IPS
Case Lian Li PC A05NB (Inverted Mobo)
Audio Device(s) Audiotechnica ATH M50X, Antlion Mod Mic 4, SYBA SD-CM-UAUD, Acoustic Research 2Ch Speakers
Power Supply Seasonic SS-660XP2 660 Watt Platinum
Mouse Zowie EC2A Mouse, Corsair MM600 hard pad, on top of a Inateck 900x300 XL pad, Tiger Gaming Skates.
Keyboard Filco Majestouch II Ninja TKL, Goldtouch GTC 0033 Ten Key, PS3 Controller
Software Win7 Pro 64 (Installed on Coffee Lake using AsRock's handy PS/2 Simulator in Bios)
#1
Picture keeps going black on display port, bought a few cables, eventually they all have this issue but I don't have this issue on DVI with same monitor and videocard. That would be fine except the #1 assigned monitor position is display port and even if I specify the primary monitor in Windows, certain applications will shove it onto my secondary monitor which is HDMI. With this videocard I only have one DVI port and that has the lowest priority of any ports for some reason.

Are there any brands of Display Port cable that don't have the picture blink black periodically? Reviews for them all seem to universally have criticism of junk cables and they all seem to be made by the same generic low quality OEM.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,163 (5.61/day)
Likes
7,333
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#2
Hmm this is a new one, have you restored gpu control panel settings to default, what about the monitor?
 
Joined
Oct 21, 2005
Messages
4,500 (0.95/day)
Likes
2,215
Location
USA
System Name Small ATX Desktop
Processor Intel i5 8600K
Motherboard Asrock Z370 Taichi
Cooling Phanteks PH-TC14PE, Fans: 2xThermalright TY143 / 2xCorsair SP-120L / 1xYate Loon D14BH-12
Memory G-Skill TridentZ 2X8GB DDR4 3200 CL14 F4-3200C14D-16GTZ
Video Card(s) Zotac 1060 6GB Mini ZT-P10600A-10L
Storage Seagate 600 240GB SSD + 2xWD Caviar Blue WD10EZEX 1TB Data
Display(s) Asus PB258Q 2560x1440 25" IPS
Case Lian Li PC A05NB (Inverted Mobo)
Audio Device(s) Audiotechnica ATH M50X, Antlion Mod Mic 4, SYBA SD-CM-UAUD, Acoustic Research 2Ch Speakers
Power Supply Seasonic SS-660XP2 660 Watt Platinum
Mouse Zowie EC2A Mouse, Corsair MM600 hard pad, on top of a Inateck 900x300 XL pad, Tiger Gaming Skates.
Keyboard Filco Majestouch II Ninja TKL, Goldtouch GTC 0033 Ten Key, PS3 Controller
Software Win7 Pro 64 (Installed on Coffee Lake using AsRock's handy PS/2 Simulator in Bios)
#3
I am certain it is the cable. I had two DP cables on hand, both are junk. Bought a second cable from Monoprice and had issue with more frequency and the cable looked like the same garbage generic. Normally had good luck with monoprice in the past. I would like to know a brand that makes a quality cable product.

When I look at critical reviews for cables on Amazon and Newegg, they all complain about this issue, so I cannot be the only one.
 

Norton

Moderator & WCG-TPU Captain
Staff member
Joined
Dec 21, 2011
Messages
13,644 (5.47/day)
Likes
39,229
Location
USA
System Name My Fortress/Trish (WCG)/Julia (WCG)/Ella (WCG)/Junior(WCG)/Cruncher 1 & 2/Kreij (WCG)
Processor Ryzen 1700X/i7-970/2600K/i7-980X/Ryzen 1700/Opteron 6168x4/Ryzen 1800X/FX-8350
Motherboard X370 Taichi/ ASUS R3E/Asus P8P67 Pro/EVGA X58 SLI 3/B350 M/SuperMicro 4P/AB350 K4/ASUS 990X
Cooling NH-D14/Phanteks/NH-U14S/H70/Scythe Mugen5/CM 212+ (x4)/NH-U14S/Xig DK Nighthawk
Memory 16GB GSkill TridentZ-3200 (1700X), 16GB GSkill FlareX-2400 (1800X),... various...., 4P- 16x1GB
Video Card(s) RX 580/HD 4670/HD 7770/HD 7870/HD 7770/onboard/HD 7770/GTX 1080
Storage WD 500GB SSD/Seagate 2TB SSHD, everything else is Western Digital (mostly)
Display(s) Dual Dell Ultrasharp U2414H
Case Silverstone FT01B/Source 530/Corsair 230T/Define XL R2/Silverstone FT05/Define R4/custom/Tt P3 open
Audio Device(s) on board (All)
Power Supply Corsair HX850/TX650/CS650M/X Gold 750/EVGA P2 850/X Gold 1050/HX650/M12 II 750
Mouse Logitech G300s
Keyboard Thermaltake Challenger Prime (Great for $30!!!)
Software Win 10 Pro (Fortress), Win 7 Pro (Ella), Ubuntu for everything else
Benchmark Scores Why sit on the Bench when you can get in the game and Crunch!!!
#4
I cannot be the only one.
I have similar issues with DP cables going bad. I've had one reg DP and 2 mini DP cables go bad on me over the past couple of years. My monitors are fairly new and I've had the issue occur over 2 different gpu's (7870 and an RX 580)

Never had an issue with an HDMI or DVI cable

Subbed to see if anyone can bring some insight towards a solution....
 
Joined
Oct 21, 2005
Messages
4,500 (0.95/day)
Likes
2,215
Location
USA
System Name Small ATX Desktop
Processor Intel i5 8600K
Motherboard Asrock Z370 Taichi
Cooling Phanteks PH-TC14PE, Fans: 2xThermalright TY143 / 2xCorsair SP-120L / 1xYate Loon D14BH-12
Memory G-Skill TridentZ 2X8GB DDR4 3200 CL14 F4-3200C14D-16GTZ
Video Card(s) Zotac 1060 6GB Mini ZT-P10600A-10L
Storage Seagate 600 240GB SSD + 2xWD Caviar Blue WD10EZEX 1TB Data
Display(s) Asus PB258Q 2560x1440 25" IPS
Case Lian Li PC A05NB (Inverted Mobo)
Audio Device(s) Audiotechnica ATH M50X, Antlion Mod Mic 4, SYBA SD-CM-UAUD, Acoustic Research 2Ch Speakers
Power Supply Seasonic SS-660XP2 660 Watt Platinum
Mouse Zowie EC2A Mouse, Corsair MM600 hard pad, on top of a Inateck 900x300 XL pad, Tiger Gaming Skates.
Keyboard Filco Majestouch II Ninja TKL, Goldtouch GTC 0033 Ten Key, PS3 Controller
Software Win7 Pro 64 (Installed on Coffee Lake using AsRock's handy PS/2 Simulator in Bios)
#5
I have similar issues with DP cables going bad. I've had one reg DP and 2 mini DP cables go bad on me over the past couple of years. My monitors are fairly new and I've had the issue occur over 2 different gpu's (7870 and an RX 580)

Never had an issue with an HDMI or DVI cable

Subbed to see if anyone can bring some insight towards a solution....
Not to mention that monitors are increasingly skipping the DVI port to only offer display port.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,163 (5.61/day)
Likes
7,333
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#6
Not to mention that monitors are increasingly skipping the DVI port to only offer display port.
I wonder if 45 degree or right angle cables would help with signalling. I havent had a problem with a dp to vga adapter.
 
Top