• We've upgraded our forums. Please post any issues/requests in this thread.

Brand new Asrock mobo-Onboard LAN not working

Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#1
As the title tells you, my friend just got a new system with the following config
AMD FX 8120
Asrock 970 Extreme4
2 GB Transcend RAM(to be changed soon)
500W Tagan power supply(from his old rig).
AMD Radeon 5870(from his olg rig).

We put everything together, installed all drivers and everything works perfect except for the onboard LAN. The Realtek chip is showing in Device manager but it is not detecting the LAN cable. The cable is perfect and we tested it on a laptop and desktop.
Tried everything possible-BIOS, drivers and all.
I am on the conclusion that the board is defective.

Any suggestions?
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#2
Problem solved. Thanks for not helping. :p