1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Brand new system not booting up! ( Rampage 2 gene + i7 920 + Gskill 1600 )

Discussion in 'General Hardware' started by amit_talkin, Jan 18, 2010.

  1. amit_talkin

    Jun 19, 2008
    158 (0.05/day)
    Thanks Received:
    Hi ppl,

    I just bought Rampage 2 mobo. today. ( I had AsRock x58 extreme which was DOA ).
    when i start the system, it doesnt show anything on display. debug-LED says "CPU INIT" and that it. it just get hang there.

    Mobo. is brand new but before thinking it is DOA, i m worrying about CPU, i think it is dead?!
    because when i sent AsRock board for repair, tht guy did everything, ( socket replacement, some capacitors and solders etc ) but couldnt get it working.

    RAM is working fine i think, because I tried a diff. module, but it didnt work also. I also tried putting all 3 sticks one by one. but it never boot up.

    I need help from rampage 2 gene owners here, can anyone tell me what you get on your dubugLED after pressing "start" button on mobo? It shows me "welcome" and then starts timer only!

    Another question is, what to do if CPU is dead? I had imported retail boxed CPU from USA to India. ( Purchased from Microcenter ). Am I able to get international warranty on this or have to send it back to USA for RMA?:(

    Last edited: Jan 18, 2010

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)