• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Bricked MSI RX570 8GB OC - Help and suggestions welcome!

Thelurker

New Member
Joined
Mar 31, 2021
Messages
2 (0.12/day)
So 1st post so don't flame me too much! hope this is posted in the correct place too lol

I'm trying to find the correct stock BIOS for a card not being recognised. The good news being the fans spin and when using AMDVBFLASH I can see the card and from inspecting the mem physically on the card have discovered its Micron. That's where the positives end and unable to locate the correct 'Micron' flash - now having tried all on the standard page seems I'm missing something here.

Card is an MSI RX570 8GB OC Model (not sure about this 'MK2' stuff)
  • S/N:602-V341-1110B1801033667
  • Radeon RX 570 ARMOUR 8GB OC
  • Above the PCI connector is labelled 'V341 VER:2.2'
  • S/N: on the rear of the back = 'S/N2:I5DH034592 1350'
  • White outers around the fans
  • No damage and card is mint condition overall with no obvious issues
  • Fans spin, GPU-Z detects and can flash using CLI ambvbflash
  • Inspected the mem on the card and has the Micron logo
The flashes attempted so far being the usual listed ones for Micron but willing to give anything a shot - any help really appreciated, in the current climate GPU's hard to come by and seeing as this was 'too good a deal' to miss took the plunge... seems the previous owner knew this too.
 
Joined
Oct 22, 2014
Messages
11,682 (4.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit

Thelurker

New Member
Joined
Mar 31, 2021
Messages
2 (0.12/day)
Thanks, I did not find this one whilst searching - the colour of the image is correct for the fan shroud (not sure if this has any relevance) but will try this! thanks!
:)

@Caring1 - windows booted this time using the onboard mobo IGFX and even looked like the driver was loaded Detected as RX570 which is positive, fans stopped spinning then hard crash. repeated attempts do not want to install the driver.

Perhaps a different BIOS or there is another problem with the card?
 
Joined
Mar 21, 2021
Messages
34 (1.26/day)

its the second one in the list... ????
first one is mk2 (probably relaunched in china) should also work, may need forced flashed.
 
Joined
Oct 22, 2014
Messages
11,682 (4.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit

its the second one in the list... ????
first one is mk2 (probably relaunched in china) should also work, may need forced flashed.
No, Mk 2 is the later version, the red trim on the shroud makes it obvious which is which.
 
Top