1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

BSOD when I change fan speed?

Discussion in 'AMD / ATI' started by Yo_Wattup, Jun 4, 2012.

  1. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Just got another 6950 for crossfire, and every time I try and change the fan speed on either one, whether it be in Afterburner or Catalyst control centre, I get a BSOD, usually with stop code 0x3B.

    This would be fine if the fans were on auto, but sometimes theyre stuck at 65%, other times at 27%.

    Anyone had this happen before?


    Thanks
     
  2. Frick

    Frick Fishfaced Nincompoop

    Joined:
    Feb 27, 2006
    Messages:
    14,145 (3.45/day)
    Thanks Received:
    4,979
    Have you updated/reinstalled the drivers?
     
    10 Year Member at TPU
  3. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Yep
     
  4. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    41,984 (10.60/day)
    Thanks Received:
    17,799
    Last edited: Jun 4, 2012
    Yo_Wattup says thanks.
    10 Year Member at TPU
  5. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Thanks erocker, I'll check it out when I get home from work. So you think it might be MSI AB? Now that I have 2x 6950s, I no longer need to overclock... so I guess its not necessary... I did like the OSD though.
     
  6. manofthem

    manofthem WCG-TPU Team All-Star!

    Joined:
    Jan 9, 2011
    Messages:
    10,544 (4.53/day)
    Thanks Received:
    25,251
    Location:
    Florida
    This happened with my 6950 cfx in Afterburner to me also, I couldn't save any changed setting without it crashing. I had to disable ULPS in registry to get rid of the bsods.
     
    fullinfusion and Yo_Wattup say thanks.
    Crunching for Team TPU
  7. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Cool, got a how-to link? :D
     
  8. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    41,984 (10.60/day)
    Thanks Received:
    17,799
    Yes, it could be.

    Run command-> Type: regedit.

    Hit: Ctrl+F-> Type: ULPS

    There will be two or more folders marked "00001, etc." within those folders there will be an entry named "EnableUlps". Change the value from 1 to 0 in each of those numbered folders where "EnableUlps" is present.

    *Leave "EnableUlps N/A" alone.

    Restart your computer. :toast:
     
    Yo_Wattup says thanks.
    10 Year Member at TPU
  9. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    So what is ulps exactly? You sure I won't need it?
     
  10. manofthem

    manofthem WCG-TPU Team All-Star!

    Joined:
    Jan 9, 2011
    Messages:
    10,544 (4.53/day)
    Thanks Received:
    25,251
    Location:
    Florida
    I think it stands for ultra low power saving or something like that. Disabling won'rt hurt anything other than perhaps the second card using more power when idle...

    That said, i had to do that for a while with my cfx setups, 6950s then 7970s, although I only have 1 7970 running right now. Other have reported that disabling ulps was necessary to get stability in some games, and I found it necessary in order to over clock and change fan settings.

    edit: did you try it out yet to see if it changed your bsods?
     
    Crunching for Team TPU
  11. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    9,257 (2.71/day)
    Thanks Received:
    3,073
    Location:
    Manitoba
    Had the exact same problem on my 6990, Just had to disable the ULPS after messing around with the different options in the CFG file.
     
  12. manofthem

    manofthem WCG-TPU Team All-Star!

    Joined:
    Jan 9, 2011
    Messages:
    10,544 (4.53/day)
    Thanks Received:
    25,251
    Location:
    Florida
    Did it affect your gaming or running of the card, or was it only changing settings and overclocking? I don't recall if it affected my games...don't think it did, but I remember I couldn't apply a fan setting in AB. I couldn't even increase a clock by 1 without a crash/bsod
     
    Crunching for Team TPU
  13. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Nah I'm still at work, will try it asap
     
  14. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    789 (0.41/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Okay for the third time I'll try posting this post... :laugh:

    Disabling ulps in the registry seemed to do the trick nicely, no more blue screens and what's better, the default fan speed is my fan profile I made in MSI AB, which is good because the stock fan profile let's the cards get to about 80-90C before it actually does anything. :rolleyes:

    So thanks to everyone who helped, and erocker, I will definately use that guide for the next time I update/reinstall drivers. :D
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)