• We've upgraded our forums. Please post any issues/requests in this thread.

Calibration of RealTemp with Xeon E5430

Natulo

New Member
Joined
Oct 8, 2016
Messages
2 (0.00/day)
Likes
0
#1
Hello everyone,

I recently got a Xeon E5430 Quadcore but now the motherboard is reading strange temperatures.
The bios was modded and the CPU is correctly recognized.

The TJMax for E54xx Xeons should be 85°C, according to this thread.
First thing I was wondering about: The Harpertown Xeons are based on the Yorkfield CPUs (Q8xxx and Q9xxx), why does the TJ Max differ so much?
For the Q8/9 CPUs, it's 100°C.
For the Xeon X33xx it's 95°C.
And for the Xeon E5430 it's 85°C.
I also noticed that the the TDPs are different aswell. Why is that the case?

Anyways, I set the TJ Max in RaelTemp to 85°C but the resulting temperatures are inaccurate.
I tried to follow this guide on calibration but I am not sure how to interpret the results.

I see that this subforum became really quiet in the last few months, but the threads are at least still read by a couple of people.

I tried to get the CPU Voltage as close to 1.1V in idle as I could, CPU multiplier was set to 6x and EIST turned off.
Most of the time the Voltage remained at 1.104V, sometimes it jumped up to 1.168V for a moment, not sure why. I can't really "fix" it, since I am only able to give an offset to VID in the bios.
CPU Cooler is a Scythe Ninja 2 (not sure if original or Rev.B.)



temptest1.JPG
This is the "Idle" result with a TJ Max set to 85°C. A cheap thermometer shows an ambient temperature of 22°C in my room. (+-1°C, not sure how accurate it is)
The Mainboard is sitting on the table without a case. A few strange things to notice here:

1) Core Temp still shows the 8x multiplier, since you can't change the TJ Max for that program, I gave each core an Offset of -15°C to match the 85°C TJ Max.
2) RealTemp still shows the 333*8 Clock, although the Multiplier is set to 6. The FSB is read incorrect. (444.44*6)
3) The most important part, the temperatures are below ambient and uneven across the cores.

temptest2.JPG
Beginning the Heatup Phase of the integrated Sensor Test. Why does the Task manager show 100% load, but RealTemp only shows 75%?

temptest3.JPG
Test completed. Distance between Core #1 and the others ranges between 6-7K. At least no sensor seems to get stuck.

I checked the applied thermal compound between the IHS and the Cooler twice and I hope that I got it right.
Not sure what to do about the temperatures though. I see that they are too low, but how exactly do I have to adjust them?
The guide speaks about an offset of 7-9K, depending on the CPU Cooler. And what causes that one core to be so much off compared to the other cores?


Help would be appreciated. Thank you very much. :)
 

Natulo

New Member
Joined
Oct 8, 2016
Messages
2 (0.00/day)
Likes
0
#2
One small update:
The pictures in the post above were taken with a fixed multiplier and a minor increased CPU Voltage to match the calibration process.

Since the shown FSB and multipliers looked strange, I checked the behaviour on Auto settings with EIST turned off and fixed multipliers. The load was caused with Prime Small FFTs.


First, the 6x Multiplier:

Idle:
6xIdle.JPG

Load:
6xLoad.JPG

As you can see and pointed out in the pictures, this time around everything seems to be alright, the only strange thing is that Core Temp didn't recognise the lowered multiplier.



Then, the 7x Multiplier:

Idle:
7xIdle.JPG

Load:
7xLoad.JPG

Here we see the first interesting things.
Core Temp still doesn't recognise the lowered Multiplier, although in Idle the multiplier was lowered, but instead of setting it to 7, it was set to 7.5.
For RealTemp we see that neither in Idle nor under Load the shown Clock matches the set clock.
In Idle, the Multiplier was pendling between 6.6 and 7, maybe even 6.5 aswell for a split second. (And with 357MHz * 6.5 that would have been the 2333MHz)
Not sure how to explain the 2500MHz though, the shown FSB stayed at 357.14. Looks like the program adjusts the FSB to hit some specific value with the multiplier, in one earlier test it tried to reach 2666MHz, although I set the Multiplier to 6x and thus showed a FSB of 444.


Then, the 7.5x Multiplier:

Idle:
7.5xIdle.JPG

Load:
7.5xLoad.JPG

In Idle, Core Temp keeps jumping between a multiplier of 7.5 and 8.
RealTemp seems alright, but the multiplier is pending between 7.1 and 7.5.

Then, the 8x Multiplier:

Idle:
8xIdle.JPG

Load:
8xLoad.JPG

Core Temp is jumping between 7.5 and 8 once again.
RealTemp shows similar behaviour as with the 7.5 Multiplier, but the FSB was changed to match 2500MHz.
Not sure why it does this though.

Afterwards I set the Multiplier to 8 again and activated EIST.

Here is one run of SuperPi:
SuperPi.JPG

And I will edit a "test run" as above with 8x Multiplier and EIST enabled in a few minutes.

Edit:
Seems to be alright, nothing unusual at 8x Multiplier with EIST enabled.
Not sure what's causing this, but it's just a minor problem since it doesn't seem to appear during regular settings.
 
Last edited:
Joined
Apr 30, 2006
Messages
1,165 (0.27/day)
Likes
433
Processor 7900
Motherboard Rampage Apex
Cooling H115i
Memory 64GB TridentZ 3200 14-14-14-34-1T
Video Card(s) Fury X
Case Corsair 740
Audio Device(s) 8ch LPCM via HDMI to Yamaha Z7 Receiver
Power Supply Corsair AX860
Mouse G903
Keyboard G810
Software 8.1 x64
#3
What exactly is the problem?

Core temp just reads the multiplier and frequency from somewhere so dont expect it to be accurate if you are manually changing it.

Also temps sensors are only close to accurate at load and it looks like the tjmax might not be set right since you are getting very low temps. Its also normal for some cores to run hotter then others,