1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Cant get my 2 x ASUS EAH4870's to Crossfire

Discussion in 'Graphics Cards' started by PostGhosties, Jul 14, 2009.

  1. PostGhosties New Member

    Joined:
    Jul 14, 2009
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    Hi there, i have spent hours trying to get my two ASUS EAH4870/HTDI/512M/A cards to Crossfire and i cant get it right. I have connected them with one ATI CrossFire bridge.

    I have the ASUS Rampage Extreme motherboard with the latest BIOS update available on the ASUS website. (Rampage Extreme 1202 Bios - 2009/06/24 update)

    My 2 EAH4870 cards still have the same BIOS version with what they came out with because I can't find any updates for the BIOS.

    I have installed the latest drivers on the ATI website. (9-6_vista64_win7_64_dd_ccc_wdm_enu)


    The problem I have is simply that when I open the ATI Catalyst Control Center, there is no "Crossfire" option, so I cant manually enable it.
    In the Information Center under "Graphics Hardware" option in CCC it gives me the following:

    Primary Adapter
    Graphics Card Manufacturer Powered by ATI
    Graphics Chipset ATI Radeon HD 4800 Series
    Device ID 9440
    Vendor 1002

    Subsystem ID 01FC
    Subsystem Vendor ID 1043

    Graphics Bus Capability PCI Express 2.0
    Maximum Bus Setting PCI Express 2.0 x16

    BIOS Version 011.007.000.000
    BIOS Part Number 113-AB67800-102
    BIOS Date 2008/08/12

    Memory Size 2303 MB
    Memory Type HyperMemory

    Core Clock in MHz 750 MHz
    Memory Clock in MHz 900 MHz


    Disabled Adapter
    Graphics Card Manufacturer Powered by ATI
    Graphics Chipset ATI Radeon HD 4800 Series
    Device ID 9440
    Vendor 1002

    Subsystem ID 01FC
    Subsystem Vendor ID 1043

    Graphics Bus Capability PCI Express 2.0
    Maximum Bus Setting PCI Express 2.0 x16

    BIOS Version 011.007.000.000
    BIOS Part Number 113-AB67800-102
    BIOS Date 2008/08/12

    Memory Size 2303 MB
    Memory Type HyperMemory

    Core Clock in MHz 750 MHz
    Memory Clock in MHz 900 MHz


    In device manager it says that both devices are working properly and i do not get any "Error 43" code that some people get. I have searched on the ATI forums for help but no luck. If anyone has ever got it right to Crossfire these two cards please let me know what i am doing wrong.
     
  2. twicksisted

    twicksisted

    Joined:
    Oct 4, 2007
    Messages:
    2,439 (0.73/day)
    Thanks Received:
    353
  3. PostGhosties New Member

    Joined:
    Jul 14, 2009
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    Thanx for the link, it cleared up some issues for me but I still can't Crossfire.

    I started following his steps, removed my 9.6 drivers and ran CCleaner to remove registry enties and all that, deleted all the folders containing "ATI", uninstalled the card in device manager and rebooted. I installed the 8.8 CCC drivers, apparently people got their setup to work with that version, but after I rebooted an error message came up saying that my graphics card driver was not found or the driver isn't installed properly. So i done it again, same story. Then i removed everything again and installed 9.6 drivers again, rebooted and my card was installed. I then installed the other 4870 into my pc and booted to windows. The card was instaled in device manager with the exact same driver version as the 1st card and it said that the device is working properly. I turned the PC off and then installed the Crossfire bridge and booted to windows. Still no Crossfire option in CCC and it is still saying that my second card is "Disabled Adapter"

    Anyone else out there running 2 x ASUS EAH4870/HTDI/512M/A's ?
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)