1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Changing boot time clocks for a Mobility Radeon HD 3650

Discussion in 'RBE' started by ilyes, Nov 1, 2008.

  1. ilyes New Member

    Joined:
    Nov 1, 2008
    Messages:
    4 (0.00/day)
    Thanks Received:
    0
    Hi all,

    I have recently acquired a new Toshiba Satellite A300 that comes with a Core 2 Duo T8100 and a (Mobility) Radeon 3650 HD. Here is the spec. as retrieved using GPU-Z (0.2.8)

    [​IMG]

    Now, my problem is that I use Linux for my day to day work and there is no graphics (and power management) driver for my radeon 3650 and basically what happens is that the fan (which cools the GPU and the CPU) doesn't stop spinning at all. My system gets noisy, hot and it just doesn't feel comfortable to use. I went back to Vista where the fan works properly (that's starts and stops periodically) and I found out that what controls the fan is the GPU driver, that's Catalyst.

    I downloaded RBE, dumped the bios and found out that there is table with a set of clocks for every power management policy and I discovered that at boot time, my GPU frequency is about 600 MHz, the GPU RAM is at 500 MHz and the Vcore is at 1.1v, which are the maximum settings for my card. Now, I'd like to change those settings to the minimum so that when Linux boots up, it will inherit those values and thus the GPU will run cool. I don't need the extra 2D or 3D performance under Linux for the moment and I think that's what really I need from my laptop.

    So, I went ahead, loaded the original bios and altered the default boot clocks and saved it to another file. Now before actually flashing it, I'd like to have a feedback from you guys, to know if it's OK to proceed (or not). This is the first time I do this and I feel like it's a bit risky. :) Any ideas?

    Regards,
    Ilyes Gouta.
     
  2. VuurVOS

    Joined:
    Mar 20, 2008
    Messages:
    307 (0.09/day)
    Thanks Received:
    75
    Could you post the new boot values? If you lowered it too much, it can cause a system which can not boot. The saftest way is to lower the clocks under windows and see what the lowest possible speed is. If you add some safety space. For example 10% above the lowest posible speed without arctifacts, the chances are high the card will be boot stable. But keep in mind the Catalyst drivers doesn't like alterd boot clocks.
     
  3. ilyes New Member

    Joined:
    Nov 1, 2008
    Messages:
    4 (0.00/day)
    Thanks Received:
    0
    Hi,

    Thanks for your answer.

    The original values are (for the boot mode):
    GPU: 600 MHz
    GPU RAM: 500 MHz
    Voltage: 1.1V

    I intend to change those to the same values for the next mode, that's "Power saving for notebooks in battery mode, High performance, Optimal performance":
    GPU: 110 MHz
    GPU RAM: 400 MHz
    Voltage: 0.9V

    As I mentioned, I didn't "invent" these values :) , these are the same as another PowerPlay mode. My card supports (at least what RBE reports) only two voltages: 1.1V and 0.9V and my goal is to reduce the power consumption and mostly heating (I want to keep my laptop cool). I read in the RBE tutorial that reducing the GPU RAM clock isn't efficient.

    I diffed the original bios and the modified (RBE generated) bios and I found that the differences are the checksum and then 8 bytes in the middle of the file where the different clock values are stored (I decoded them and they look OK).

    My question guys is very simple: Should the boot clock values be set to the maximum values (or not) at the boot time? Is there such a constraint? If I manipulate those values, is there a risk that my card won't post/boot?

    Regards,
    Ilyes Gouta.
     
  4. Fastmix

    Fastmix New Member

    Joined:
    Aug 5, 2008
    Messages:
    627 (0.19/day)
    Thanks Received:
    115
    Location:
    The Kingdom of Heaven
    As far as I know, you need the default clock on the boot field, then you can lowered the way you want it, the problem is......if you card doesn't boot at that clock...how are you going to be able to flash it back, it's not like a desktop that you can plug a pci card and flash it back, so I would be really carefull with those settings.

    I would look for better driver support or a third party app.

    In regards to the fan, you can use the fan table..it works rather well...if you need some example values, just download one of the bioses attched to my signature and take a look.
     
    Last edited: Nov 1, 2008
  5. VuurVOS

    Joined:
    Mar 20, 2008
    Messages:
    307 (0.09/day)
    Thanks Received:
    75
    I lowered my boot clocks of my old HD3870 once too much. The problem I got was the drivers didn't recognized it anymore. The card was still bootable but I don't recommend it :)
     
  6. ilyes New Member

    Joined:
    Nov 1, 2008
    Messages:
    4 (0.00/day)
    Thanks Received:
    0
    Hi,

    Fastmix, I'm using Linux and there is no such driver for the radeon 3650 HD for X11. There is an experimental driver called radeonhd which just implements the basic chip initialization and framebuffer setup but still no 2D and 3D acceleration and more importantly, no power management support (i.e, PowerPlay). Alright, so Fastmix, you're saying that it's risky and thus I'm going to back-off. I'll wait for the open source driver to mature, however, this means no full support for Linux on my laptop.

    Any other comments?

    Regards,
    Ilyes Gouta.
     
  7. ilyes New Member

    Joined:
    Nov 1, 2008
    Messages:
    4 (0.00/day)
    Thanks Received:
    0
    VuurVOS, so even with the modified boot clocks, your card continued to function properly? Is it a desktop gfx card or for a laptop?

    Regards,
    Ilyes Gouta.
     
  8. VuurVOS

    Joined:
    Mar 20, 2008
    Messages:
    307 (0.09/day)
    Thanks Received:
    75
    Its a Desktop gfx card. This doesn't mean it will work on other models as well
     
    Last edited: Nov 1, 2008

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)