• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

CMMS 3D with AE-7

Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
Hi everybody,

a few days ago I switched from my X-Fi Titanium to an AE-7 soundblaster. Mostly because I wanted a better basis for my DT770 250Ohm and DT990 600Ohm headphones. Now I miss the CMMS 3D functionality when I'm hearing music on my 5.1 system. It was so nice to get the rear speakers playing the same as the front speakers. Is there a work around or some third party drivers like Daniel K.?

Best regards from Germany!
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
Found the solution, reddit...

Copy Paste:
By accident I actually found a solution for this problem:
Since Windows Vista, Microsoft implemented so called Audio Processing Objects (APO, more info here). The program Equalizer APO allows you to process your audio on software side. The most noticable feature is the equalizer I guess. However, with just a couple of lines of code I can add the functionality of mirroring the sound to the rear speakers and get a mix in the center speaker. All you have to do is add the following to the config.cfg in the installation folder:
Stage: pre-mix
If: inputChannelCount == 2
Copy: 3=0.5*1+0.5*2 5=1 6=2
EndIf:

Should be pretty much self-explanatory, but it checks whether there is a stereo signal (inputChannelCount == 2) and then copies a 50:50-mixture of left and right to channel 3 (center, 3=0.5*1+0.5*2) and mirrors left and right front channels to rear channels (5=1 6=2).
With this I have the same functionality as the old Stereo-Surround mode for stereo signals and real 5.1 signals are unprocessed and work as intended. I really wonder why I haven't found anything about Equalizer APO during my hours of search for a solution and find it while searching for something completely different...
Edit: Beware, when testing the channels with the Sound Blaster Command it does not seem to work. But when using the Windows built-in speaker test, it does work as well as any application.

---------------

Download and install Equalizer APO. Within the Folder (Programs) there's an Editor.exe. Open it, delete all existing filters, clicking on + -> simple filters -> copy (between channels) creates a new filter. Click on the edit-symbol and type:

Stage: pre-mix
If: inputChannelCount == 2
Copy: 3=0.5*1+0.5*2 5=1 6=2

You're finished, and it can be turned on / off again if needed.

Greetings from Germany
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
6,484 (1.11/day)
Location
Canuck in Norway
System Name Hellbox 4.0(same case new guts)
Processor Ryzen 7 3700X
Motherboard Gigabyte Auros X570 Pro
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua
Memory 2x8GB Corsair Vengeance RGB Pro 3600@CL16
Video Card(s) Sapphire 5700XT Nitro+
Storage 970 Evo Plus 500GB WD Caviar Black SATA 3 1TB x2 RAID1 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue
Display(s) Samsung CGH70 27” 1440 144hz Freesync 2 HDR
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic X-1050W 80+ Gold
Mouse G502 Proteus Spectrum
Keyboard G19s
Software Win 10 Pro x64
you use sbx surround set to 67% and set speakers to 5.1 this will do the trick.
Yeah not looking in my SB ZX control panel but certainly remembering CMSS on my X-Fi there would definitely be setting available that would replace it without having to resort to complicated reg hacks etc.
Yep just checked. Just tick the Surround box and adjust the slider to taste. Surely the AE-7 would have similar features or better available I’ve still got Crystallizer apparently that feature hasn’t died....
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
Absolutely not the same. The surround settings in the AE-7 software sounds like DTS:NEO or so. It is no mirroring from front to rear.

If it were so easy as you say, why are there so many complaints about that issue?
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
6,484 (1.11/day)
Location
Canuck in Norway
System Name Hellbox 4.0(same case new guts)
Processor Ryzen 7 3700X
Motherboard Gigabyte Auros X570 Pro
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua
Memory 2x8GB Corsair Vengeance RGB Pro 3600@CL16
Video Card(s) Sapphire 5700XT Nitro+
Storage 970 Evo Plus 500GB WD Caviar Black SATA 3 1TB x2 RAID1 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue
Display(s) Samsung CGH70 27” 1440 144hz Freesync 2 HDR
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic X-1050W 80+ Gold
Mouse G502 Proteus Spectrum
Keyboard G19s
Software Win 10 Pro x64
Absolutely not the same. The surround settings in the AE-7 software sounds like DTS:NEO or so. It is no mirroring from front to rear.

If it were so easy as you say, why are there so many complaints about that issue?
I’m not a fan of DSPs period and run my card pure analog 5.1 always have back to theX-Fi if not the Audigy 2 I figure. I thought CMSS was terrible if you want to compare it the popular DSPs surely your superior AE-7 has something better than my ZXs surround option than to go back seeking CMSS... I literally turn everything off n every;SB I‘ve owned. Your source and the card should be handling what you hear and how not some terrible “canned effect“
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
And this "canned effect" is what the surround option within the Soundblaster Softwaresuite does. It sounds terrible.

CMSS 3D hast two options, and one is the mirroring of stereo signal to the rear speakers. The AE-5/7/9s are missing this feature. Mirroring is not the same as some pseudo surround.

The solution described above has been figured out by somebody else. I testet it and it works fine.
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
6,484 (1.11/day)
Location
Canuck in Norway
System Name Hellbox 4.0(same case new guts)
Processor Ryzen 7 3700X
Motherboard Gigabyte Auros X570 Pro
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua
Memory 2x8GB Corsair Vengeance RGB Pro 3600@CL16
Video Card(s) Sapphire 5700XT Nitro+
Storage 970 Evo Plus 500GB WD Caviar Black SATA 3 1TB x2 RAID1 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue
Display(s) Samsung CGH70 27” 1440 144hz Freesync 2 HDR
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic X-1050W 80+ Gold
Mouse G502 Proteus Spectrum
Keyboard G19s
Software Win 10 Pro x64
And this "canned effect" is what the surround option within the Soundblaster Softwaresuite does. It sounds terrible.

CMSS 3D hast two options, and one is the mirroring of stereo signal to the rear speakers. The AE-5/7/9s are missing this feature. Mirroring is not the same as some pseudo surround.

The solution described above has been figured out by somebody else. I testet it and it works fine.
Whatever floats your boat Music is in Stereo. It’s still faked. Now if fire up a game next it’s not in 5.1 then Im gonna have an issue. That said in almost 15 years of gaming in 5.1 only one game comes to mind that did have 5.1 support nor have I ever ha$ to use a DSP in any game at most just had to select my correct output.
Now don’t get me wrong my Home Theatre does all the modern lossless surrounds barring ATMOS so I use them where appropriate. .
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
6,484 (1.11/day)
Location
Canuck in Norway
System Name Hellbox 4.0(same case new guts)
Processor Ryzen 7 3700X
Motherboard Gigabyte Auros X570 Pro
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua
Memory 2x8GB Corsair Vengeance RGB Pro 3600@CL16
Video Card(s) Sapphire 5700XT Nitro+
Storage 970 Evo Plus 500GB WD Caviar Black SATA 3 1TB x2 RAID1 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue
Display(s) Samsung CGH70 27” 1440 144hz Freesync 2 HDR
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic X-1050W 80+ Gold
Mouse G502 Proteus Spectrum
Keyboard G19s
Software Win 10 Pro x64
Don’t know what that is or it’s purpose! ? I will admit to using the Classical Eq on my ZX for a bit better top and bottom definition. my Z906 are only one way, single drivers
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
The game will play in 5.1 because this solution starts with "If:inputChannelCount == 2''.

The picture illustrates how it works, the EQ is not used.
 

INSTG8R

Vanguard Beta Tester
Joined
Nov 26, 2004
Messages
6,484 (1.11/day)
Location
Canuck in Norway
System Name Hellbox 4.0(same case new guts)
Processor Ryzen 7 3700X
Motherboard Gigabyte Auros X570 Pro
Cooling TT Kandalf L.C.S.(Water/Air)EK Velocity CPU Block/Noctua
Memory 2x8GB Corsair Vengeance RGB Pro 3600@CL16
Video Card(s) Sapphire 5700XT Nitro+
Storage 970 Evo Plus 500GB WD Caviar Black SATA 3 1TB x2 RAID1 2xSamsung 850 Evo 500GB RAID 0 1TB WD Blue
Display(s) Samsung CGH70 27” 1440 144hz Freesync 2 HDR
Case TT Kandalf L.C.S.
Audio Device(s) Soundblaster ZX/Logitech Z906 5.1
Power Supply Seasonic X-1050W 80+ Gold
Mouse G502 Proteus Spectrum
Keyboard G19s
Software Win 10 Pro x64
Not sure what point your trying to make its just 2 channel source and whatever your using to convert it to 5.1.My whole point is you shouldn‘t have to rely on anything than matching the sources options with your own. Obviously if I leave it on Headphones all I’m gonna get is stereo. In fact my ZX has a dedicated headphone Jack Windows doesn’t see and unless I go into Windows sound properties and manually set it to stereo it sill trying to do some form of simulated surround if you run the speaker test....
 

dcGColts

New Member
Joined
Mar 7, 2020
Messages
7 (0.03/day)
Absolutely not the same. The surround settings in the AE-7 software sounds like DTS:NEO or so. It is no mirroring from front to rear.

If it were so easy as you say, why are there so many complaints about that issue?
Not for me it's exactly same only way it isn't is if sbx surround is not set to proper 67% or windows is not set to 5.1 or if I use direct mode. DTS NEO is trash how are you plugging in your speakers? I went from xfi titanium HD to ae-5 to now ae-7 I know exactly what you mean because if it wasn't working the same it would annoy me especially when listening to music. I am using Logitech z906 5.1 through toslink.
 
Joined
Aug 12, 2020
Messages
11 (0.10/day)
Location
Germany
System Name Spirit
Processor i9-9900k@5GHz
Motherboard ASUS Maximus Hero XI (WiFi)
Cooling Thermalright Macho Le Grand RT
Memory G.Skill Trident Z RGB 3600MHz CL14 2x8GB
Video Card(s) ASUS GTX 1080 ti @ 2GHz @ Morpheus II @ NB eLoops
Storage WD Black SN750 500GB / WD Blue M.2 2TB / WD Blue 4TB (external) / NAS (2x WD RED 4TB@Raid0)
Display(s) Dell S2716DG / LG C9 55"
Case Be Quiet! Dark Base 700 with 4x Silent Wing 3 140mm PWM
Audio Device(s) Creative AE-7 @Toslink / DT770 pro 250ohm / Kenwood 6400D / Teufel Kompakt 30 5.1
Power Supply Be Quiet! Dark Power Pro 11 850W
Mouse Steelseries Rival 500
Keyboard Steelseries Apex 7 brown switches
Software Win10 Pro
I'm using a Teufel 5.1 system connected to a Kenwood 6400D which is connected to the AE-7 via Toslink. The difference is very clear to hear, I can test it with the SBX 67% setting vs. the solution I described above, and the SBX 67% makes not a mirroring of the front speakers to the rear speakers, it's some kind of mixing, especially to the center speaker. I wish you could be here to hear it. On the other hand, the solution is done in under 5 minutes if you want to check it out:

Download and install Equalizer APO. Within the Folder (Programs) there's an Editor.exe. Open it, delete all existing filters, clicking on + -> simple filters -> copy (between channels) creates a new filter. Click on the edit-symbol and type:

Stage: pre-mix
Copy: 3=0.5*1+0.5*2 5=1 6=2

You're finished, and it can be turned on / off again if needed.
 
Last edited:

dcGColts

New Member
Joined
Mar 7, 2020
Messages
7 (0.03/day)
It's mixing the music to 5.1 surround. The other way you describe is Multi-Channel Stereo.
 
Top