• We've upgraded our forums. Please post any issues/requests in this thread.

COD4 Prob - Weapon won't stop firing.

infrared

Moderator
Staff member
Joined
May 28, 2005
Messages
4,241 (0.92/day)
Likes
1,859
Location
Southampton, UK
System Name Raisin
Processor Ryzen 7 1800X (binned silicon lottery chip, good for 4.2GHz)
Motherboard Asus Crosshair VI Hero - bios 1401
Cooling 240mm rad with corsair ML fans, EK D5 pump/res, XSPC raystorm pro, lapped.
Memory G.Skill TridentZ DDR4-4266 16GB @ 3466MHz CL14
Video Card(s) EVGA 1080Ti FE - waterblock pending.
Storage Samsung 960 Evo 500GB + Corsair 120GB ssd (linux)
Display(s) Asus ROG Swift PG278QR 165hz 1440P
Case Lian Li test bench (can't decide on a case!)
Power Supply EVGA Supernova 750W G3
Mouse Logitech G602
Keyboard Cherry MX Board 6.0
Software Win 10 & Linux Mint 18.1
#1
Hey,

Just wandering if anyone is having the same prob, and maybe found a fix. I've done lots of searching, but can't seem to find anything.

The problem is if i'm firing a weapon, and i release both left and right mouse buttons at the same time, the gun will continue to fire until i click again. One example, i fired an rpg at the heli, and quickly hid around a corner, and it fired a second one by itself and blew me up! :banghead:

Another thing, but i don't think it's related. Sometimes i will spawn and not be able to move until i click a mouse button.
 
Joined
Jun 5, 2005
Messages
4,640 (1.01/day)
Likes
415
Location
Toronto, Canada
System Name old school / new school
Processor 3.0e C0 @ 3.6 / e5200
Motherboard p4p800e-dlx / p5q-DLX
Cooling custom water see sig / air
Memory 2x1g oczPC4000EbPl / 2x2g ocz2rpr1066
Video Card(s) 3850AGP / 4890vaporX
Storage 36g raptor+120g wd / wd 1001fals 1tb
Display(s) BenQ / sharpAQUOS LC-37D64U
Case modded antec plusview / generic
Audio Device(s) audigy 2zs / ASUS Xonar HDAV1.3
Power Supply fan/cable modded powerstream 520 / OCZ 700mxsp
Software Xp pro SP2 / VISTA ultimate OEM
#2
sounds like a mouse problem
 

infrared

Moderator
Staff member
Joined
May 28, 2005
Messages
4,241 (0.92/day)
Likes
1,859
Location
Southampton, UK
System Name Raisin
Processor Ryzen 7 1800X (binned silicon lottery chip, good for 4.2GHz)
Motherboard Asus Crosshair VI Hero - bios 1401
Cooling 240mm rad with corsair ML fans, EK D5 pump/res, XSPC raystorm pro, lapped.
Memory G.Skill TridentZ DDR4-4266 16GB @ 3466MHz CL14
Video Card(s) EVGA 1080Ti FE - waterblock pending.
Storage Samsung 960 Evo 500GB + Corsair 120GB ssd (linux)
Display(s) Asus ROG Swift PG278QR 165hz 1440P
Case Lian Li test bench (can't decide on a case!)
Power Supply EVGA Supernova 750W G3
Mouse Logitech G602
Keyboard Cherry MX Board 6.0
Software Win 10 & Linux Mint 18.1
#3
Possibly. It's the Saitek Gaming mouse. Might try installing the software/drivers for it and see if that helps.
 
Joined
Jun 5, 2005
Messages
4,640 (1.01/day)
Likes
415
Location
Toronto, Canada
System Name old school / new school
Processor 3.0e C0 @ 3.6 / e5200
Motherboard p4p800e-dlx / p5q-DLX
Cooling custom water see sig / air
Memory 2x1g oczPC4000EbPl / 2x2g ocz2rpr1066
Video Card(s) 3850AGP / 4890vaporX
Storage 36g raptor+120g wd / wd 1001fals 1tb
Display(s) BenQ / sharpAQUOS LC-37D64U
Case modded antec plusview / generic
Audio Device(s) audigy 2zs / ASUS Xonar HDAV1.3
Power Supply fan/cable modded powerstream 520 / OCZ 700mxsp
Software Xp pro SP2 / VISTA ultimate OEM
#4
Possibly. It's the Saitek Gaming mouse. Might try installing the software/drivers for it and see if that helps.
give it a go, hopefully that fixes the problem. if not do you have an extra mouse laying around you can test with?
 
Joined
Mar 27, 2008
Messages
697 (0.20/day)
Likes
70
Location
Zagreb, Croatia
Processor C2D E8400@3.9GHz (488x8, 1.4v :( )
Motherboard Abit IP35-E
Cooling Thermaltake Sonic Tower+120mm fan
Memory 2GB kingmax ddr1066@976MHz 5-5-5-15
Video Card(s) Radeon X1800GTO @700/1400MHz with Accelero S1+Glacialtech fancard
Storage 2xSeagate Barracuda 7200.10 160GB
Display(s) Samsung SyncMaster 793s... just you laugh...
Case some Aplus case
Audio Device(s) Realtek ALC888
Power Supply Chieftec 450W
Software Win7 x64
#5
:roll::roll::roll:

When I read this I was like wtf! :wtf:

Anyways, if I remember correctly, it happened to me in COD2, on LANparty we had once though...