• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Computer wont boot - no monitor display, no beeps, no keyboard lighting

Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#1
Strange. So here is the setup:

Asrock Z87E itx mobo
Core i7 4790
12gb ram
600W Silverstone PSU
GTX 1070

So I connect it all outside of the case since case is coming in still.

Connected everything.

Turn on, nothing. Spins up, but no beep, no nothing.

Try different PSU

Same thing.

Tried different Ram

Same thing.

Tried without GPU and use onboard.

Same thing.

Tried with no ram to see if anything?

Same thing.


So do you guys suspect is the Mobo? If the CPU was bad, would it still not at least try to go to bios?

Got it used from Netherlands from Ebay (mobo). It looks brand new but they are apparently refurbished.
 
Joined
Nov 28, 2012
Messages
1,316 (0.60/day)
Likes
475
System Name N/A
Processor I3 3.5GHZ (3150)
Motherboard ASRock B85M-ITX
Cooling stock
Memory 8GB
Video Card(s) XFX GTX750Ti 2GB
Storage 1TB WD and 1TB Seagate
Display(s) LG 21.5" LCD IPS
Case CoolerMaster
Audio Device(s) Onboard
Power Supply Rosewill 610WATT
Mouse R.A.T3
Keyboard Razer BlackWidow
Software Windows 10 Pro 64-Bit
#2
Could be the MB. If nothing spins on the fans then I'd say it's the MB. How do you have the MB set up on? Best be on wooden floor or the MB box or just a box. Carpet is a no no
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#3
of course not on carpet.

It was on the desk, which is wood.

Fans spin. Just no beeps or anything.
 
Joined
Mar 18, 2015
Messages
1,127 (0.84/day)
Likes
662
Location
Long Island
#4
1. EPS cable plugged in next to CPU ? See Manual, Item No. 2 page 11

2. RAM installed in correct slots * ... as depicted in manual ? That would be 2 x 4GB ..or 2 x 8GB ..... not 3 x 4Gb (see edit)* or 8GB + 4 GB.

* EDIT:

Link for Manual .... http://asrock.pc.cdn.bitgravity.com/Manual/Z87E-ITX.pdf

Glad I checked ... you only have two slots ... see page 22

3. I don't expect that a board in this price range has troubleshooting LEDs but if so, determine the significance of status.

4. Cleared CMOS ? See Item No. 14 , page 11

5. CPU HS Fan connected to CPU Header ?
 
Last edited:
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#5
I used ram that is working and tested. I tried it with 1 stick in either slot. Nothing.

FYI its an itx mobo, it has only 2 rams slots.
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#6
You could try getting a new, soft toothbrush and some cleaning alcohol (believe it is called isopropahol alcohol) and clean the motherboard. That generally works with old mobos that I have. It cleans dust and thermal paste that could have gotten in the mobo.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,481 (5.65/day)
Likes
7,513
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#7
Strange. So here is the setup:

Asrock Z87E itx mobo
Core i7 4790
12gb ram
600W Silverstone PSU
GTX 1070

So I connect it all outside of the case since case is coming in still.

Connected everything.

Turn on, nothing. Spins up, but no beep, no nothing.

Try different PSU

Same thing.

Tried different Ram

Same thing.

Tried without GPU and use onboard.

Same thing.

Tried with no ram to see if anything?

Same thing.


So do you guys suspect is the Mobo? If the CPU was bad, would it still not at least try to go to bios?

Got it used from Netherlands from Ebay (mobo). It looks brand new but they are apparently refurbished.
Check bios jumper, replace battery, if the same get your money back

You could try getting a new, soft toothbrush and some cleaning alcohol (believe it is called isopropahol alcohol) and clean the motherboard. That generally works with old mobos that I have. It cleans dust and thermal paste that could have gotten in the mobo.
Electronics grade
Contact cleaner
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#8
There is no bios jumper cap. Looking at the info online, it is used to clear cmos if you put jumper on.
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#9
@eidairaman1, I don't know if it is contact cleaner, but it might work. I meant isopropyl alcohol, also electronics grade if it exists there or 90% or above pure.
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#10
motherboard is as clean as a babies bottom.

Contacted seller. He said it was tested with a core i3 cpu and it worked. He thinks its the bios.

Great. I don't have another CPU.
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#11
Can you tell the bios version on your mobo. Sad that I'm in Europe and don't have any 4th gen CPU's or I would try and send one.
 
Joined
Nov 28, 2012
Messages
1,316 (0.60/day)
Likes
475
System Name N/A
Processor I3 3.5GHZ (3150)
Motherboard ASRock B85M-ITX
Cooling stock
Memory 8GB
Video Card(s) XFX GTX750Ti 2GB
Storage 1TB WD and 1TB Seagate
Display(s) LG 21.5" LCD IPS
Case CoolerMaster
Audio Device(s) Onboard
Power Supply Rosewill 610WATT
Mouse R.A.T3
Keyboard Razer BlackWidow
Software Windows 10 Pro 64-Bit
#12
You could just get a cheap cpu off ebay. Guess the bios needs to be updated in order to support the cpu you have.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,481 (5.65/day)
Likes
7,513
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#13
@eidairaman1, I don't know if it is contact cleaner, but it might work. I meant isopropyl alcohol, also electronics grade if it exists there or 90% or above pure.
Ive seen tests on gpus to clean them

motherboard is as clean as a babies bottom.

Contacted seller. He said it was tested with a core i3 cpu and it worked. He thinks its the bios.

Great. I don't have another CPU.
Send it back claiming its not working as advertised
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#14
So a bios could be causing this?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,481 (5.65/day)
Likes
7,513
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#16
No pins are bent. Already verified that.

So a bios could be causing this? I notice latest bios supports for 4790k but mine is a 4790 non K

I already spent $400 for cpu and mobo. God forbid I have to spend more just because of the bios.

God must really hate me right now. Cause I am pissed like you wouldn't imagine.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
23,481 (5.65/day)
Likes
7,513
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#17
No pins are bent. Already verified that.

So a bios could be causing this? I notice latest bios supports for 4790k but mine is a 4790 non K
That is possible because iirc a k ans non k have different clocks

Do you know for fact the cpu is good still and being inswrted right?
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#18
it was apparently tested on fleebay by seller. It is in mint condition too.

I know how to insert a CPU as well, there is a little arrow on it. I verified it twice if I inserted it correctly.

Been building machines for last 15 years and never experienced this one before.

Never buying used components like this again unless I verified it is working before purchase.
 
Joined
Nov 28, 2012
Messages
1,316 (0.60/day)
Likes
475
System Name N/A
Processor I3 3.5GHZ (3150)
Motherboard ASRock B85M-ITX
Cooling stock
Memory 8GB
Video Card(s) XFX GTX750Ti 2GB
Storage 1TB WD and 1TB Seagate
Display(s) LG 21.5" LCD IPS
Case CoolerMaster
Audio Device(s) Onboard
Power Supply Rosewill 610WATT
Mouse R.A.T3
Keyboard Razer BlackWidow
Software Windows 10 Pro 64-Bit
#19
Just because the cpu isn't a K version or not doesn't mean that it's a supported cpu listed prior to the bios version is installed already
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#20
Well, probably is the BIOS. It all points to it. If you can return the board, as many said here, you could probably search for one that supports your CPU. @eidairaman1 I honestly didn't know you could clean components with contact cleaner. Nice, thanks.
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#21
here is the kicker. Seller is in the Netherlands. I am here in Canada.

Best option is now to either spend $150 cad for a dell computer with a core i3 in it or just count my losses and sell the motherboard at discount, same with CPU. And possibly sell a kidney to make up the loss.
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#22
Can't you talk with anybody who owns a 4th gen rig, so that they can help you? Can you ask someone to lend you a early Haswell i3? Spending an extra 150 bucks and calling it quits it's a terrible idea.
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#23
well, no its either spend the $150 or calling it quits.

And no, nobody I know has a Haswell I3.

So I am hoping someone here would be nice enough to sell me one.

I wont be surprised if my wife divorces me at this point for spending too much :p
 
Joined
Jan 27, 2018
Messages
55 (0.19/day)
Likes
15
Location
Sintra, Lisbon
System Name Toshiba C850D-117
Processor AMD "Vision" E1-1200
Motherboard Toshiba Board
Cooling Stock Cooler
Memory 6GB DDR3 SO-DIMM
Video Card(s) AMD Radeon Mobility HD7310
Storage Toshiba 500GB 5400rpm HDD
Display(s) 15.4 in Toshiba Display 1366X768
Audio Device(s) 2X Toshiba Speakers (Really Crap Actually)
Power Supply 65 or 45W Laptop Power Brick
Software Windows 8.1 Home X64
#24
Do you know anyone with any Haswell CPU? Apart from yours, of course.
 
Joined
Sep 28, 2005
Messages
525 (0.11/day)
Likes
272
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Some crappy Silverstone ITX Cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) Sapphire Vega 64
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR
Software Windows 10 64bit Pro
#25
Top