• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Corsair H100i not being recognised by Corsair Link

TehNemes1s

New Member
Joined
Dec 23, 2013
Messages
1 (0.00/day)
First of all, hello everyone, I'm new here and I expect to participate more in the forums from now on.

I recently upgraded my desktop gaming system to accommodate the brand new ASUS ROG Rampage IV Black Edition motherboard. I installed a Intel Core i7 4960X and 32 GB of Memory DDR3, 2 EVGA NVidia GTX Titan in SLI, plus 3 SSD in Raid, all this around a Corsair AX1200 PSU Inside a Corsair Graphite Series 600T. For cooling system I use the case stock fans (2x 200 mm and 1x 120 mm) and for CPU cooling I use the Corsair Hydro Series H100i. OS: Windows 8.1.

When I installed Windows 8 the system was unable to recognize the cooler so Corsair Link can't see it, making impossible to manage fan speed and other features.. Moreover, I can't use Corsair Link to update the firmware or anything else. I've looked for a solution but nothing I've tried works at all. The cooler used to work just fine before I changed the motherboard.

Has anyone been able to fix this?
I Hope someone can help.
 
Joined
Dec 3, 2009
Messages
1,235 (0.31/day)
Location
The Netherlands
System Name PC || Acer Nitro 5
Processor R5 1600 Pinnacle Ridge @ 4,0Ghz || R5 2500U @ 35W
Motherboard B450 I AORUS PRO WIFI || default
Cooling Corsair H100i + frankenstein loop H80i modded onto 290|| Stock
Memory 2x16GB G Skill || 2x8GB DDR4 @ 2400MHz
Video Card(s) AMD R9 290 @ 1050MHz / 1825MHz || RX 560X
Storage Samsung 960 Evo + Tiered Storage Space (128Gb SSD + Striped 2x1TB HDD) || 128GB SSD, 1TB HDD
Display(s) Samsung U28E590 4K & S23A750D 120Hz + others|| 15,6" 1080P IPS @ 100Hz Freesync enabled
Case Corsair 500R Fans Galore ||
Power Supply Corsair AX860i || 135Watt 19V OEM adaptor
Software Win 10 64bit || Win 10 64bit
There is currently no fix for this, and corsair is still working on resolving it. Their next version of the link software should solve this, but its been delayed for quite a while now. Corsair forums should give more detail.
 

newtekie1

Semi-Retired Folder
Joined
Nov 22, 2005
Messages
27,307 (5.03/day)
Location
Indiana, USA
Processor Intel Core i7 9900K@5.0GHz
Motherboard AsRock Z370 Taichi
Cooling Corsair H115i Pro w/ Noctua NF-A14 Fans
Memory 32GB Corsair DDR4-3000
Video Card(s) ASUS Strix GTX 1080Ti
Storage 500GB SX8200 Pro + 8TB with 1TB SSD Cache
Display(s) QNIX QX2710 1440p@120Hz
Case Fractal Design Define S
Audio Device(s) Onboard is good enough for me
Power Supply eVGA SuperNOVA 1000w G3
Software Windows 10 Pro x64
I had the same issue on my P55 board. Eventually I figured out the H100i would not be recognized if I used the internal USB headers. But if I ran a USB cable out to one of the USB ports on the back of the motherboard it worked fine.
 

InnocentCriminal

Resident Grammar Amender
Joined
Feb 21, 2005
Messages
6,477 (1.14/day)
System Name BeeR 6
Processor Intel Core i7 3770K*
Motherboard ASUS Maximus V Gene (1155/Z77)
Cooling Corsair H100i
Memory 16GB Samsung Green 1600MHz DDR3**
Video Card(s) 4GB MSI Gaming X RX480
Storage 256GB Samsung 840 Pro SSD
Display(s) 27" Samsung C27F591FDU
Case Fractal Design Arc Mini
Power Supply Corsair HX750W
Software 64bit Microsoft Windows 10 Pro
Benchmark Scores *@ 4.6GHz **@ 2133MHz
Weirdly I came on TPU this morning to post the supposed fix for this as I'm suffering from it myself...

 
Joined
Apr 5, 2010
Messages
731 (0.19/day)
Location
Israel
System Name PC ?
Processor AMD Ryzen 9 3900X
Motherboard Gigabyte X570 AORUS XTREME
Cooling NZXT Kraken X62
Memory 32gb of G.Skill Trident Z Neo 32GB 3600 / CL16
Video Card(s) EVGA 1080 Ti FTW3 Hybrid
Storage C:/ADATA XPG SX8200 Pro 2TB - D:/7TB of Storage (WD-Bx2) - X:/Samsung 840 EVO 1TB
Display(s) Acer X27
Case Corsair 1000D
Audio Device(s) Topping DX7S + Cambridge Audio CXA60 + Klipsch RP-160M + Klipsch Reference R-112
Power Supply Seasonic PRIME Ultra Titanium 1000TR
Mouse Logitech G900
Keyboard Logitech G Pro Keyboard
Software Windows 10 Pro (64bit)
same problem . x79 tried 3 -4 dif ports and it's worked some months ego....
 
Top