• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Creative Titanium Fatal1ty - mic background noise?

hat

Enthusiast
Joined
Nov 20, 2006
Messages
18,583 (4.55/day)
Likes
3,195
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i5 2400 :: Athlon II x4 630
Motherboard MSI H67-G43-B3 :: GIgabyte GA-770T-USB3
Cooling Corsair H70 :: Thermaltake Big Typhoon
Memory 4x2GB DDR3 1333 :: 2x1GB DDR3 1333
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Plextor M5s 128GB, WDC Black 500GB :: Mushkin Enhanced 60GB SSD, WD RE3 1TB
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) X-Fi Titanium Fatal1ty Pro - iLive IT153B Soundbar (optical) :: None
Power Supply Corsair CX600w :: Unknown
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
#1
A friend sent me a Creative Titanium Fatal1ty. It sounds good, but there is a strong static background noise with my mic that isn't present with my Asus Xonar DG or my Realtek onboard sound. It's not picking up actual background noise, it's more like a constant static that never variates.
 
Joined
Jul 18, 2008
Messages
2,866 (0.82/day)
Likes
697
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4770K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x4GB Gskill 2400mhz
Video Card(s) EVGA GTX 780TI
Storage SSD Kingston 240GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 7 64 Bit
Benchmark Scores 3DMark Vantage 51342
#2
Install creative console launcher and set one of your mic settings all the way down.

You will have to adjust on them to see what one controlls what.

 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
18,583 (4.55/day)
Likes
3,195
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i5 2400 :: Athlon II x4 630
Motherboard MSI H67-G43-B3 :: GIgabyte GA-770T-USB3
Cooling Corsair H70 :: Thermaltake Big Typhoon
Memory 4x2GB DDR3 1333 :: 2x1GB DDR3 1333
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Plextor M5s 128GB, WDC Black 500GB :: Mushkin Enhanced 60GB SSD, WD RE3 1TB
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) X-Fi Titanium Fatal1ty Pro - iLive IT153B Soundbar (optical) :: None
Power Supply Corsair CX600w :: Unknown
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
#3
That's in the playback screen... I had already muted everything in playback, other than master volume.
 
Joined
Jul 18, 2008
Messages
2,866 (0.82/day)
Likes
697
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4770K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x4GB Gskill 2400mhz
Video Card(s) EVGA GTX 780TI
Storage SSD Kingston 240GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 7 64 Bit
Benchmark Scores 3DMark Vantage 51342
#4
Muting is not the answer.

You have to drop the slider all the way down like I have on the left set.

You can click the arrow above the slider on the right to change settings.

Then use the sliders to increase the mic output and slide the other all the way down to remove the feedback.
 

mp3boy

New Member
Joined
Feb 13, 2009
Messages
150 (0.05/day)
Likes
3
System Name derpmaster
Processor I7 950 @4.2ghz
Motherboard MSI Big Bang Xpower X58
Cooling Corsair H100 (4 Gentle typhoons)
Memory 12 Gb G-skill ddr3
Video Card(s) MSI GTX 570 SLI W/ Accelero Xtreme Plus II
Storage 128GB OCZ Vertex IV/ 1 TB Caviar black 32mb/ 2TB Seagate Barracuda 64mb
Display(s) ASUS 238H LED 1920X1080
Case HAF 932 "black" edition
Audio Device(s) X-fi Titanium Fata1ty Champion
Power Supply 850 watt Cougar
Software Windows 7 ulti 64 bit
#5
I had the same problem. Fixed it by dropping Microphone FP to 0 :)