• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Creative X-Fi Soundcards and Windows 10 Fall Creators Update 1709 = Complete Disaster / Not Working

Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
Hi i need some help. I am also suffering this bug that when installing Windows 10 Fall Creators Update 1709 + Creative X-Fi Titanium sound card it goes into oblivion of black screens crash , bsod and system is unresponsive. When installing a fresh / new installation from my usb thumb drive of the Windows 10 Fall Creators Update 1709 i get some weird black screen crash and system becomes unresponsive after installing the latest drivers from the creative website or Daniel K package for my Creative X-Fi Titanium pci-express sound card. After installation of the fresh OS i noticed it detects my X-Fi Titanium as a high definition audio device under device manager sound and not as an X-Fi sound card as previously on Windows 10 Creators Update 1703.

With Windows 10 Creators Update 1703 everything runs perfectly without a single problem with my Creative X-Fi Titanium , the problem started with the Windows 10 Fall Creators Update 1709 , so the culprit of the problems is the Creative drivers and W10 Fall CU 1709 , as something has change in the way it detects audio devices and the drivers.

I have wrote to microsoft support for help and on the feedback hub from within windows but without luck so far :/ , this is frustrating as everything was working so good and great before the Windows 10 Fall Creators Update 1709. I have search the whole web for a week for a fix but i have not been unable to find one. As some other people who have posted here on this thread i also am running an AMD AM4 x370 / Ryzen set up.

If someone has found a fix for this huge problem please reply to me if possible so that i can use my Creative X-Fi soundcard again ( I'm Using Realtek Onboard sound and it is horrible , me do not like it ). Please help.

Hardware Configuration:
--------------------------
Asus Crosshair VI Hero x370 / AMD Ryzen 1700x / G.Skill 2x8GB DDR4 3200Mhz Cas 14 / Nvidia GTX 1080Ti / Crucial MX300 1TB SSD + WD Green 2TB HD / eVGA Supernova G3 1300w psu / and of course Creative X-Fi Titanium pci-express sound card.

Here is a link for this same problem reported at Microsoft support and on Creative Support website:

https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-fall-creators-update-clean-install/7bb6f8ca-efb2-4802-8bec-6bcf7ada849a

http://forums.creative.com/showthread.php?t=742065

Kind Regards: Chispy
 
Last edited:

rtwjunkie

PC Gaming Enthusiast
Supporter
Joined
Jul 25, 2008
Messages
13,346 (2.98/day)
Location
Louisiana -Laissez les bons temps rouler!
System Name Bayou Phantom
Processor Core i7-8700k 4.4Ghz @ 1.18v
Motherboard ASRock Z390 Phantom Gaming 6
Cooling All air: 2x140mm Fractal exhaust; 3x 140mm Cougar Intake; Enermax T40F Black CPU cooler
Memory 2x 16GB Mushkin Redline DDR-4 3200
Video Card(s) EVGA RTX 2080 Ti Xc
Storage 1x 500 MX500 SSD; 1x 6TB WD Black; 2x 4TB WD Black; 1x400GB VelRptr; 1x 3TB WD Blue storage (eSATA)
Display(s) HP 27q 27" IPS @ 2560 x 1440
Case Fractal Design Define R4 Black w/Titanium front -windowed
Audio Device(s) Soundblaster Z
Power Supply Seasonic X-850
Mouse Coolermaster Sentinel III (large palm grip!)
Keyboard Logitech G610 Orion mechanical (Cherry Brown switches)
Software Windows 10 Pro 64-bit (Start10 & Fences 3.0 installed)
So what I didn't see was whether you checked to see if the X-Fi drivers on the Creative website have been updated yet. It's really not Microsoft's problem, it is Creative's.

If not, you'll need to go with motherboard sound, or upgrade to a SB-Z, since the Z is working under Fall Creator's Ipdate, or to the new X. Or wait, and hope Creative updates.

EDIT: It looks like last driver update for Titanium was 24 Jan, 2016, which barely made it to operable period with anniversary Update.
 
Last edited:
Joined
Jan 29, 2012
Messages
5,588 (1.75/day)
Location
Florida
System Name natr0n-PC
Processor 2600K @ 4.5GHz / Dual Xeon 5675's @ 3.33GHz 12c/24t
Motherboard MAXIMUS V FORMULA / GA-7TESM
Cooling Deepcool Assassin - 3 Fans / RAIJINTEK AIDOS x2
Memory 4x8GB 2133MHz Samsung Dual Channel / 6x8GB 1333MHz Samsung Hexa Channel
Video Card(s) Asus Strix 980ti /Sapphire Pulse RX590
Storage Various SSD/HD
Display(s) AOC 24" IPS / Various Dells
Case Sunbeam Transformer Silver / Matrexx 55
Audio Device(s) Various
Power Supply Corsair TX 650w / Evga NEX 750B
Mouse Alienware AW558 @ 5000 DPI
Keyboard Asus KB34211
Software XP64/7/8.1/10
Benchmark Scores http://valid.x86.fr/79kuh6
You can rollback to before the update/prevent windows from auto updating.


As far as realtek sound it is actually good once you manually adjust the EQ to your liking.
 
Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
Thank you for the feedback and trying to help me guys. I will see what i can do to make it work :/ if possible.
 
Joined
Sep 22, 2012
Messages
1,010 (0.34/day)
Location
Belgrade, Serbia
System Name Intel® X99 Wellsburg
Processor Intel® Core™ i7-5820K - 4.5GHz
Motherboard ASUS Rampage V E10 (1801)
Cooling EK RGB Monoblock + EK XRES D5 Revo Glass PWM
Memory CMD16GX4M4A2666C15
Video Card(s) ASUS GTX1080Ti Poseidon
Storage Samsung 970 EVO PLUS 1TB /850 EVO 1TB / WD Black 2TB
Display(s) Samsung P2450H
Case Lian Li PC-O11 WXC
Audio Device(s) CREATIVE Sound Blaster ZxR
Power Supply EVGA 1200 P2 Platinum
Mouse Logitech G900 / SS QCK
Keyboard Deck 87 Francium Pro
Software Windows 10 Pro x64
That's completely distaster when Windows start to update drivers. You have option to disable Driver updates in Windows 10 newer updates.
Nice because I saw this, now I will not update on 1709 I don't want mess with SBZxR.
I can't look for solution for their halucinations and decisions to Windows install what you want.
 

SQr

Joined
Mar 10, 2009
Messages
16 (0.00/day)
System Name XT
Processor AMD Ryzen 7 3700X 8C/16T
Motherboard Asrock X570 Taichi
Cooling ARCTIC Liquid Freezer II 280
Memory G.Skill Trident Z Neo 2x16GB DDR4 3600Mhz C16
Video Card(s) MSI GeForce GTX 1080 Ti DUKE 11G OC (NZXT G10+X31)
Storage SiliconPower P34A80 M.2 512GB + Samsung Evo 860 500GB + Too many others
Display(s) Samsung U28D590D UHD/4K
Case Raijintek Zofos EVO (Window)
Audio Device(s) Creative X-Fi Titanium Fatal1ty Pro
Power Supply Corsair RM850
Mouse Logitech G602
Keyboard Logitech G510
Software Windows 10 Pro x64
I have the same sound card. Don't have any issues with it under Fall Creators update. I am using Daniel K.'s drivers as well.

Something must have gone wrong during the update process. You should see if the issue persists on a clean install of windows.

Also, please post your PC specs.
 
Joined
Oct 1, 2010
Messages
2,309 (0.63/day)
Location
Marlow, ENGLAND
System Name Chachamaru-III | Retro Battlestation
Processor Intel Core i7 3770K | Intel Pentium II 450MHz
Motherboard BIOSTAR TZ77XE4 (Intel Z77 Chipset) | MSI MS-6116 (Intel 440BX chipset)
Cooling Cooler Master Hyper 212X, case fully populated
Memory 16GB G.Skill Ares 1600MHz (2x8GB) [30 10-10-10] | 512MB PC133 SDRAM
Video Card(s) MSI GeForce 1070 Gaming Z, Intel HD 4000 (for secondary monitor) | 3dfx Voodoo3 3000
Storage 250GB SK hynix SSD (OS), Toshiba 3TB (Storage), Toshiba 3TB (Steam), Samsung 1TB (Personal Files)
Display(s) LG 24UD58-B @ 4k & Eizo FlexScan L887 20" @ 1600x1200
Case Antec Three Hundred Two | Beige box
Audio Device(s) Creative Sound Blaster Z (Speakers), Realtek ALC898 (Headphones) | Sound Blaster AWE64
Power Supply EVGA Supernova 750 G2 | 250W ASETEC
Mouse Razer DeathAdder | Microsoft Serial Mouse v2.0A
Keyboard Redragon K551-UK VARA | Dell AT102W
Software Microsoft Windows 10 Pro | Microsoft Windows 98SE
Please don't screw with your text. Leave it with the default colour and font. I had to highlight it in order to be able to read the text.
 
Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
Please don't screw with your text. Leave it with the default colour and font. I had to highlight it in order to be able to read the text.
Sorry about that , it was a copy and paste i did from another website while looking for help , i fixed it already.

Do you have any help or advice for me , any help will be highly appreciate it.

Kind regards: Chispy
 
Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
I have the same sound card. Don't have any issues with it under Fall Creators update. I am using Daniel K.'s drivers as well.

Something must have gone wrong during the update process. You should see if the issue persists on a clean install of windows.

Also, please post your PC specs.
Thank you for the feedback. This are my PC specifications:

Asus Crosshair VI Hero x370 / AMD Ryzen 1700x / G.Skill 2x8GB DDR4 3200Mhz Cas 14 / Nvidia GTX 1080Ti / Crucial MX300 1TB SSD + WD Green 2TB HD / eVGA Supernova G3 1300w psu / and of course Creative X-Fi Titanium pci-express sound card
 
Joined
Oct 17, 2012
Messages
9,247 (3.16/day)
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MGK-1 RGB (Kaith Blue)
Software Win 10 Professional 64 bit
Thank you for the feedback and trying to help me guys. I will see what i can do to make it work :/ if possible.
The fall creators update is known to have a variety of bugs Even for computers with standard or basic hardware, that factor is only going to increase with specialized or less than common components. just roll back. Im sure it will get resolved in time. FCU doesnt add anything worth writing home about anyway
 
Joined
Jul 19, 2006
Messages
43,056 (8.26/day)
Processor i7 8700K
Motherboard Asus Maximus Hero X WiFi
Cooling Water
Memory 32GB G.Skill 3200Mhz CL14
Video Card(s) RX 5700 XT
Storage SSD's
Display(s) Nixeus EDG27
Case Lian Li PC 011 Dynamic
Audio Device(s) Yamaha AG03, Beyerdynamic DT990 Pro, ModMic
Power Supply Corsair H1000i
Mouse PCMR Model O
Keyboard Razer BlackWidow Tournament Ed.
Software Windows 10 Enterprise
Any Windows update breaks my Creative sound drivers. Best way for me is to disable it via group policy:

  1. Go to Run –> gpedit.msc
  2. In the Group Policy Editor, go to Computer Configuration –> Administrative Templates –> System –> Device Installation –> Device Installation Restrictions
  3. In the right hand pane, select “Prevent installation of devices not described by other policy settings” and set it to Enabled.
Once that's done, uninstall the driver Windows put in there and install the correct one.
 
Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
Any Windows update breaks my Creative sound drivers. Best way for me is to disable it via group policy:

  1. Go to Run –> gpedit.msc
  2. In the Group Policy Editor, go to Computer Configuration –> Administrative Templates –> System –> Device Installation –> Device Installation Restrictions
  3. In the right hand pane, select “Prevent installation of devices not described by other policy settings” and set it to Enabled.
Once that's done, uninstall the driver Windows put in there and install the correct one.

Thank you for trying to help , i did tried your suggestion but it did not work :/ , nothing seems to make it work on Windows 10 Fall Creators Update 1709. In the meantime i have bought a new SoundBlasterX AE-5 and it did installed flawlessly , no problems whatsoever. it is up to Creative ( drivers ) and Microsoft ( bug fix ) to fix this huge bugs with Audio.

Kind Regards: Chispy
 
Joined
Jan 29, 2012
Messages
5,588 (1.75/day)
Location
Florida
System Name natr0n-PC
Processor 2600K @ 4.5GHz / Dual Xeon 5675's @ 3.33GHz 12c/24t
Motherboard MAXIMUS V FORMULA / GA-7TESM
Cooling Deepcool Assassin - 3 Fans / RAIJINTEK AIDOS x2
Memory 4x8GB 2133MHz Samsung Dual Channel / 6x8GB 1333MHz Samsung Hexa Channel
Video Card(s) Asus Strix 980ti /Sapphire Pulse RX590
Storage Various SSD/HD
Display(s) AOC 24" IPS / Various Dells
Case Sunbeam Transformer Silver / Matrexx 55
Audio Device(s) Various
Power Supply Corsair TX 650w / Evga NEX 750B
Mouse Alienware AW558 @ 5000 DPI
Keyboard Asus KB34211
Software XP64/7/8.1/10
Benchmark Scores http://valid.x86.fr/79kuh6
@chispy How does the AE-5 compare to the X-fi Titanium ?
Like as good or equal to.
 
Joined
Sep 22, 2012
Messages
1,010 (0.34/day)
Location
Belgrade, Serbia
System Name Intel® X99 Wellsburg
Processor Intel® Core™ i7-5820K - 4.5GHz
Motherboard ASUS Rampage V E10 (1801)
Cooling EK RGB Monoblock + EK XRES D5 Revo Glass PWM
Memory CMD16GX4M4A2666C15
Video Card(s) ASUS GTX1080Ti Poseidon
Storage Samsung 970 EVO PLUS 1TB /850 EVO 1TB / WD Black 2TB
Display(s) Samsung P2450H
Case Lian Li PC-O11 WXC
Audio Device(s) CREATIVE Sound Blaster ZxR
Power Supply EVGA 1200 P2 Platinum
Mouse Logitech G900 / SS QCK
Keyboard Deck 87 Francium Pro
Software Windows 10 Pro x64
Do you like Sound Blaster X AE-5?
Looks like its' best sound card for now.

But because SBZxR look far better and probably sound difference is small I will stay on SBZxR.
SBZxR still cost 100$ more.
 
Joined
Sep 26, 2009
Messages
55 (0.01/day)
Location
Puerto Rico
@chispy How does the AE-5 compare to the X-fi Titanium ?
Like as good or equal to.

Do you like Sound Blaster X AE-5?
Looks like its' best sound card for now.

But because SBZxR look far better and probably sound difference is small I will stay on SBZxR.
SBZxR still cost 100$ more.


After spending quite some time fiddling with the settings on the dashboard ( equalizer and other settings ) i have finally made it sound better than my old X-Fi Titanium on games / movies / music , thru my 5.1 speaker system. Definitely it does sound better than my old ( 7+ years old ) X-Fi Titanium :) , i'm very pleased with the sounds and in my opinion it was a worth it upgrade.
 
Joined
Jul 5, 2013
Messages
10,769 (4.04/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Even though you've resolved the issue with a new sound card, there are some people who will read through this thread looking to resolve the same issue.
It's worthy of note for those who have and wish to continue using their XFi cards that DanielK's current custom driver offerings are working without flaw on the newest update of Win10. Out of curiosity I tested it personally with my XFi card. No problems at all.

Those drivers are found here; https://danielkawakami.blogspot.com/

@chispy
Don't throw that card away. Keep it as a spare or give it to someone who might enjoy using it.
 
Joined
Jan 29, 2012
Messages
5,588 (1.75/day)
Location
Florida
System Name natr0n-PC
Processor 2600K @ 4.5GHz / Dual Xeon 5675's @ 3.33GHz 12c/24t
Motherboard MAXIMUS V FORMULA / GA-7TESM
Cooling Deepcool Assassin - 3 Fans / RAIJINTEK AIDOS x2
Memory 4x8GB 2133MHz Samsung Dual Channel / 6x8GB 1333MHz Samsung Hexa Channel
Video Card(s) Asus Strix 980ti /Sapphire Pulse RX590
Storage Various SSD/HD
Display(s) AOC 24" IPS / Various Dells
Case Sunbeam Transformer Silver / Matrexx 55
Audio Device(s) Various
Power Supply Corsair TX 650w / Evga NEX 750B
Mouse Alienware AW558 @ 5000 DPI
Keyboard Asus KB34211
Software XP64/7/8.1/10
Benchmark Scores http://valid.x86.fr/79kuh6
Even though you've resolved the issue with a new sound card, there are some people who will read through this thread looking to resolve the same issue.
It's worthy of note for those who have and wish to continue using their XFi cards that DanielK's current custom driver offerings are working without flaw on the newest update of Win10. Out of curiosity I tested it personally with my XFi card. No problems at all.

Those drivers are found here; https://danielkawakami.blogspot.com/

@chispy
Don't throw that card away. Keep it as a spare or give it to someone who might enjoy using it.
Yeah with Dan.K (lol dank drivers) I have tested xp,7,8.1 and 10.Only 1 driver and it works on all those OS.
Funnily enough I got an x-fi titanium pcie earlier today. Been using pci extreme music previously on old system.
Still amazing cards the x-fi.
 
Joined
Jul 5, 2013
Messages
10,769 (4.04/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
The Audigy cards are still very useful as well and fully functional thanks to DanielK. I still use an Audigy2 on Win7 in an older Dell system. Tried Win10 out on the same system, it worked perfectly. I kinda wish DanielK would do a Patreon so we who are grateful for all his hard work over the years could show him some love.
 
Joined
Nov 18, 2010
Messages
5,125 (1.41/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor Intel 5960X @ 4.4GHz
Motherboard Gigabyte GA-X99-UD3
Cooling Custom Loop. 360+240 rads. 5x Nidec Servo Gentle Typhoons. AC CUPLEX KRYOS NEXT.
Memory 4x8GB Corsair Vengeance LPX 3000MHz 15-17-17-36 CR1
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer Deathstalker
Software Windows 10 insider
Sounds like any X-Fi when it dies. It could a bad supply cap...

I had them a lot, and it is like that usually.
 
Joined
Jul 5, 2013
Messages
10,769 (4.04/day)
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Sounds like any X-Fi when it dies. It could a bad supply cap... I had them a lot, and it is like that usually.
Oh right, that could be it. Those caps are easy to replace and worth the effort.
 
Joined
Nov 18, 2010
Messages
5,125 (1.41/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor Intel 5960X @ 4.4GHz
Motherboard Gigabyte GA-X99-UD3
Cooling Custom Loop. 360+240 rads. 5x Nidec Servo Gentle Typhoons. AC CUPLEX KRYOS NEXT.
Memory 4x8GB Corsair Vengeance LPX 3000MHz 15-17-17-36 CR1
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer Deathstalker
Software Windows 10 insider
30/70.

Mine usually had a bad X-Fi controller itself. The caps are bad, the card is usually so hot so with time many issues develop. I've using my second ZxR already too.

PCB is actually fragile, melt with Pb containing solder to lower the melting point, then remove the cap.
 
Last edited:
Joined
Mar 24, 2010
Messages
5,047 (1.31/day)
Location
Iberian Peninsula
I didn't expect it, but Creative = still Destructive after 20 years of wasting time and money of customers, despite DanielK.
 

rtwjunkie

PC Gaming Enthusiast
Supporter
Joined
Jul 25, 2008
Messages
13,346 (2.98/day)
Location
Louisiana -Laissez les bons temps rouler!
System Name Bayou Phantom
Processor Core i7-8700k 4.4Ghz @ 1.18v
Motherboard ASRock Z390 Phantom Gaming 6
Cooling All air: 2x140mm Fractal exhaust; 3x 140mm Cougar Intake; Enermax T40F Black CPU cooler
Memory 2x 16GB Mushkin Redline DDR-4 3200
Video Card(s) EVGA RTX 2080 Ti Xc
Storage 1x 500 MX500 SSD; 1x 6TB WD Black; 2x 4TB WD Black; 1x400GB VelRptr; 1x 3TB WD Blue storage (eSATA)
Display(s) HP 27q 27" IPS @ 2560 x 1440
Case Fractal Design Define R4 Black w/Titanium front -windowed
Audio Device(s) Soundblaster Z
Power Supply Seasonic X-850
Mouse Coolermaster Sentinel III (large palm grip!)
Keyboard Logitech G610 Orion mechanical (Cherry Brown switches)
Software Windows 10 Pro 64-bit (Start10 & Fences 3.0 installed)
I didn't expect it, but Creative = still Destructive after 20 years of wasting time and money of customers, despite DanielK.
Huh? You know most, including in this thread don't have that experience? Was it supposed to be helpful?
 
Joined
Jan 31, 2012
Messages
1,917 (0.60/day)
Location
Bulgaria
System Name Sandfiller
Processor I5-7600K
Motherboard Asus PRIME Z270-P
Cooling Noctua NH-L9i
Memory 2 x 8GB Cruicial 2400 mhz DDR4 CL17
Video Card(s) RX 580 4GB NITRO+
Storage Cruicial M.2 275GB drive
Display(s) 2560x1080 LG 29"
Case TT URBAN R31
Audio Device(s) Creative Sound Blaster Z
Power Supply Fractal Design IntegraM 650W
Mouse Logitech G602
Keyboard Dell Somethin wireless
Software Windows 10 x 64 bits
Dunno, after what I read here, but I have a Recon3D, which is not new, to say the least. No problems so far with Creator's update. I will have in mind the suggestion here though, if something arises.
 
Joined
Nov 7, 2017
Messages
525 (0.49/day)
Location
Ft. Washington, MD
System Name Main
Processor R7 3700x
Motherboard Gigabyte Aorus Ultra
Cooling Eisbaer 280 with 2 Arctic F14 (top/exhaust), two F14/two F12 for intake, F14 (rear/exaust)
Memory 16 GB 3600/16/19/19/36-1T@1.35v Corsair Veng Pro (Micron die)
Video Card(s) GB 2080S WaterForce WB
Storage 970 evo pro/Inland pro/Adata NVME's
Display(s) Vizio 43 UHD
Case Thermaltake S300 TG
Audio Device(s) Asus Xonar DX, modded Sennheiser HD 558, Klipsch 2.1 THX
Power Supply EVGA G+ 650w
Mouse Logitech G903
Keyboard GSKILL Ripjaws
Software win 10 x64
Benchmark Scores 3DMark11 xtrm 15K Unigine SuperPosition 1080p xtrm 7704 TimeSpy perf 12130
@rtwjunkie
Had 5 different creative cards, all failed with the left channel having less output when below 1/5-1/4 of total volume.
Crackling noise on 2 when changing volume.

Not even talking about their driver support
(no, Daniels drivers dont count).

Unless its a card above 100$, i wont get anything from creative anymore.
the asus xonar dgx/dx are cheaper, and most the time will also sound better...
 
Top