1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Dell D600 Power Inverter bad again!???

Discussion in 'General Hardware' started by lucasweir, Mar 4, 2011.

  1. lucasweir

    lucasweir

    Joined:
    Aug 28, 2008
    Messages:
    1,268 (0.42/day)
    Thanks Received:
    73
    Location:
    USA
    hello everyone just got my hands on a older dell latitude d600 and the back light was out on it when i received it. I ordered a new lcd inverter for the machine same part and everything. When i installed the new inverter every time i boot up the screen will light up for 1/2 sec and make a popping noise, and then goes black again but can still see the lcd is working correctly. So does this mean this part is also bad or is something else not right? :banghead::banghead:
     
    Last edited: Mar 4, 2011
  2. lucasweir

    lucasweir

    Joined:
    Aug 28, 2008
    Messages:
    1,268 (0.42/day)
    Thanks Received:
    73
    Location:
    USA
    heres a pic if that helps at all lol


    [​IMG]
     
  3. Swamp Monster

    Swamp Monster

    Joined:
    Oct 22, 2010
    Messages:
    571 (0.26/day)
    Thanks Received:
    88
    Location:
    Latvia
    If you post a proper size pic of inverter and power section schematic, then it might help to locate the problem.
     
  4. FreedomEclipse

    FreedomEclipse ~Technological Technocrat~

    Joined:
    Apr 20, 2007
    Messages:
    16,213 (4.61/day)
    Thanks Received:
    4,138
    Location:
    London,UK
    I dont think the Inverter is the problem - the light tube in the panel itself is gone. similar thing happend to mine. replaced the inverter - and the screen didnt work. had to get a new panel before it started working again
     
  5. lucasweir

    lucasweir

    Joined:
    Aug 28, 2008
    Messages:
    1,268 (0.42/day)
    Thanks Received:
    73
    Location:
    USA
    well the light flashes on the screen and didnt do that before i bought the new one. So maybe its a bad part? or the screen/video cable is bad
     
  6. FreedomEclipse

    FreedomEclipse ~Technological Technocrat~

    Joined:
    Apr 20, 2007
    Messages:
    16,213 (4.61/day)
    Thanks Received:
    4,138
    Location:
    London,UK
    mine flashes on then off again everytime you powerd it up. trust me. the light tube inside the panel is gone
     
  7. lucasweir

    lucasweir

    Joined:
    Aug 28, 2008
    Messages:
    1,268 (0.42/day)
    Thanks Received:
    73
    Location:
    USA
    so order a new lcd and that should fix it?
     
  8. FreedomEclipse

    FreedomEclipse ~Technological Technocrat~

    Joined:
    Apr 20, 2007
    Messages:
    16,213 (4.61/day)
    Thanks Received:
    4,138
    Location:
    London,UK
    If you already replaced the inverter then yes it should work providing the screen is compatible with the laptop
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)