• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

DFI lanparty ULTRA D NF4 and SSD RAID 0 help

Sep 20, 2006
460 (0.11/day)
I need help with my DFI lanpartu Ultra D nf4 chipset..

Here's the kicker... Windows installed and configured on a single 30GB IDE disk, plugged into IDE-0 on the DFI lanparty, and also have 2 130GB IDE disks in RAID 0, using a Promise Fast-track 100 RAID controller.

I have setup windows XP pro sp2 with Nlited nvraid drivers, reconfigured windows/registry to move profiles, system writes, temp files, page file, temp internet files, cache and other frequent System drive writes to a partition on the IDE RAID-0 Promise fasttrack array, to reduce system writes, to preserve the SSD Array..

I have cloned my C: xp installation from a single ATA disk, over to a partition on the IDE RAID-0 promise fasttrack array, to see if it would work, and have booted from that and have since removed the single 30GB disk from the DFI onboard IDE controller.. Windows working fine after cloning over to the promise array..

I only have a single opticle IDE disk connected to the DFI onboard IDE controller..
And 2 IDE disks connected to the promise RAID controller, setup in RAID 0..

I went into the bios, enable RAID, opened up the f10 console, setup the stripe for the SSD's, booted windows off the fast-track Array, aligned and partitioned the SSD array and have cloned my XP installation from the Promise array, over to the SSD array primary/active partition, then went into regedit and swapped drive letters between the IDE array and the SSD array and rebooted..

Now unable to boot off the SATA SSD, and unable to set the SSD array to BOOT via the F10 RAID configuration/bios..

I think This is because the DFI lanparty NF4 bios detects the IDE disks on the promise controller so, the bios/F10 thing won't allow me to set the SSD array as "bootable"

Also, since i have configured the SATA array, and done all the partition/formatting, once in a while the bios hangs on "detecting disks" at the mediashield bios.. It takes a couple of reboots before the NVIDIA STRIPE is re-detected... This is only after setting the partition to "active" before this, the NVIDIA STRIPE was detected on every single reboot...

Do I need to add "hard disk delay" in the bios? is that what the delay for hard disks setting is for?

I have read that the only way to get the SATA array bootable is to remove ALL P-ATA, IDE disks physically from the computer, then reboot and open F10 configuration, set the array to bootable, and then boot/install windows on the SATA array, then re-install the IDE disks after booting windows.

I have not tried removing the promise array/IDE disks, because they are hard coded in my xp installation to used one of the partitions on that array as cache/profiles/temp files etc..

I do not want to attempt to boot windows off the SSD array without these disks installed, in fear of windows freaking out, because I have the profiles and such, already set to be written to another IDE RAID volume.. Any ideas? If I unplug the promise controller/disks, then open f10 mediashield thing, set the array to boot; turn off computer/reconnect the promise controller...

One thing that I can try is to delete the C: partition off the Promise controller ARRAY. Remove the promise controller/disks, the open F10, set array to bootable if it allows... then boot the windows installation CD "nvraid" nlited, and attempt to "repair" the installation, if it allows.. then before windows reboots after copying files, re-install the promise controller/disks??

lota different things to try..

I have everything backed up, and can reconnect the single 30GB disk, clone my install to it, then remove it and have that backed up, ready to go, just incase..

I don't mind borking the fast-track RAID-0 C: install but I seriously don't want to bork the install on the SSD's because it means re-flashing each SSD and resetting bios a few times, configuring the stripe, align/partition rinse spin/dry etc... Any suggestions?
Sep 20, 2006
460 (0.11/day)
Little update;

I just removed the Promise Fastrack100 controller, and opened F10 mediashield bios, set the array to BOOT, then booted windows from the SSD array, got up to the log-in screen.. Then I shut down the computer, to prevent windows from not finding profiles/pagefile etc.. From there I reconnected the Promise Fastrack100 controller, then rebooted the computer and found the mediasheild bios "BOOT" setting was reset to OFF... and the Promise controller's array showed up in the bios hard disk boot priority, as the first HDD bood device, even though I set disk boot priority to the NVidia stripe, rather than the FT array. Needless to say, windows booted up off the Promise array, verified by opening disk managment and noting that that (system drive) "the partition windows booted from" is disk 0, on promise fastrack controller....

This is a little progress, seeing that I can actually boot from the SSD array after cloning is good news but still not what I want to happen..

It looks like the NF4 board has this IDE disk boot priority hard coded into the bios..
Now I gotta try adding the 30GB disk, cloning to it, then removing the boot partition from the fasttrack array....

Then try rebooting with the 30GB disk removed and no boot partition on the fasttrack array....

I'm thinking that there will still be a no boot condition on the SATA SSD array, due to the NF4 bios wierdness by having the IDE disks installed..
Sep 20, 2006
460 (0.11/day)

If there are NO other IDE/ATAPI disks installed, the Mediashield RAID bios configuration allows setting the SATA RAID volume as bootable, that allows windows XP to boot from the SATA RAID volume. As soon as any other IDE/non SATA RAID hard disk, or any other bootable media, like usb thumb drive, is installed.. The nf4 chipset/BIOS and POST detect a usable MBR on these and pressent them TO the BIOS as the HARD DISK "boot priority" item 1/ or DMI pool data registers somewhere that the OTHER non SATA disks are THE bootable media. Then the SATA RAID volume boot setting goes away/grayed out in the F10 mediashield configuration menu.... However.. Once you are able to set the SATA RAID volume as bootable and attempt to boot off it, and get somewhere.. This "successfull boot" is logged into the DMI pool data of the bios/chipset..

If there is no bootable file system installed on OTHER bootable media... All that is left is the SATA RAID volume with bootable media, from there, going into the bios setup configuraiton, configure the SATA RAID volume as the BIOS's HARD DISK BOOT PRIORITY.

I deleted the boot partition off the Promise array, disconnected the 30GB backup/setup disk from primary IDE.. entered the BIOS SETUP, disabled all the boot first/second/third options, then opened Hard disk boot priority, then set the NVstripe "vertex array" as the hard disk boot priority 1.. Saved then exited, then imediately re-entered BIOS setup and set boot other device enabled..

Now it boots off the Cloned XP partition that I backed up onto the primary/active partition on the SSD array.. So I now have a minimal SSD write system install, pre-configured to reduce system drive writes, with as many system writes/temp and pagefile stored on a partition that takes up the outside track of a RAID 0 volume.. I have another IDE disk partitioned and used to store images of the RAID partition that contains system file info/logs/temp/cache/myfavs/user profiles etc.....
With this setup, restoring the system is going to be easier, after all the work.. 3 months of reading/trying testing, reconfiguring etc.. And rebooting like a bazillion times... So now things are going very smooth, except for some wierd graphics drivers that cause the screen to blank a couple times before the desktop loads.... It works and it's fast enough..

I had it working pretty fast before moving to the SSD array, the SSD's bench at 500+MBPS writes from 128K files up, and read 700+MBPs before I was stuck at 7MBps writes on the 30GB disk, and about 27 to 58-60ish on the promise array.. HUGE difference..

The boot times and such can't get much better unless I had better RAID drivers, or faster hardware....

I'm stuck using Legacy RAID drivers that get apprximately 10-30MBps slower small file write/read performance... Since this is an old computer board, and outdated, outclased drive controllers/drivers.. I can't expect too much..

Alot of work to simply test out SSD's on this OLD computer board, to see if there's any more elbow room for a few more 3D \ photo-pp and game benchmark points....

Once I get my array and other drive partitions imaged and backed up, I'll start overclocking the CPU, I'm pretty sure the CPU clock and Dram FSB are holding back the SSD's :O

CPC disabled, lax memory timings and stock CPU timings probly slowing down data throughput on the databus.

I've got to admit, this is the fastest computer that I've used, well, atleast it seams that way, with how fast the drives move data around..

Game loading takes nearly 75% less time than before.....

If I had more system memory, I'm sure I could setup a RAMDISK and setup pagefile/temp/cache and all that stuff to the RAMDISK and the system would really fly along.....

Anyway, thanks for looking, I figured it out somehow....