• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Do I have the latest BIOS version on my 5600XT?

berkm00n

New Member
Joined
Nov 28, 2020
Messages
1 (0.02/day)
Guys I got my new pc yesterday, and i have XFX Radeon 5600XT Thicc II Pro videocard. I posted my question literally everywhere, also sent mail to AMD but still can't find the answer. You see two photos, with different memory numbers.

It was 1560-1750-1620 like half hour ago, but now it's 1375-1500-1560. And on my videocard box, there is a ' 14 GBPS Version ' Write. I'm totally confused, I am afraid to update it the latest version if it has already latest version it may be risky.
 

Attachments

  • 2.png
    2.png
    37.4 KB · Views: 40
  • Adsız.png
    Adsız.png
    39.5 KB · Views: 37
Joined
Oct 22, 2014
Messages
10,795 (4.72/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
@W1zzard
The bus width and bandwidth have changed also, this might be a bug with GPU-z

And on my videocard box, there is a ' 14 GBPS Version ' Write. I'm totally confused, I am afraid to update it the latest version if it has already latest version it may be risky.
I believe the earlier versions were 12GBPs, you have the later Vbios already.
 

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
21,529 (3.53/day)
Processor Core i7-8700K
Memory 32 GB
Video Card(s) RTX 3080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 10 64-bit
Hmm, no idea why these numbers are so different. Any chance you had no graphics driver installed in the first screenshot?
 
Top