• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

EDIT

Joined
Aug 16, 2007
Messages
7,180 (1.89/day)
Likes
720
#1
All right so i turned my speakers on today and noticed the back and centre channels where not working as they should. The centre/sub is extremely low volume and if i stick the jack in half way, it sort of works for a few seconds and then nothing. Its definitely the connections on the sub not the speakers; problem is i cant get to see the connections as there is a plastic surround over them.

The speakers i got on sale for £40 a couple years ago and ive used them daily so its not a major loss but id rather not have to spend money on new ones.





As you can see, the connections are all soldered on and glued so it would be a wee job to get them off just to find out one of them might be fucked anyway.
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
15,367 (3.98/day)
Likes
4,778
Location
US
Processor 2500k \ 3770k
Motherboard ASRock Z68 \ Z77
Memory Samsung low profile 1600
Video Card(s) XFX 6770 \ XFX R9 390X
Storage Intel 80Gb (SATA2) WD 250Gb \ Team SSD+Samsung Evo 250Gb+500Gb+ 2xCorsair Force+WD250GbHDD
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( original ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-V475 \ Marantz SR5008 Tannoy Mercury MKII Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse MS intelimouse \ Logitech G700s + Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
#2
Tried cleaning inside the connections ?. Like with some isopropyl highest % possible and if that fails try to see in side the jack to see if you can see the pins that make the connection to bend the slightly inwards.

I would try a paper clip and bend it so it would help to bend the pins inwards in side the plug.

EDIT be careful if you use q tips to clean in side the connector as the cotton could get cought up..
 
Joined
Aug 16, 2007
Messages
7,180 (1.89/day)
Likes
720
#2
Okay i will try some isopropyl as i have 99.9% stuff around, then i'll see if i can fit my engineers tweezers in the jack to see if anything is broken. Worth a shot.
 
Joined
Aug 16, 2007
Messages
7,180 (1.89/day)
Likes
720
#2
Stuck on a 5.1 surround movie to test, one by one i checked each channel of sound and it seems to be working now. I think the rear jack is bent a bit inside so the metal isnt making proper contact with the connector but seems to be working now for whatever reason.

I might save up for a new set of speakers if the rear channel starts to go again but at least i have my Superlux headphones for backup for now. The centre/sub and front all seem to be in great shape.

I just used a torch (flash light) to see in the 3.5mm jacks.
 
Joined
Sep 15, 2009
Messages
2,076 (0.68/day)
Likes
379
System Name Omen
Processor i7-4710HQ
Cooling Dual fan/heatpipe
Memory 16GB
Video Card(s) 4GB GTX 860M
Storage 256GB PCIE SSD/256GB PNY UHS-1 SD Card
Display(s) 15.6' 1080P
Case Aluminium
Audio Device(s) Onboard
Power Supply Brick
Software Win 10
#3
Stuck on a 5.1 surround movie to test, one by one i checked each channel of sound and it seems to be working now. I think the rear jack is bent a bit inside so the metal isnt making proper contact with the connector but seems to be working now for whatever reason.

I might save up for a new set of speakers if the rear channel starts to go again but at least i have my Superlux headphones for backup for now. The centre/sub and front all seem to be in great shape.

I just used a torch (flash light) to see in the 3.5mm jacks.
If your gonna get a new set of speakers, I suggest the logitech z623. They are amazing for the price. I have two myself and run them as a 4.2 set. One set is more powerful than your x540's so it would be a nice upgrade. :D
 
Last edited by a moderator:
Joined
Dec 24, 2012
Messages
3 (0.00/day)
Likes
0
#4
yeah, i'll see if i can fit my engineers tweezers in the jack to see if anything is broken. Worth a shot.
 
Joined
Jun 26, 2008
Messages
2,303 (0.66/day)
Likes
981
Location
EDM, AB, CAN
Processor AMD FX-4350
Motherboard Gigabye GA-970A-D3P
Cooling Enermax ETD-T60-VD - 7 x 120mm case fans
Memory Kingston HyperX 2x4GB@1600mhz
Video Card(s) Asus R9 380
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55"
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
#5
I had a pair of x-530's that crapped out on me after the warranty had expired and they still replaced them with the x-540's.

I like the 540's better than the newer Logitech Z506's cause the remote is wired and not attached to the speaker.