• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Elitebook 840 G5 throttling due to max tdp being extremely low

Joined
May 15, 2021
Messages
5 (0.14/day)
System Name EliteBook 840 G5, Inspiron 5570, Pavilion DV4, Vostro 1500, ThinkPad T61
Processor EliteBook: i5 8250U, Inspiron: i7 8550U, Pavilion: i3 2320m, Vostro: T5200, ThinkPad: T7500
Memory EliteBook: 20 GB, Inspiron: 24 GB, Pavilion: 8 GB, Vostro: 2 GB, ThinkPad: 6GB
Video Card(s) EliteBook & Inspiron: UHD 620, Pavilion: 3000 Series, Vostro: 8400m, ThinkPad: GMA 945
Storage EliteBook: 1TB NVME, Inspiron: 128 GB NVME+ 1TB HDD, Pavilion: 500 GB HDD, Vostro & ThinkPad: 128GB
Software EliteBook & Inspiron: W10 Enterprise, Pavilion, Vostro and ThinkPad: W7 Enterprise
Hey y'all, long time lurker, first time poster. I have an Elitebook 840 G5 with the i5 8250U, and it has been extremely slow. I have used Throttlestop to squeeze some extra power, and I got it to go above the 0.4 GHz limit. It usually hovers @ 0.8-1.2 GHz, and doesn't go past that. I have tried everything, and I have been pulling my hair out because of this. The max tdp for this laptop is ~ 5w , which is just shocking, since this is a 15w cpu, and Idk which engineer thought it would be aa good idea to make the max tdp 5w for this cpu, but they did. I have been dealing with this for the past few months, but I've had it with this. Attached are my configs that I use with throttlestop. Any help is welcome. Thanks in advance.
 

Attachments

  • Screenshot (113).png
    Screenshot (113).png
    211.4 KB · Views: 32
  • Screenshot (114).png
    Screenshot (114).png
    229.1 KB · Views: 34

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
Start by installing ThrottleStop 9.3. The FIVR Disable and Lock feature is not working because the driver is not installed. The new version includes a new driver.

It looks like CPU voltage control has been locked out. The new version should make this obvious. You might want to consider installing an older bios version.

Post some new pics while using the new version. Include the TPL window. A log file would be a good idea too.

Do not check Set Multiplier. It is no longer used because your CPU is using Speed Shift Technology. Clock Modulation is not used on your laptop so do not check that one either.
 
Joined
Oct 22, 2014
Messages
12,258 (5.04/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Do not check Set Multiplier. It is no longer used because your CPU is using Speed Shift Technology. Clock Modulation is not used on your laptop so do not check that one either.
Sorry for mentioning this here, I couldn't find a feature request thread.
Is it possible for the next version of ThrottleStop to make it clear when Set Multiplier can be used maybe by adding "CPU's up to 2010" or whenever SS Technology came out?
Same with Clock Modulation, can that be auto detected if capable, if not can the check box be greyed out?
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
All Intel CPUs for the last 15+ years support clock modulation. Most recent laptops use power limit throttling but clock modulation is still an option if they choose to use it.

In TS 9.3, Set Multiplier is not available when Speed Shift is enabled. With 10th Gen CPUs, both of these are still available. It depends on what the BIOS leaves available and what the individual user prefers.

There is no clear cut line. That is why ThrottleStop provides both options.
 
Last edited:
Joined
May 15, 2021
Messages
5 (0.14/day)
System Name EliteBook 840 G5, Inspiron 5570, Pavilion DV4, Vostro 1500, ThinkPad T61
Processor EliteBook: i5 8250U, Inspiron: i7 8550U, Pavilion: i3 2320m, Vostro: T5200, ThinkPad: T7500
Memory EliteBook: 20 GB, Inspiron: 24 GB, Pavilion: 8 GB, Vostro: 2 GB, ThinkPad: 6GB
Video Card(s) EliteBook & Inspiron: UHD 620, Pavilion: 3000 Series, Vostro: 8400m, ThinkPad: GMA 945
Storage EliteBook: 1TB NVME, Inspiron: 128 GB NVME+ 1TB HDD, Pavilion: 500 GB HDD, Vostro & ThinkPad: 128GB
Software EliteBook & Inspiron: W10 Enterprise, Pavilion, Vostro and ThinkPad: W7 Enterprise
@unclewebb
Here is the updated screenshot using the latest version of throttlestop. Attached is the log file that was generated.
 

Attachments

  • Screenshot (115).png
    Screenshot (115).png
    1.5 MB · Views: 21
  • 2021-05-15.txt
    1.5 KB · Views: 10

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
Your log file and screenshot shows constant EDP throttling. This type of throttling will prevent your CPU from running at its full rated speed and power. That is why you are hitting a max of 5W.

In the Turbo Power Limits, try increasing Power Limit 4. It is set to 44W at the moment. Increase this to 150 or more and see if the constant EDP throttling problem goes away. On some computers you can also set Power Limit 4 to 0. This tells the CPU to ignore this power limit. It is unnecessary.

The other values that control EDP throttling are the core and cache IccMax settings in the FIVR window. Unfortunately, I think the BIOS has locked this setting so you cannot use ThrottleStop to increase IccMax. Does the top of the FIVR window show Locked?

For comparison, here is how a similar low power 8th Gen U CPU runs in a Lenovo C930.
CPU voltage control and power limits are unlocked so one can get the most out of this 8550U.

 
Joined
May 15, 2021
Messages
5 (0.14/day)
System Name EliteBook 840 G5, Inspiron 5570, Pavilion DV4, Vostro 1500, ThinkPad T61
Processor EliteBook: i5 8250U, Inspiron: i7 8550U, Pavilion: i3 2320m, Vostro: T5200, ThinkPad: T7500
Memory EliteBook: 20 GB, Inspiron: 24 GB, Pavilion: 8 GB, Vostro: 2 GB, ThinkPad: 6GB
Video Card(s) EliteBook & Inspiron: UHD 620, Pavilion: 3000 Series, Vostro: 8400m, ThinkPad: GMA 945
Storage EliteBook: 1TB NVME, Inspiron: 128 GB NVME+ 1TB HDD, Pavilion: 500 GB HDD, Vostro & ThinkPad: 128GB
Software EliteBook & Inspiron: W10 Enterprise, Pavilion, Vostro and ThinkPad: W7 Enterprise
@unclewebb
Yup, the FIVR panel is grayed out, and I don't think that I can downgrade my bios. My bios version is 01.15.00, and for some versions, HP disabled the ability to downgrade the bios, and I think that this bios version probably locked out the ability to downgrade the bios.
 

Attachments

  • Screenshot (117).png
    Screenshot (117).png
    1.6 MB · Views: 17

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
@unclebalaji - Did you try adjusting Power Limit 4 yet? That might be the main reason for EDP throttling.
 

extremecarver

New Member
Joined
Apr 30, 2021
Messages
15 (0.29/day)
I am pretty sure it is. This limit is super confusing in Throttlestop - it is a number that is not watts (i guess on other processors this is called PP0 current limit) ... Set it to minimum 105, or higher if you want to only have thermal throttling... On most Intel U processors I believe 105 is the default.

There should be a unit value for all those TPL vales (watts, seconds, or if none of the two than Units). If this were called units people would not confuse it with watts and set it too low. Oh and the turbo time limit should be called PL2 turbo time limit. Then it is clear that afterwards it will go to PL1. People could be confused and think this applies to PL1 - and afterwards it would drop to the default non turbo power limit.


Also if you set PL2 or PL1 to low watt values - I think any less than the non turbo limit, they will not be respected. So setting 10w on PL1 and PL2 will have your CPU running on much higher wattage. Not sure if this works on some CPU to reduce them to say 15W instead of 28W... To 10w it does not work.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
This limit is super confusing in ThrottleStop
Intel is using the same register location for two different things. This register was originally called the CURRENT_CONFIG register and Intel still uses that name for this register. Its original purpose was to limit the amount of current which is measured in amps.

On the newer CPUs, Intel started using the IccMax settings to control the current. Instead of creating a new register for Power Limit 4, they reused the CURRENT_CONFIG register to store this information. The Intel publicly available documentation is not clear whether this register holds a value in Watts or if the value in this register is Amps. Intel has combined their documentation as this register's use has evolved.

1621266440824.png




The units of this limit are not important. All I know is that if Power Limit 4 is set too low, you will see EDP OTHER throttling in Limit Reasons. It is best to either set Power Limit 4 to 0 so it is not used or set Power Limit 4 sky high so it does not interfere with maximum performance. A CPU should never be constantly EDP throttling, especially when it is lightly loaded.

Also if you set PL2 or PL1 to low watt values - I think any less than the non turbo limit, they will not be respected.
The purpose of the Clamp option is so power consumption is clamped to that value. I have tested the Clamp option and it works well.

Here is an example of a desktop CPU which has a 125W TDP rating. ThrottleStop is set to Clamp power consumption to 45W. When fully loaded, the CPU is power limit throttled and forced to run below its 3.60 GHz base speed so it never exceeds 45.0W.

1621265727094.png
 
Last edited:

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
1621267668092.png


@extremecarver - Your screenshot shows that the Power Limit register is locked. PL1 is set to 30W and PL2 is set to 36W.

You can request 8W for PL1 and PL2 but the CPU will ignore this request if the register is already locked. You will need to clear the check mark in the Lock option and you will need to reboot to try to unlock this register. After you do that, then try setting PL1 and PL2 to 8W with the Clamp options enabled.

Thanks for the screenshot. On 11th Gen CPUs, it should say Power Limit 4 where it says PP0 Current Limit. I will get that fixed up in the next TS release.
 
Last edited:

extremecarver

New Member
Joined
Apr 30, 2021
Messages
15 (0.29/day)
Yes I made a mistake. because of locking.
Seems the i5 tiger lake U is either much more effective than the 10850K or you have high GPU load. Needs only 24w for the same speed as your one on 45w (well actual is about 3w more - the higher the wattage the more difference I can actually see with batterviewinfo - if I assume the fan on full speed needs 1w, there are 3w that are missing in the equation vs idle - so package power of 24w is like 27w in reality. On the i7 tiger lake this discrepancy was even bigger. This is running Cinebench 20. VID is also significantly lower. Above that speed the increases get marginal however. For 3400mhz it needs about 34...

24w efficiency is still pretty good. Tiger lake U any increase over 3300mhz or so needs loads loads loads of additional power.
unlocked.PNG
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
3,572 (0.75/day)
Needs only 24w for the same speed as your one on 45w
The difference is that the 10850K has 10 cores running at just over 3.0 GHz while your Tiger Lake only has 4 cores running at that speed.

24W / 4 cores = 6.0W per core

vs

45W / 10 cores = 4.5W per core

Based on that, the 10850K is more efficient compared to Tiger Lake.

The power consumption data that Intel CPUs report is not measured power consumption so trying to make any comparisons between different CPU families is meaningless. This data's only purpose is to control the turbo boost function.

All of this has nothing to do with the original question in this thread. Time for you to start a new thread.
 
Top