• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Error: Could not delete driver

Joined
Nov 8, 2013
Messages
25 (0.01/day)
Likes
0
Location
Shanghai, China
System Name HOME
Processor E3-1230 V2
Motherboard ASUS P8Z77-V LX2
Memory 8G DDR3 1600
Video Card(s) ASUS R9 280X-DC2T-3GD5-V2
Storage PLEXTOR M5S 128G SSD
Display(s) DELL U2412M 24-inch
Software WINDOWS 8.1 64-BIT
#1
Occasionally (or more frequently recently) I get this error messagebox after logoff/logon or reboot. I'm running Windows 10 Pro and it seems the problem does not relate to any specific build.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
25,858 (6.00/day)
Likes
8,893
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#2
Occasionally (or more frequently recently) I get this error messagebox after logoff/logon or reboot. I'm running Windows 10 Pro and it seems the problem does not relate to any specific build.
What driver?
 
Joined
Jun 15, 2016
Messages
950 (0.91/day)
Likes
464
System Name My PC
Processor 4670K@4.4GHz
Motherboard Gryphon Z87
Cooling CM 212
Memory 2x8GB+2x4GB @2400GHz
Video Card(s) XFX Radeon RX 580 GTS Black Edition 1425MHz OC+, 8GB
Storage Intel 530 SSD 480GB + Intel 510 SSD 120GB + 2x500GB hdd raid 1
Display(s) HP envy 32 1440p
Case CM Mastercase 5
Audio Device(s) Sbz Zxr
Power Supply Antec 620W
Mouse G502
Keyboard G910
Software Win 10 pro
#3
Try to start windows in safe mode and see if that helps, if not look in event viewer what driver specifically cannot be deleted.
 
Joined
Apr 28, 2011
Messages
615 (0.21/day)
Likes
85
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO/Intel Box cooler/Intel Box cooler
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2x1TB ADATA SSDs in RAID0+3 HDDs/2xCrucial 1TB SSDs in RAID0+3 HDDs/Samsung 1TB SSD+8TB+4TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Win10 64-bit (Main PC v.1809 RTM Enterprise/2nd PC v.1903 Insider Preview Pro/3rd PC - same as 2nd)
#4
Occasionally (or more frequently recently) I get this error messagebox after logoff/logon or reboot. I'm running Windows 10 Pro and it seems the problem does not relate to any specific build.
Can you attach a screenshot?
 
Joined
Mar 14, 2009
Messages
4,005 (1.08/day)
Likes
2,073
Location
Ohio
System Name Fractured puke.
Processor Intel I7-8700k/G4400/AMD 2200g/Ryzen 5 1600
Motherboard MSI z370 Gaming M5/h110/ AMD a320/ AMD B450-ASRock pro 4 atx
Cooling Corsair H110i/Intel/AMD/H60
Memory 16GB G.Skill TridentZ 3200MHZ/8gb 2133mhz/8gb 2400mhz/8gb Viper 3000mhz
Video Card(s) Nvidia GTX 1070ti/integrated/apu/rx570
Storage 960 EVO 500gb/256gb WD Black 2280 M2/Patriot Ignite 480gb SSD/ Inland Pro 256gb SSD/Patriot Scorch-&
Display(s) AOC 32" QHD/Acer 32" QHD/ ViewSonic 24" FHD/ TV
Case Fractal Design Meshify-C/ Rosewill FBM-01/ Rosewill FBM-01/Sigma eclipse
Audio Device(s) creative audigy/nboard/ onboard/inboard
Power Supply Seasonic/TT/TT/Cooler Master white80+ 500w
Mouse Red Dragon/red dragon/Razer/Razer
Keyboard Razer Deatstalker/red dragon RGB/Red Dragon 502/Razer
Software Windows 10Pro x64///
#5
You need to view Non present devices in device manger and eliminate the problem driver then manually update the device drivers manually in device manger

Open cmd prompt under admin and type
SET DEVMGR_SHOW_NONPRESENT_DEVICES=1
Then type from start menu.
devmgmt.msc to go into device manger.
I'm not at my PC and I'm not sure if that's correct... Going from memory.. Haven't had to do this in awhile


I think you have to enable Hidden devices under the view tab in device manger... I think that's all...
 
Last edited:
Joined
Nov 8, 2013
Messages
25 (0.01/day)
Likes
0
Location
Shanghai, China
System Name HOME
Processor E3-1230 V2
Motherboard ASUS P8Z77-V LX2
Memory 8G DDR3 1600
Video Card(s) ASUS R9 280X-DC2T-3GD5-V2
Storage PLEXTOR M5S 128G SSD
Display(s) DELL U2412M 24-inch
Software WINDOWS 8.1 64-BIT
#6
I don't believe it's specific to GPU driver. I think it's something related to a temporary driver installed in %TEMP%.

Oh, I forgot to mention that I have a CMD batch that runs at logon and deletes all files in %TEMP% folder. That's why I guess it's the cause of my problem.
 
Last edited:
Top