• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Esprimo P520 E85+, boot failure, after battery replacement and FUJITSU D12-250P1A power supply, how to test?

nico_ar

New Member
Joined
Aug 2, 2021
Messages
3 (0.06/day)
Hi,
I got recently an Fujitsu Esprimo P520 E85+ Desktop that won't start.
After replacing the battery on the motherboard, BIOS won't load.

I want to test firstly the FUJITSU D12-250P1A power supply.
I removed it from the desktop. Can anyone tell me, please, how could I start it?
I got 12V on the green wire and 11,7 on the brown/yellow one.
Wil it start with no load?

Thanks!
 
Last edited by a moderator:
Joined
Nov 11, 2004
Messages
8,931 (1.45/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard Gigabyte X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Audio Device(s) Corsair Virtuoso SE
Power Supply Corsair RM750
Mouse Logitech G502 Lightspeed
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/33u9si
Short these pins.


 

nico_ar

New Member
Joined
Aug 2, 2021
Messages
3 (0.06/day)
Thank you very much for your answer, LostSwede!
Unfortunately the power supply connector doesn't match your description, it is about a proprietary Fujitsu 16 pin connector. See att. please. I have 12V on pin 7 and 11.7 on pin 8. No idea what pin should I short in order to start it...
 

Attachments

  • Fujistsu Power Connector.jpg
    Fujistsu Power Connector.jpg
    140.1 KB · Views: 82
Joined
Oct 8, 2015
Messages
491 (0.23/day)
Location
Earth's Troposphere
System Name cvasi-rocket
Processor AMD Ryzen R7 5800X
Motherboard Asus ROG B550-F Gaming
Cooling Oldie but a goodie
Memory SK Hynix PC4-17000 4x8GB
Video Card(s) AMD Radeon RX 5700XT 50th Anniversary Edition
Storage 480 GB Corsair MP510 , Kingston A400 480 GB SSD
Display(s) Dell UltraSharp U2410 , HP 24x
Case Silverstone Raven RV05 white
Audio Device(s) onboard
Power Supply Seasonic Focus PX-550 |
Mouse Trust
Keyboard wireless , Logitech
Software W1021xx
The grey one ,PG (power good) to ground to start it manually.
 

nico_ar

New Member
Joined
Aug 2, 2021
Messages
3 (0.06/day)
Hi, "dont-whant-to-set-it"!
Thank you very much for your answer! Unfortunately, grounding the grey pin didn't work. Finally I was lucky: I replaced the battery on the motherboard and the power supply started with full load. Another problem: bios won't load...
However, thank you again, all, for your effort trying to help me!
 
Top