• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Fedora hanging at boot

Joined
Oct 12, 2008
Messages
1,590 (0.47/day)
Likes
757
#1
I installed Fedora on my work laptop because I'm thinking about switching from W7 to it - but I'm having an issue. I booted it a few times, got some stuff installed, all was 'good'...but I went to boot it and it hangs at the F. Through a bit of troubleshooting I saw that it appears to be hanging at ip6tables - however I cannot get it to stop. A mention was to try going and disabling it through the chkconfig but that didn't work. I could only find one thing that was ip6tables, and that was in usr/sbin and didn't let me do anything with it.

Another boot shows this:

 
Last edited:
Joined
Oct 24, 2004
Messages
825 (0.17/day)
Likes
473
System Name Seriously ?
Processor Core i7 4790K @ 4.4Ghz
Motherboard MSI Z97 Gaming 5
Cooling Alpenföhne Broken 120 + 2 huge coolermaster chassis fans
Memory 2x8GB DDR3 2133Mhz Crucial Ballistix
Video Card(s) Geforce GTX 1080
Storage 2x60gb Kingston SSDnow 320 / 1x120gb Crucial SSD C300 / 1 WD caviar black 1tb
Display(s) 40" Samsung UE40ES5500
Case Cooler Master HAF932
Audio Device(s) onboard realtek audio
Power Supply Corsair AX1200
Mouse Microsoft intellimouse optical
Keyboard Logitech K270
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/vmb641
#2
To completely disable IPv6 in your system, all you have to do is save the following line in a file inside /etc/modprobe.d/ :
install ipv6 /bin/true
The above line means: whenever the system needs to load the ipv6 kernel module, it is forced to execute the command true instead of actually loading the module. Since /bin/true, does absolutely nothing, the module never gets loaded.


Again, it is required to reboot for the changes to take effect.

It is obvious that this is an aggressive method to disable kernel modules, but it guarantees that the module never gets loaded.

This is the recommended way to disable IPv6.

source
 
Joined
Oct 12, 2008
Messages
1,590 (0.47/day)
Likes
757
#3
Tried that, put it in a file that was just called ipv6, still failing at ip6_tables. There is a sys/module/ip6_tables (and others), and I tried to get in there and rename some files and rename the folder to _old but nothing worked, even as root.



I just reinstalled, whatever. Really was hoping to have a better experience but so far it's meh.
 
Last edited:
Joined
Apr 19, 2009
Messages
809 (0.25/day)
Likes
1,070
Location
Romania
System Name Asus ROG G752VY
Processor i7-6700HQ
Memory 24GB DDR4 2133mhz
Video Card(s) nvidia 980m
Storage Samsung SSD 850 pro 2TB+1tb hdd 7200rpm
Software Mageia 6 + Windows 10
#4
Try Mageia 4 Kde, I have it from sometime...