• We've upgraded our forums. Please post any issues/requests in this thread.

Front Speaker Sounds coming out of Rear Speaker on Logitech X-540

W

wolf2009

Guest
#1
i connected my Logitech X-540 to X-FI . Now when i check sound from individual speaker from x-fi control panel, it sends the left front speaker sound to left rear speaker and vice-versa and same on right side .

I checked the connections on the rear of the sub, everything is plugged right there . wats wrong ?
 
Joined
Oct 4, 2007
Messages
2,444 (0.66/day)
Likes
352
System Name PC
Processor i7 2600K @4ghz
Motherboard Asus P8P67 Pro
Cooling Noctua NH-U14S
Memory 16GB Corsair Vengeance Blue DDR3 1600mhz
Video Card(s) Palit GTX 1080 Jetstream
Storage Samsung 850 pro 512gb SSD, 2x Kingston 120GB SSD, 2TB WB Green
Display(s) LG 34UM68 34-Inch Monitor
Case Corsair Obsidian 550D Case
Audio Device(s) Asus Xonar D2X PCI Express Audio / Audioengine A5+ Speakers
Power Supply Corsair RM650 Power Supply
Mouse Logitech G500 Mouse
Keyboard Corsair Vengeance K70 Keyboard
Software Windows 10 64bit
#2
um... you have the surrounds plugged into the fronts and vice versa ;)
 

sneekypeet

Unpaid Babysitter
Staff member
Joined
Apr 12, 2006
Messages
24,613 (5.78/day)
Likes
9,340
System Name His
Processor Intel i7 5930K
Motherboard Asus Maximus V Extreme
Cooling Thermalright True Spirit 140 BW Rev.A
Memory Corsair Dominator Platinum ROG
Video Card(s) nVidia GTX 1080 SLI with EVGA Hybrid coolers.
Storage Samsung 960 Pro / Crucial MX300 750GB / Seagate 1TB Spinner
Display(s) Sony 43" 4K 60hz
Case SilverStone Temjin TJ11
Audio Device(s) Realtek on board > Sony receiver > Cerwin Vega's
Power Supply Thermaltake TPSG 1050W
Mouse Always Changing
Keyboard Always Changing
Software Windows 10 Pro 64
#4
Try changing the audio output on the Xfi then?
 
Joined
Oct 4, 2007
Messages
2,444 (0.66/day)
Likes
352
System Name PC
Processor i7 2600K @4ghz
Motherboard Asus P8P67 Pro
Cooling Noctua NH-U14S
Memory 16GB Corsair Vengeance Blue DDR3 1600mhz
Video Card(s) Palit GTX 1080 Jetstream
Storage Samsung 850 pro 512gb SSD, 2x Kingston 120GB SSD, 2TB WB Green
Display(s) LG 34UM68 34-Inch Monitor
Case Corsair Obsidian 550D Case
Audio Device(s) Asus Xonar D2X PCI Express Audio / Audioengine A5+ Speakers
Power Supply Corsair RM650 Power Supply
Mouse Logitech G500 Mouse
Keyboard Corsair Vengeance K70 Keyboard
Software Windows 10 64bit
#5
???

i plugged the front and rear speakers into what they said on the back of the sub . i cleared that in my post .
well everything cant be plugged in correctly then... just swap it around so that it works.
the speakers just take the signal they are sent and play it... it dosent swap anything round... 5 inputs and 5 outputs.

The soundcard is the same... has the outputs and thats not going to change... perhaps the jacks you plug from the soundcard to the speakers is the wrong way round... check that... and try swapping the fromnt and rear jacks around... see if that works ;)