• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

geforce 8500 and call of duty

Joined
Apr 2, 2006
Messages
10 (0.00/day)
Likes
0
#1
geforce 8500 and call of duty uo

I need help. i bought a gigabyte 8500 with 512ram pci16x and cannot get it to play call of duty uo without lag. ive tried 5 different drivers and rma'd once. It plays all other games correctly execpt for call of duty uo. If you have any ideas please let me know.
 
Last edited:

JC316

Knows what makes you tick
Joined
Jan 24, 2006
Messages
9,371 (2.14/day)
Likes
1,004
System Name Budget Gaming
Processor AMD FX6300
Motherboard Gigabyte 880GMA-USB3
Cooling Coolermaster Hyper 212+
Memory 8GB Ripjaws DDR3 1600
Video Card(s) HD7850 1GB
Storage 1TB Sata2
Display(s) Acer 24" LED
Case Generic black
Audio Device(s) Stock onboard
Power Supply FSP Aurum Gold 650W
Software Windows 7 Home Premium 64bit
#2
Call of Duty 1 or 2? Either one should work fine, but I had that same problem with COD2's demo and my X1800XT, it never would run smooth.
 
Joined
May 10, 2007
Messages
1,396 (0.36/day)
Likes
124
Location
London, England
#3
UO is the expansion for CoD1. CoD1 should be supported by the 8500, and should run quite well. What settings are you attempting to run CoD with?
Oh, and what are your PC's specs?
Might help to know the drivers you tried too.
 

JC316

Knows what makes you tick
Joined
Jan 24, 2006
Messages
9,371 (2.14/day)
Likes
1,004
System Name Budget Gaming
Processor AMD FX6300
Motherboard Gigabyte 880GMA-USB3
Cooling Coolermaster Hyper 212+
Memory 8GB Ripjaws DDR3 1600
Video Card(s) HD7850 1GB
Storage 1TB Sata2
Display(s) Acer 24" LED
Case Generic black
Audio Device(s) Stock onboard
Power Supply FSP Aurum Gold 650W
Software Windows 7 Home Premium 64bit
#4
Hmm, Call of duty 1 ran fine on my 8600, so I don't see why it's acting up on yours. Maybe your sound drivers?