• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Google Chrome Issue

OrbitzXT

New Member
Joined
Mar 22, 2007
Messages
1,969 (0.50/day)
Likes
59
Location
New York City
System Name AX-01
Processor Intel Core i5-2500K @3.7 GHz
Motherboard ASRock Z68 Extreme3 Gen3
Cooling Zalman 9700
Memory Kingston HyperX T1 Series 8GB DDR3 1600 MHZ
Video Card(s) GTX 590
Storage Intel X25-M
Display(s) 42" Samsung LED HDTV
Case Antec Twelve Hundred
Audio Device(s) HT | OMEGA STRIKER 7.1
Power Supply Kingwin 1000W
Software Windows 7 64-Bit
#1
I was trying out Google Chrome at work and find that it's not loading certain pages. Here is a screenshot, on the left is the page in Chrome and on the right it's displayed properly with Firefox. The link to the page in question is here.

 

OrbitzXT

New Member
Joined
Mar 22, 2007
Messages
1,969 (0.50/day)
Likes
59
Location
New York City
System Name AX-01
Processor Intel Core i5-2500K @3.7 GHz
Motherboard ASRock Z68 Extreme3 Gen3
Cooling Zalman 9700
Memory Kingston HyperX T1 Series 8GB DDR3 1600 MHZ
Video Card(s) GTX 590
Storage Intel X25-M
Display(s) 42" Samsung LED HDTV
Case Antec Twelve Hundred
Audio Device(s) HT | OMEGA STRIKER 7.1
Power Supply Kingwin 1000W
Software Windows 7 64-Bit
#2
I should also add this is happening on three different PC's, one with Windows 7 64 bit, another XP 64 bit, and the last XP 32 bit. All are using the latest version of Chrome.
 

sneekypeet

Super Moderator
Staff member
Joined
Apr 12, 2006
Messages
24,710 (5.75/day)
Likes
9,455
System Name His
Processor Intel i7 5930K
Motherboard Asus Maximus V Extreme
Cooling Thermalright True Spirit 140 BW Rev.A
Memory Corsair Dominator Platinum ROG
Video Card(s) nVidia GTX 1080 SLI with EVGA Hybrid coolers.
Storage Samsung 960 Pro / Crucial MX300 750GB / Seagate 1TB Spinner
Display(s) Sony 43" 4K 60hz
Case SilverStone Temjin TJ11
Audio Device(s) Realtek on board > Sony Receiver > Cerwin Vega's
Power Supply Thermaltake TPSG 1050W
Mouse Always Changing
Keyboard Always Changing
Software Windows 10 Pro 64
#3
fails to load in chrome for me as well...IDK why though.