• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GPU bios flash

Vincentm

New Member
Joined
Sep 9, 2018
Messages
2 (0.03/day)
Likes
1
#1
Hello, Im wanting to flash a bios to my MSI Vega 56 airboost OC card to the Vega 64 bios using a BIOS for an MSI Vega 64 Airboost OC. Is this the correct one?

I tried doing so via the guide here, but when im in DOS and type in "atiflash -i"
I get "no adapter found"
The board i have is an MSI X470 gaming plus. If that helps. It was on board graphics...i aslo have the BIOS swith set to 1

And nothing is overclocked.
 
Joined
Feb 2, 2015
Messages
2,023 (1.46/day)
Likes
1,672
Location
On The Highway To Hell \m/
#2
Is it showing up in Device Manager. If it isn't, there's your problem. It's not being detected by the system. If it is showing up in Device Manager, you have bigger problems.

Best/easiest way to do it is to use the card as the primary graphics adapter(connected to the monitor). And use the latest ATIWinflash(GUI not DOS). I've flashed a million times from within Windows with ATIWinflash. Never had a problem. As such, I don't subscribe to the "DOS is safer" theory. And if you have dual BIOS, there's nothing about it that's "safer".
 

Vincentm

New Member
Joined
Sep 9, 2018
Messages
2 (0.03/day)
Likes
1
#3
Resolution: Opened command prompt with elevated permissions (administrator). And di so through there, using the ATIflash exec by typing
Atiflash -i -p <filename>
Rebooted, clean reinstall of drivers, success
 
Top