1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GPU-Z does not run on Gentoo Linux

Discussion in 'GPU-Z' started by Shining Arcanine, May 26, 2010.

  1. Shining Arcanine New Member

    May 26, 2010
    1 (0.00/day)
    Thanks Received:
    I registered for an account just to post this. I run KDE under Gentoo Linux on my laptop and I wanted to run GPU-Z after seeing it being it used in a review at xbitlabs.com, but it seems that GPU-Z does not run on Linux.

    I even tried running GPU-Z under WINE 1.1.44. The splash screen appeared on the screen and a moment later, an error dialog box appeared saying "Could not start driver: Service request timeout". After clicking "OK", the splash screen disappeared and another error dialog box appeared saying "Could not stop driver: Invalid service control". The program then terminated upon clicking "OK".

    I have attached the output of WINE to stderr to this post. I also posted it under a bug report in the WINE bug tracker:


    It is customary to post the contents of emerge --info on Gentoo Linux's bug tracker, so here is emerge --info for my system:

    $ emerge --info
    Portage (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11.1-r0, 2.6.34 i686)
    System uname: Linux-2.6.34-i686-Genuine_Intel-R-_CPU_T2400_@_1.83GHz-with-gentoo-2.0.1
    Timestamp of tree: Wed, 26 May 2010 20:00:01 +0000
    ccache version 2.4 [enabled]
    app-shells/bash:     4.1_p7
    dev-java/java-config: 2.1.11
    dev-lang/python:     2.6.5-r2, 3.1.2-r3
    dev-util/ccache:     2.4-r8
    dev-util/cmake:      2.8.1-r1
    sys-apps/baselayout: 2.0.1
    sys-apps/openrc:     0.6.1-r1
    sys-apps/sandbox:    2.2
    sys-devel/autoconf:  2.13, 2.65
    sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
    sys-devel/binutils:  2.20.1-r1
    sys-devel/gcc:       4.4.3-r2
    sys-devel/gcc-config: 1.4.1
    sys-devel/libtool:   2.2.7b
    virtual/os-headers:  2.6.33
    ACCEPT_KEYWORDS="x86 ~x86"
    CFLAGS="-O2 -march=prescott --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -pipe -fomit-frame-pointer"
    CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
    CPPFLAGS="-O2 -march=prescott --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -pipe -fomit-frame-pointer"
    CXXFLAGS="-O2 -march=prescott --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -pipe -fomit-frame-pointer"
    FEATURES="assume-digests buildpkg ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
    FFLAGS="-O2 -march=prescott --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -pipe -fomit-frame-pointer"
    GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.netnitco.net http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/vmware /var/lib/layman/java-overlay /usr/local/portage"
    USE="X acpi alsa apm berkdb bzip2 cdr cli consolekit cracklib crypt cups cxx dbus dri dvd dvdr fftw fortran gd gdbm gif gnutls gpm hal iconv ipv6 java java6 jpeg kde lzma midi mmap mmx mng modules mp3 mudflap ncurses networkmanager nls nptl nptlonly nsplugin opengl openmp pam pcre perl png pppd python qt3 qt3support qt4 readline reflection samba session spl sqlite sse sse2 sse3 ssl svg sysfs tcpd threads tiff unicode vorbis x264 x86 xml xorg xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" NETBEANS_MODULES="*" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
    While I am sure that the WINE project will try to address this, is there any possibility that the issue of Linux compatibility could be resolved natively by producing a version of GPU-Z that relies upon the Qt libraries and UNIX system interfaces?

    This issue affects Mac OS X as well as Linux. A port using the Qt libraries and POSIX should enable things to work on Mac OS X as well:


    If the developers would be so kind to open source this program, I am sure that there are people who would be willing to do this for them.

    Attached Files:

  2. W1zzard

    W1zzard Administrator Staff Member

    May 14, 2004
    16,959 (3.43/day)
    Thanks Received:
    no plans for a linux build, sorry
    10 Year Member at TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)