• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GPU-Z Lookup Graphics Card not Found..

QRbrewer21

New Member
Joined
Dec 14, 2021
Messages
3 (0.02/day)
Hi guys, I'm kinda new here but I have a question...
So I bought a Rog Strix 3080 OC 10 Gaming from Newegg (shipped from chinese retailer). However, when I run GPU-Z Lookup, I get this: https://www.techpowerup.com/gpu-spe...2216-1043:882E.A1.10240.1440.1905.hNN5GYEA4ks

I ran a validation too, and it seems the VBIOS is 94.02.71.40.9B, which doesn't seem to match ANY VBIOS driver online except on TPU. ASUS website is useless for bios and firmware lookup too.
However, on TPU, it shows it as an unverified bios, with 2 uploads.

I'm kind of concerned that maybe I got screwed over and this isn't a 3080. I tried looking on forums but most threads are about mismatching lookups. Help?

See GPU-Z snapshot as well.

gpuz1.gif
 
Joined
Apr 28, 2011
Messages
938 (0.23/day)
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO/Intel Box cooler/Intel Box cooler
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2x1TB ADATA SSDs in RAID0+3 HDDs/2xCrucial 1TB SSDs in RAID0+3 HDDs/Samsung 1TB SSD+8TB+4TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Win10 64-bit (Main PC v.1809 RTM Enterprise/2nd PC v.1903 Insider Preview Pro/3rd PC - same as 2nd)
Your screenshot is not readable. Attach it again?
 
Joined
Nov 7, 2009
Messages
4,254 (0.93/day)
Location
Denmark
System Name The work PC /4790 /2700x/2700x-1
Processor 3900X stock/ 2x2700x stock
Motherboard Gigabyte AORUS Master X570/2xMSI X470 M7 AC
Cooling Custom WC XSPC RX480, Laing DDC, XSPC Laing DDC Top V3 and EK Velocity/2xNH-U12S SE
Memory 16 GB Trident Z F4-4000C18D-16GTZSW 3800/16, 32GB XSkill Flare CL14 3200/16GB Viper 3466/14
Video Card(s) 2070 Super X MSI/AMD 7770/ GTX 970 MSI
Storage 1 TB SSD / 250/500 GB SSD
Display(s) Dell UltraSharp U2518D/2408WFP
Case Corsair 800D / Lian test bench/NZXT 500
Power Supply AX 850 Titanium/AX 860i/AX 760
Software Dual boot/Win 7 & 10 / Linux
Your screenshot is not readable. Attach it again?
How did the red warning on top of this site escape you? :D
 
Joined
Apr 28, 2011
Messages
938 (0.23/day)
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO/Intel Box cooler/Intel Box cooler
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2x1TB ADATA SSDs in RAID0+3 HDDs/2xCrucial 1TB SSDs in RAID0+3 HDDs/Samsung 1TB SSD+8TB+4TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Win10 64-bit (Main PC v.1809 RTM Enterprise/2nd PC v.1903 Insider Preview Pro/3rd PC - same as 2nd)
Sorry, no idea what you are talking about?

I am not seeing any red warnings.
Also, my browser ad-blocker uBlock Origin is fully disabled for this site?!
So, if you are assuming something about my ad-blocker, that is not it.
Something else is amiss.
 
Joined
Nov 7, 2009
Messages
4,254 (0.93/day)
Location
Denmark
System Name The work PC /4790 /2700x/2700x-1
Processor 3900X stock/ 2x2700x stock
Motherboard Gigabyte AORUS Master X570/2xMSI X470 M7 AC
Cooling Custom WC XSPC RX480, Laing DDC, XSPC Laing DDC Top V3 and EK Velocity/2xNH-U12S SE
Memory 16 GB Trident Z F4-4000C18D-16GTZSW 3800/16, 32GB XSkill Flare CL14 3200/16GB Viper 3466/14
Video Card(s) 2070 Super X MSI/AMD 7770/ GTX 970 MSI
Storage 1 TB SSD / 250/500 GB SSD
Display(s) Dell UltraSharp U2518D/2408WFP
Case Corsair 800D / Lian test bench/NZXT 500
Power Supply AX 850 Titanium/AX 860i/AX 760
Software Dual boot/Win 7 & 10 / Linux
Just stop asking people to upload pictures again. The site have problems and so has your set-up it seems. TPU run in safe-mode, changes are not saved and that seem to affect picture upload. @Naki
 
Joined
Apr 28, 2011
Messages
938 (0.23/day)
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO/Intel Box cooler/Intel Box cooler
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2x1TB ADATA SSDs in RAID0+3 HDDs/2xCrucial 1TB SSDs in RAID0+3 HDDs/Samsung 1TB SSD+8TB+4TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Win10 64-bit (Main PC v.1809 RTM Enterprise/2nd PC v.1903 Insider Preview Pro/3rd PC - same as 2nd)
Just stop asking people to upload pictures again. The site have problems and so has your set-up it seems. TPU run in safe-mode, changes are not saved and that seem to affect picture upload. @Naki

Okay, get it now. Will do.
Hopefully they will sort out the website proper operation soon!

(Website failure? Images don't load? WTH - very strange, 2022 is almost here, how does such a website "FAIL" this way nowadays?!
Seems like deja-vu and it being year 1999 again. :) Hope it is nothing serious (total failure of storage, ransomware?) and full operation will be back online soon. )

EDIT: Nope, my setup is just fine, and has had no problems for years.
Using a vintage Intel Haswell Core i3 CPU (2 cores/4 threads) system on this PC -- nothing is wrong with it, nor has been for years now. It serves me well. :)
And it has been upgraded a few times too, now with a big 2 TB Crucial SSD as one of the latest upgrades.

(I have 2 other PCs too, which are used less rarely and/or are used for additional tasks.
I must say I used to have issues due to the bad quality of Windows 10 updates, but this was last 1-2+ years ago..)
 
Last edited:
Joined
Aug 22, 2010
Messages
598 (0.14/day)
Location
Germany
System Name Acer Nitro 5 (AN515-45-R715)
Processor AMD Ryzen 9 5900HX
Motherboard AMD Promontory / Bixby FCH
Cooling Acer Nitro Sense
Memory 32 GB
Video Card(s) AMD Radeon Graphics (Cezanne) / NVIDIA RTX 3080 Laptop GPU
Storage WDC PC SN530 SDBPNPZ
Display(s) BOE CQ NE156QHM-NY3
Software Windows 11 beta channel
I'm kind of concerned that maybe I got screwed over and this isn't a 3080. I tried looking on forums but most threads are about mismatching lookups. Help?

Get NVFlash from TPU's downloads
Run
nvflash64.exe --version >output.txt
Copy the content of output.txt and paste it here.
(And don't fool around with NVFlash's write operations)

It should look similar to the output from my RTX 3080 mobile (except from the device id)

Code:
NVIDIA Firmware Update Utility (Version 5.728.0)
Copyright (C) 1993-2021, NVIDIA Corporation. All rights reserved.

Sign-On Message       : E4735 SKU 10 VGA BIOS
Build GUID            : 2621B080AC87492FB5FE101EF72F5C8D
IFR Subsystem ID      : 10DE-0000
Subsystem Vendor ID   : 0x10DE
Subsystem ID          : 0x0000
Version               : 94.04.35.00.33
Image Hash            : N/A
Product Name          : GPU Board
Device Name(s)        : Graphics Device
Board ID              : 0x0262
Vendor ID             : 0x10DE
Device ID             : 0x249C
Hierarchy ID          : Normal Board
Chip SKU              : 775-1
Project               : 4735-0010-Q
Build Date            : 10/15/20
Modification Date     : 01/20/21
UEFI Version          : 0x60009 ( x64 )
UEFI Variant ID       : 0x000000000000000A ( GA1xx )
UEFI Signer(s)        : Microsoft Corporation UEFI CA 2011
XUSB-FW Version ID    : N/A
XUSB-FW Build Time    : N/A
InfoROM Version       : G001.0000.03.03
InfoROM Backup        : Present
License Placeholder   : Present
GPU Mode              : N/A
CEC OTA-signed Blob   : Not Present


EDIT:
otherwise get ASUS GPU Tweak II from your GPU's support site
It should be able to identify a legit ASUS GPU
You need it anyway if your GPU comes with fancy LED's
 
Last edited:

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
24,049 (3.65/day)
Processor Core i7-8700K
Memory 32 GB
Video Card(s) RTX 3080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 10 64-bit
I just checked, our lookup works for the older version without low-hash-rate.

I suspect your card is a newer revision based on the LHR GPU. Please post a GPU-Z screenshot and the packaging if you can
 

QRbrewer21

New Member
Joined
Dec 14, 2021
Messages
3 (0.02/day)
gpuz1.gif


Get NVFlash from TPU's downloads
Run
nvflash64.exe --version >output.txt
Copy the content of output.txt and paste it here.
(And don't fool around with NVFlash's write operations)

It should look similar to the output from my RTX 3080 mobile (except from the device id)

Code:
NVIDIA Firmware Update Utility (Version 5.728.0)
Copyright (C) 1993-2021, NVIDIA Corporation. All rights reserved.

Sign-On Message       : E4735 SKU 10 VGA BIOS
Build GUID            : 2621B080AC87492FB5FE101EF72F5C8D
IFR Subsystem ID      : 10DE-0000
Subsystem Vendor ID   : 0x10DE
Subsystem ID          : 0x0000
Version               : 94.04.35.00.33
Image Hash            : N/A
Product Name          : GPU Board
Device Name(s)        : Graphics Device
Board ID              : 0x0262
Vendor ID             : 0x10DE
Device ID             : 0x249C
Hierarchy ID          : Normal Board
Chip SKU              : 775-1
Project               : 4735-0010-Q
Build Date            : 10/15/20
Modification Date     : 01/20/21
UEFI Version          : 0x60009 ( x64 )
UEFI Variant ID       : 0x000000000000000A ( GA1xx )
UEFI Signer(s)        : Microsoft Corporation UEFI CA 2011
XUSB-FW Version ID    : N/A
XUSB-FW Build Time    : N/A
InfoROM Version       : G001.0000.03.03
InfoROM Backup        : Present
License Placeholder   : Present
GPU Mode              : N/A
CEC OTA-signed Blob   : Not Present


EDIT:
otherwise get ASUS GPU Tweak II from your GPU's support site
It should be able to identify a legit ASUS GPU
You need it anyway if your GPU comes with fancy LED's
I'll go ahead and do that
 

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
24,049 (3.65/day)
Processor Core i7-8700K
Memory 32 GB
Video Card(s) RTX 3080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 10 64-bit
Lookup should be working correctly now, I also marked that BIOS upload as verified
 

QRbrewer21

New Member
Joined
Dec 14, 2021
Messages
3 (0.02/day)
Lookup should be working correctly now, I also marked that BIOS upload as verified
Thank you! Does that mean I should be okay? Reason I asked is that my brother also got a 3080 card from china and on GPU-Z it showed a GTX 980, so I was sweating about my card! lol
 

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
24,049 (3.65/day)
Processor Core i7-8700K
Memory 32 GB
Video Card(s) RTX 3080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 10 64-bit
I'm not seeing anything that would suggest that your card isn't a 3080. All good
 
Top