• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GPUZ reports my BFG GeForce 7600 OC GS AGP as as G71 when I expect it should be a G70

Joined
Apr 21, 2011
Messages
42 (0.01/day)
Location
England
System Name \\RED
Processor Intel Core i9 Extreme 9980XE (Skylake-X)
Motherboard ASUS WS X299 Sage
Memory 128GB - 8 x 16GB - 1 x CMR64GX4M4A2666C16 + 2 x CMR32GX4M2A2666C16
Video Card(s) 1 x GeForce RTX 3080 + 1 x GeForce RTX 2080 + 1 x GeForce GT 1030
Storage 1 x Intel SSDPEKNW010T9 + 5 x Intel SSDPEKKW256G8 + 1 x Intel SSDPED1D280GA + 6 x Samsung 860 EVO
Display(s) 2 x Dell UP3017 (DP) + 1 x Dell 2407WFP (Digital) + 1 x Dell 2007FP (Digital)
Power Supply Thermaltake TPG-1250D-T
Software Windows 10 x64 Enterprise V10.00 Build 19044 21H2
I just added a BFG GeForce 7600 OC GS AGP to my collection and was rather surprised when GPUZ reported it as a G71. I think this is incorrect for the following reasons:
  1. The BFG GeForce 7600 OC GS AGP was released on 02-Feb-2006, see https://www.neoseeker.com/Articles/Hardware/Reviews/bfg7800gs_agp/
  2. The G71 was released on 28-Sep-2006, see https://www.techpowerup.com/gpu-specs/?generation=GeForce 7 AGP&memsize=256 MB&interface=AGP 8x&sort=generation
  3. NvAPI_GPU_GetShortName() reports G70
  4. NaAPI_GPU_GetArchInfo() reports 040 07 A1 which is a G70, G71 would start 040 09
  5. The NVidia Chip ID is 0x047300A1 which is a G70, G71 would start 0x049
  6. It says G70 at offset 0x1E8 in a dump of the BIOS.
  7. A dump from https://www.techpowerup.com/vgabios...nterface=AGP&memType=GDDR3&memSize=256&since= says G71 at offset 0x19F in the BIOS.
Should GPUZ report G70 and if so would you like me to validate a fixed version ?

BTW this is another AGP card that GPUZ reports as supporting Resizable BAR, this time on W7 x32. It also reports the CPU core temperature as 100°C when P4s don't report their core temperatures, only Core 2 and later do.

G70 [GeForce 7800 GS AGP].png

GeForce 7800 GS AGP VGA BIOS G70 Board - p492n0.png
GeForce 7800 GS AGP VGA BIOS G71 Board - p492h2.png

I remembered that MSR 0x019C has a reading valid bit 31 which as I expected is not set. Given this GPUZ should not report a CPU temperature.

It's strange that given the clocks are @ 0 MHz and the memory @ 0 MB the plots look to be at 100%

RP4-W10.png
 
Last edited:
Top