• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Green Screen of Death & Confusion.

Joined
Apr 30, 2008
Messages
4,574 (1.00/day)
Location
Multidimensional
System Name PC Mustard Race
Processor AMD Ryzen 5 4600H
Motherboard Asus Laptop OEM AM4
Cooling Internal Laptop Cooling
Memory 16GB Crucial 3200Mhz
Video Card(s) GTX 1650 Ti 4GB + Intergrated Vega GPU
Storage 512GB Crucial M.2 / 2TB Seagate 2.5in HDD
Display(s) 144hz Laptop IPS Panel 1080p
Case Laptop Chassis
Audio Device(s) Realtek Laptop Trash
Power Supply Power brick
Mouse CoolerMaster Masterkeys Lite L RGB Mem-Chanical Combo + Touch Pad
Keyboard Laptop RGB KB
Software Windows 10 Home 64bit
Benchmark Scores Don't do em anymore.
Hey guys, I've gotten this random green screen randomly out of nowhere twice so far. First time was a week ago during a Starcraft II session & then now today randomly just surfing the web, I power cycle & then it's back to normal. Just updated to the latest AMD drivers to see if that will solve it, will have to play the waiting game on that. Has anyone experience this at all? :(

green screen of bs.jpg
 
Joined
Aug 12, 2019
Messages
446 (0.94/day)
System Name Custom
Processor i9 9900k
Motherboard Gigabyte Z390 arous master
Cooling corsair h150i
Memory 4x8 3200mhz corsair
Video Card(s) Galax RTX 3090 EX Gamer White OC
Storage 500gb Samsung 970 Evo PLus
Display(s) MSi MAG341CQ
Case Lian Li Pc-011 Dynamic
Audio Device(s) Arctis Pro Wireless
Power Supply 850w Seasonic Focus Platinum
Mouse Logitech G403
Keyboard Logitech G110
maybe loose cable?
 
Joined
Dec 29, 2010
Messages
1,548 (0.43/day)
Display port? Just in case, sometimes the female port will wear and get loose. I just use a razor or thin flat head and push the thin frame of the port so it makes a snug connection again. Before realizing that the female ports can get enlarge, I went thru a bazilion things pulling my hair out.
 
Joined
Apr 30, 2008
Messages
4,574 (1.00/day)
Location
Multidimensional
System Name PC Mustard Race
Processor AMD Ryzen 5 4600H
Motherboard Asus Laptop OEM AM4
Cooling Internal Laptop Cooling
Memory 16GB Crucial 3200Mhz
Video Card(s) GTX 1650 Ti 4GB + Intergrated Vega GPU
Storage 512GB Crucial M.2 / 2TB Seagate 2.5in HDD
Display(s) 144hz Laptop IPS Panel 1080p
Case Laptop Chassis
Audio Device(s) Realtek Laptop Trash
Power Supply Power brick
Mouse CoolerMaster Masterkeys Lite L RGB Mem-Chanical Combo + Touch Pad
Keyboard Laptop RGB KB
Software Windows 10 Home 64bit
Benchmark Scores Don't do em anymore.
Oh yeah my bad, I forgot to mention I'm using a standard HDMI cable, connected to a 1080p HDTV. Yup I've checked the cable for being lose, looks fine to me. :/
 
Joined
Mar 18, 2008
Messages
5,384 (1.16/day)
System Name Virtual Reality / Bioinformatics
Processor Undead CPU
Motherboard Undead TUF X99
Cooling Noctua NH-D15
Memory GSkill 128GB DDR4-3000
Video Card(s) EVGA RTX 3090 FTW Ultra
Storage Samsung 960 Pro 1TB + 860 EVO 2TB + WD Black 5TB
Display(s) Acer K272HUL, HTC Vive
Case Fractal Design R5
Audio Device(s) BOSE 2.0
Power Supply Seasonic 850watt
Mouse Logitech Master MX
Keyboard Corsair K70 Cherry MX Blue
Software Windows 10 Professional/Linux Mint
5700XT I assume? Any overclocking? What's the temperature and hot spot temperature like?
 
Joined
Nov 13, 2007
Messages
8,108 (1.70/day)
Location
Austin Texas
System Name _
Processor 8700K @ 5.1 24/7
Motherboard MSI Z370-A PRO
Cooling 120mm Custom Liquid
Memory 32 GB 4000 Mhz DDR4 17-18-18-36-400 trfc - 2T
Video Card(s) GTX 2080 Ti (Undervolted OC 1925MHz)
Storage 3x1TB SSDs
Display(s) LG 49NANO85 - 49" 4K 120HZ NanoIPS
Case Jonsbo U4
Audio Device(s) Bose Solo
Power Supply Corsair SF750
Mouse Logitech GPro Wired
Keyboard Penclic C3
Software Windows 10 64 Bit
looks like a signal problem, hopefully cable if not tv :/

Next time instead of cycling it try to unplug and replug the cable.
 
Joined
Apr 30, 2008
Messages
4,574 (1.00/day)
Location
Multidimensional
System Name PC Mustard Race
Processor AMD Ryzen 5 4600H
Motherboard Asus Laptop OEM AM4
Cooling Internal Laptop Cooling
Memory 16GB Crucial 3200Mhz
Video Card(s) GTX 1650 Ti 4GB + Intergrated Vega GPU
Storage 512GB Crucial M.2 / 2TB Seagate 2.5in HDD
Display(s) 144hz Laptop IPS Panel 1080p
Case Laptop Chassis
Audio Device(s) Realtek Laptop Trash
Power Supply Power brick
Mouse CoolerMaster Masterkeys Lite L RGB Mem-Chanical Combo + Touch Pad
Keyboard Laptop RGB KB
Software Windows 10 Home 64bit
Benchmark Scores Don't do em anymore.
5700XT I assume? Any overclocking? What's the temperature and hot spot temperature like?
Yeah Sapphire's RX 5700 XT Nitro+ one, no overclocking at all I just left it at it's default settings, I've been monitoring temps with HWiNFO but only the normal GPU temperature not the hot spot/junction one nor the memory temps, GPU temps are fine for the most part, depending on the game it ranges around 75C - 80C (My case can be a hot box)

looks like a signal problem, hopefully cable if not tv :/

Next time instead of cycling it try to unplug and replug the cable.
No worries I'll try that next time.
 
Joined
Mar 9, 2018
Messages
55 (0.06/day)
I had the exact same issue just yesterday. I turned on the pc and left for a couple of minutes, only to come back to a green screen.
I inmediatly restarted the pc and the picture was fine while going through the boot stages, then desktop shows up, i click firefox, then bam, white screen of death (same as OP's green but all white).
I restart again, but this time as soon as it gets to the desktop, i go to msi afterburner and set my gpu settings to stock (it was OCed) i had no problems since, will try to OC later again and see if the issue pops up again.
I should note that i am using an hdmi cable and i haven't touched it, wiggled it, or disconnected it, or even slightly move the case. I have no reason to think that was the problem (for me atleast).
 
Joined
Jul 25, 2006
Messages
7,691 (1.47/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
If Vader's solution does not help, I would try a different monitor before getting too deep into troubleshooting the computer or graphics solution - just to eliminate the monitor from the equation.
 
Low quality post by Jetster
Joined
Jan 17, 2010
Messages
11,563 (2.91/day)
System Name Delta // HTPC
Processor Intel i7 6700K // Intel i5 4570
Motherboard GIGABYTE Z270X-Gaming K7 // Gigabyte H97M -D3H
Cooling Corsair H80i V2 // Silverstone NT-06 Pro
Memory Corsair DDR4 3600 32gb //G.SKILL Ripjaws X Series 8GB 1600
Video Card(s) EVGA GeForce RTX 2080 XC ULTRA GAMING// EVGA GTX 1050 ti
Storage Samsung 950 Pro NVMe 512 Intel 665 Tb, 2 Tb FireCuda// Samsung 1Tb SSD
Display(s) ASUS VP348QGL 34" Quad HD 3440 x 1440 // 55" LG 4K SK8000 Series
Case Corsair Obsidian Series 550D // Silverstone Granada GD05
Audio Device(s) Focusrite Scarlett // HDMI to Samsung HW-R650 sound bar
Power Supply Corsair TX850M // SeaSonic G Series 550w
Mouse Cooler Master MM710 53G
Keyboard Logitech 920-009300 G512 SE
Software Windows 10 Pro // Windows 10 Pro
Low quality post by Vader
Low quality post by R-T-B
Joined
Aug 20, 2007
Messages
13,748 (2.83/day)
System Name Pioneer
Processor Intel i9 9900k
Motherboard ASRock Z390 Taichi
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory G.SKILL TridentZ Series 32GB (4 x 8GB) DDR4-3200 @ 14-14-14-34-2T
Video Card(s) EVGA GeForce RTX 2080 SUPER XC ULTRA
Storage Mushkin Pilot-E 2TB NVMe SSD
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) VGA HDMI->Panasonic SC-HTB20/Schiit Modi MB/Asgard 2 DAC/Amp to AKG Pro K7712 Headphones
Power Supply Seasonic Prime Titanium 750W
Mouse ROCCAT Kone EMP
Keyboard WASD CODE 104-Key w/ Cherry MX Green Keyswitches, Doubleshot Vortex PBT White Transluscent Keycaps
Software Windows 10 Enterprise (Product of work, yes it's legit)
Benchmark Scores www.3dmark.com/fs/23478641 www.3dmark.com/spy/13863605 www.3dmark.com/pr/306218

notVladel

New Member
Joined
Feb 4, 2020
Messages
15 (0.05/day)
Hi,

I am having the exactly same issue but with 5600 XT, not 5700 XT. Have you solved the issue in any way?
 
Joined
Sep 3, 2019
Messages
1,669 (3.68/day)
Location
Thessaloniki, Greece
System Name PC alive since Aug 18th 2019
Processor Ryzen 5 3600 (PBO Enabled)
Motherboard Gigabyte X570 Aorus Pro, BIOS F22
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory CorsairVengeanceLPX DDR4 2x8GB 3466MHz CL16-18-18-36 1T, B-die A0 PCB, @3800 CL16-18-18-36 1T(1.46V)
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB (2019) / SATA-III: 850Pro 1TB SSD (2017), 860Evo 1TB SSD (2020)
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA 14-bit (16.7M/1.06B colors), 6ms G2G
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W
Power Supply Corsair HX750i
Mouse Logitech MX Master
Keyboard Logitech G15 v2
Software Windows 10 Home 64bit (v2004)
When this color screen occurs try to unplug and replug the cable/adapter from the card, or move it around in case of misconnection.

I have MSI 5700XT GamingX
I also have an adaptor, HDMI(card output) to DVI(cable/monitor input) ...and the first day I plug it I had similar issues from the cable weight. Once I changed the rout of it and supported it’s weight the issue never happen again.
You should think also to change the cable with a new one just in case. A quality one...
 

notVladel

New Member
Joined
Feb 4, 2020
Messages
15 (0.05/day)
Hmm, okay. Thing is If the restart button on my PC isn't responding to this, but If I hold the power button and shut down the PC, after turning it on it works. I shall give this a try (tho' when it crashes I lose audio as well)
 
Joined
Sep 3, 2019
Messages
1,669 (3.68/day)
Location
Thessaloniki, Greece
System Name PC alive since Aug 18th 2019
Processor Ryzen 5 3600 (PBO Enabled)
Motherboard Gigabyte X570 Aorus Pro, BIOS F22
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory CorsairVengeanceLPX DDR4 2x8GB 3466MHz CL16-18-18-36 1T, B-die A0 PCB, @3800 CL16-18-18-36 1T(1.46V)
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB (2019) / SATA-III: 850Pro 1TB SSD (2017), 860Evo 1TB SSD (2020)
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA 14-bit (16.7M/1.06B colors), 6ms G2G
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W
Power Supply Corsair HX750i
Mouse Logitech MX Master
Keyboard Logitech G15 v2
Software Windows 10 Home 64bit (v2004)
Hmm, okay. Thing is If the restart button on my PC isn't responding to this, but If I hold the power button and shut down the PC, after turning it on it works. I shall give this a try (tho' when it crashes I lose audio as well)
This is clearly a crash and not some cable misconnection....
 

notVladel

New Member
Joined
Feb 4, 2020
Messages
15 (0.05/day)
Yeah, that's what I'm saying :)) The driver crashes, alongside with the PC. Oh well, I shall wait for OP to reply or AMD come with a fix.
 
Joined
Apr 30, 2008
Messages
4,574 (1.00/day)
Location
Multidimensional
System Name PC Mustard Race
Processor AMD Ryzen 5 4600H
Motherboard Asus Laptop OEM AM4
Cooling Internal Laptop Cooling
Memory 16GB Crucial 3200Mhz
Video Card(s) GTX 1650 Ti 4GB + Intergrated Vega GPU
Storage 512GB Crucial M.2 / 2TB Seagate 2.5in HDD
Display(s) 144hz Laptop IPS Panel 1080p
Case Laptop Chassis
Audio Device(s) Realtek Laptop Trash
Power Supply Power brick
Mouse CoolerMaster Masterkeys Lite L RGB Mem-Chanical Combo + Touch Pad
Keyboard Laptop RGB KB
Software Windows 10 Home 64bit
Benchmark Scores Don't do em anymore.
Just got your message Vladel. The green screen issue did go away for me & the 3 main things I did was, re-seat the GPU, update drivers & I changed the HDMI cable around to a better one, problem went away. Not 100% what fixed it but I'm aiming towards the trash HDMI cable I was using. I hope you get issue sorted out, nothing more annoying than PC hardware/software issues.
 
Last edited:
Joined
Jul 5, 2013
Messages
11,224 (4.15/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Hey guys, I've gotten this random green screen randomly out of nowhere twice so far. First time was a week ago during a Starcraft II session & then now today randomly just surfing the web, I power cycle & then it's back to normal. Just updated to the latest AMD drivers to see if that will solve it, will have to play the waiting game on that. Has anyone experience this at all? :(

View attachment 136410
That's a new one. What did you do to it?
 
Joined
Dec 22, 2011
Messages
3,350 (1.03/day)
System Name I'm sorry Dave, I'm afraid I can't do that.
Processor AMD Ryzen 7 3700X
Motherboard MSI MAG B550 TOMAHAWK
Cooling AMD Wraith Prism
Memory Team Group Dark Pro 8Pack Edition 3600Mhz CL16
Video Card(s) Palit GTX 980 Ti Super JetStream
Storage Kingston A2000 1TB + Seagate HDD workhorse
Display(s) Crossover 27Q 27" 2560x1440 + Hisense 43" 4K
Case Antec 1200
Audio Device(s) Don't be silly
Power Supply XFX 650W Core
Mouse Razer Deathadder Chroma
Keyboard Logitech UltraX
Software Windows 10
Benchmark Scores Epic
Navi certainly is exciting, each day... something new.
 
Joined
Jun 7, 2019
Messages
186 (0.34/day)
System Name Times Killer
Processor Ryzen 9 3900X
Motherboard MSI B450-A Pro rev. 2.0
Cooling Corsair H110 Extreme Performance AIO
Memory 2x 8gb Corsair 3200 mhz LPX for Ryzen @ 3733mhz 16-16-16-38
Video Card(s) EVGA GTX 1070Ti ACX 3.0 +223/455/ Asus Strix Vega 56 Gaming OC 1650/890mhz 1060mw
Storage 2 X 1TB WD's 1X 4gb WB red 1x LG WH16NS40 16x blu-ray writer
Display(s) HP Omen X 27
Case Corsair Obsidian 750D W/ airflow kit
Audio Device(s) SoundblasterX AE-5 / Asus Xonar DX
Power Supply Carsair 850-M
Mouse Logitech Proteus spectrum G502
Keyboard Logitech G213 Prodigy
Software Windows 10 home
both look like video card was loose, same thing happened on my 1070ti.
 
Joined
Apr 30, 2008
Messages
4,574 (1.00/day)
Location
Multidimensional
System Name PC Mustard Race
Processor AMD Ryzen 5 4600H
Motherboard Asus Laptop OEM AM4
Cooling Internal Laptop Cooling
Memory 16GB Crucial 3200Mhz
Video Card(s) GTX 1650 Ti 4GB + Intergrated Vega GPU
Storage 512GB Crucial M.2 / 2TB Seagate 2.5in HDD
Display(s) 144hz Laptop IPS Panel 1080p
Case Laptop Chassis
Audio Device(s) Realtek Laptop Trash
Power Supply Power brick
Mouse CoolerMaster Masterkeys Lite L RGB Mem-Chanical Combo + Touch Pad
Keyboard Laptop RGB KB
Software Windows 10 Home 64bit
Benchmark Scores Don't do em anymore.
Joined
Aug 20, 2007
Messages
13,748 (2.83/day)
System Name Pioneer
Processor Intel i9 9900k
Motherboard ASRock Z390 Taichi
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory G.SKILL TridentZ Series 32GB (4 x 8GB) DDR4-3200 @ 14-14-14-34-2T
Video Card(s) EVGA GeForce RTX 2080 SUPER XC ULTRA
Storage Mushkin Pilot-E 2TB NVMe SSD
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) VGA HDMI->Panasonic SC-HTB20/Schiit Modi MB/Asgard 2 DAC/Amp to AKG Pro K7712 Headphones
Power Supply Seasonic Prime Titanium 750W
Mouse ROCCAT Kone EMP
Keyboard WASD CODE 104-Key w/ Cherry MX Green Keyswitches, Doubleshot Vortex PBT White Transluscent Keycaps
Software Windows 10 Enterprise (Product of work, yes it's legit)
Benchmark Scores www.3dmark.com/fs/23478641 www.3dmark.com/spy/13863605 www.3dmark.com/pr/306218
I forgot about this thread.

I had this problem occasionally when overclocking Navi. I think it has something to do with idle voltages but it really has no way to confirm that outside of just killing idle-mode, and seeing if it helps.

If anyone wants to test that, I have a kit that can do it. PM me.
 
Joined
Mar 18, 2008
Messages
5,122 (1.10/day)
Location
Australia
System Name Night Rider | Mini LAN PC | Workhorse
Processor AMD R7 2700X | Ryzen 1600X | i7 970
Motherboard MSi AM4 Pro Carbon | GA- | Gigabyte EX58-UD5
Cooling AMD Wraith cooler| Stock Cooler, Copper Core)| Big shairkan B
Memory 2x8GB DDR4 G.Skill Ripjaws 3600MHz| 2x8GB Corsair 3000 | 6x2GB DDR3 1300 Corsair
Video Card(s) ASUS GTX 970 OC in Sli | Inno3d GTX 1050 TI | MSI RX 580 8GB
Storage 250GB Plextor SSD Por 5 /1TB WD Black | 500GB SSD WD, 2x1TB, 1x750 | WD 320/Seagate 320
Display(s) LG 27" 1440P| Samsung 20" S20C300L/DELL 15" | 22" DELL/19"DELL
Case LIAN LI PC-18 | Mini ATX Case (custom) | Atrix C4 9001
Audio Device(s) Onboard | Onbaord | Onboard
Power Supply Silverstone 750 | Silverstone Mini 450W | Corsair CX-750
Mouse Coolermaster Pro | Rapoo V900 | Gigabyte 6850X
Keyboard MAX Keyboard Nighthawk X8 | Creative Fatal1ty eluminx | Some POS Logitech
Software Windows 7 Pro 64 | Windows 7 Pro 64 | Windows 7 Pro 64/Windows 10 Home
GSOD....Interesting :laugh:
 
Joined
Sep 17, 2014
Messages
13,826 (6.10/day)
Location
The Washing Machine
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Gigabyte G34QWC (34'' 3440x1440x)
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
Navi certainly is exciting, each day... something new.
That is what strikes me too. Not just with Navi either. I spot a trend here

And I think Jetster might be on to something, Low Quality or not.
 
Top