• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GTX 670 - Identify manufacturer

Joined
May 24, 2013
Messages
23 (0.01/day)
Processor i3570k @4.5
Motherboard Asus Maximus Gene V
Video Card(s) GTX670 SLI
Case Fractal Design Define Mini
Mouse Razer DeathAdder Chroma
Keyboard Steelseries Apex
Hi all. Hope someone can kill my curiosity :)

I bought this GTX670, second hand, a few years ago to pair with an EVGA 670 SC, at the time I didn't pay much attention to the fact that there isn't any brand (asus, zotac, whatever...). It paired well with the EVGA and the SLI worked flawlessly. Recently was checking GPU-Z and noticed that it identifies this cards vendor as PCPartner. I tried to google it but couldn't find anything.
So, who manufacter this card? Chinese OEM? :confused:

GPUZ-670.png
20210228_173152.jpg
 
Joined
Jun 23, 2014
Messages
671 (0.27/day)
Processor 3900X PBO (4.5 / 4.4 and lower on other cores)
Motherboard X570 Tomahawk
Cooling AMD Wraith Prism at 2000 RPM (Kyronaut Extreme) - Phoenix 240 with Vardar push-pull soon
Memory 2x16gb Crucial Ballistix 3600 CL16 dual rank
Video Card(s) Duke 2080 OC + 100 core / 250 memory OC
Storage Optane 280gb PCI-E + 980 Pro 500gb
Display(s) PG348Q
Case Core X71
Audio Device(s) ATOLL DAC 100SE, Sony DN1070 to Dali Ikon 1 MK2, QED banana cabling
Power Supply AX1500i
Mouse Projects Gaming S001
Keyboard Topre Realforce 87U with all 30g keys (black)
Software Win 10 Pro
They made some Nvidia boards like that, correct.

You're running the cards at PCI-E x8 1.1 btw.
 
Joined
May 24, 2013
Messages
23 (0.01/day)
Processor i3570k @4.5
Motherboard Asus Maximus Gene V
Video Card(s) GTX670 SLI
Case Fractal Design Define Mini
Mouse Razer DeathAdder Chroma
Keyboard Steelseries Apex
Thanks Wizz and X71200 for the quick replies.
I know it looks like the ref design, but is missing the green logo and green GEFORCE text, so it made me curious cause I never seen a OEM mid/high tier GPU. Also the BIOS is not on TPU database (submiting as i type) which denses the mistery :)

You're running the cards at PCI-E x8 1.1 btw.
Yes, SLI defaults both cards to x8.
 
Joined
Oct 22, 2014
Messages
11,682 (4.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
The stickers appear to have been removed and the sub system I.D. indicates the manufacturer was indeed Sapphire.
 
Joined
Jun 23, 2014
Messages
671 (0.27/day)
Processor 3900X PBO (4.5 / 4.4 and lower on other cores)
Motherboard X570 Tomahawk
Cooling AMD Wraith Prism at 2000 RPM (Kyronaut Extreme) - Phoenix 240 with Vardar push-pull soon
Memory 2x16gb Crucial Ballistix 3600 CL16 dual rank
Video Card(s) Duke 2080 OC + 100 core / 250 memory OC
Storage Optane 280gb PCI-E + 980 Pro 500gb
Display(s) PG348Q
Case Core X71
Audio Device(s) ATOLL DAC 100SE, Sony DN1070 to Dali Ikon 1 MK2, QED banana cabling
Power Supply AX1500i
Mouse Projects Gaming S001
Keyboard Topre Realforce 87U with all 30g keys (black)
Software Win 10 Pro
It's 1.1 which is even slower than 2.0, what I was trying to point at.
 
Joined
May 30, 2015
Messages
1,014 (0.47/day)
Location
Los Altos, CA
It's 1.1 which is even slower than 2.0, what I was trying to point at.

Auto negotiated idle link speed isn't load link speed. It'll bump up to read 2.0/3.0 depending on the board's capabilities and whether they are set to the higher link bandwidth in the BIOS.
 
Joined
May 24, 2013
Messages
23 (0.01/day)
Processor i3570k @4.5
Motherboard Asus Maximus Gene V
Video Card(s) GTX670 SLI
Case Fractal Design Define Mini
Mouse Razer DeathAdder Chroma
Keyboard Steelseries Apex
The stickers appear to have been removed and the sub system I.D. indicates the manufacturer was indeed Sapphire.
Regarding the stickers I don't know, already got the card as it is. About the manufacter beeing Saphhire, now that you mention it, I remember GPU-Z showing Sapphire when I first installed the card (in 2013), but I assumed it was a GPU-Z error since I never saw a Sapphire with nvidia GPU. From where did you figured the sub system I.D.?

Regarding the PCIe speed, Isaac and Fouquin are correct. It jumps to 3.0 when required.
Captura de ecrã 2021-03-01 144825.png
 
Joined
Oct 22, 2014
Messages
11,682 (4.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
10DE 1189 indicate Nvidia, the numbers following are the subsystem I.D numbers
 
Top