• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GTX 965m not working on laptop display

Status
Not open for further replies.
Joined
Nov 24, 2018
Messages
17 (0.04/day)
I've just upgraded my personal machine from HP 8560w (FullHD TN Panel) to Zbook 15 G2 UHD+ (3200 x 1800 IPS). The 8560w has been upgraded with GTX 965m MXM Type A graphic card for 1 year now and all running fine. Since I upgraded my machine I wanted to move the GTX 965m to the Zbook, since it is much better than the k2100m for the use I need (dont do any CAD or OpenGL intensive stuff). So I moved the GTX 965m to my new machine. However the laptop display would never light up. The laptop boots successfully, I can hear the Windows 10 loading sound, but screen is black. Putting bright light against it to see if its just the backlight not working due to missing drivers doesnt show any picture at all (like it did on the 8560w.

However when I connect the laptop to a docking station, then the external monitor lights up successfully and I can login, install the Nvidia modified drivers for this laptop and the GTX 965m is recognized successfully in Windows 10 Pro. As soon as I undock the laptop, its display still does not work, although correct drivers installed now. Already watched this video (
) and I thoroughly checked BIOS, but my model/variation Zbook does not appear to have Hybrid graphics option in it (I later found info on various forums that Nvidia Optimus does not work on HP DreamColor displays). Although my display is not DreamColor, I assume it is the UHD+ resolution that is most likely the reason for Optimus not being supported. Anyway, although Optimus would have been nice for battery saving, I dont care for it, I just want to get the laptop display working with the GTX 965m graphics card.

I also installed the k2100m on the 8560w laptop and the result is even worse - no output neither on laptop display, nor on external monitor through docking station. So with all of that said, I would assume it is eDP/LVDS issue. Question is, can I make the GTX 965m card output eDP signal to the laptop display? Flashing a vbios maybe? If I understand correctly info I came upon, all graphic cards prior Pascal support both eDP and LVDS, but its not both simultaneously, only one is enabled and working.

I would appreciate any help I could get on this, as I was going to primary use this machine as laptop and only occasionally dock it.

P.S. If you're going to suggest I get 1050Ti or P1000 graphic cards, please provide links where I can buy them. I would prefer to stick to the 965m for now, if above issue can be fixed!

Thanks in advance for any help!
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Jul 3, 2018
Messages
727 (1.29/day)
Location
Haswell, USA
System Name Matrexx 55 | Clevo P770ZM
Processor i7 8700K 5GHZ 1.35v | 4790K 4.6ghz 1.3V |
Motherboard Z390 Gaming X | Z97 Clevo |
Cooling Macho Rev B | Laptop heatsinks
Memory 64GB | 32GB 2400MHZ SODIMM
Video Card(s) Vega 56 | GTX 980M
Storage 512GB MX100 + 1.5TB Spinpoint HDD | 256GB MX300 + 1TB HDD|
Display(s) 1080P 144HZ/1200 66HZ (2)/ 1440P 60HZ | 1080P 75HZ 15.4 |
Case Matrexx 55 | Laptop shells
Audio Device(s) Various sound cards
Power Supply 750W | 330W |
Mouse too many
Keyboard K552 | Acer and Dell OEM KB's |
Software Windows 8.1/Windows 10/OSX "Mojave"
Likely some kind of display incompatibility, do you have a eDP or LVDS display? QHS/120HZ is eDP, 1080p 60hz or lower is LVDS. Maxwell should support both, as should kepler, buts it's likely due to the HP VBIO. Alsoc, check taobao for a 1050 ti MXM, it's pricey at $300, I'd go for a WX 4150 MXM. Also, check the notebookreview forums for help, they're experts. Someone even shoe-horned a 1070 into a Zbook 15
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
Have to agree with this. HP is infamous for blacklisting MXM cards in their bios.
Did you read my first post in its entirety? I have to disagree with both of you and actually provide arguments, not guesses:

1) HP Bios does not throw any errors upon startup. For example it throws bios errors when u install unsupported WWAN or WLAN card in mSATA port.
2) GTX 965m has been proven to work on Zbook G2, there are multiple examples, including the video I shared in first post
3) The card is correctly recognized in BIOS, shows VBIOS version and date
4) The card is correctly recognized in Windows and works on external monitor. So it works with the MainBoard without any problems obviously!

@king of swag187: already been there, read everything related and tried everything suggested besides flashing new VBIOS to the card - I simply don't know which to flash, I don't want to brick the card. I've opened a thread there as well - so far no actual help. But I like you suspect it has to be an issue with the display. It is LED-backlit QHD+ UWVA IPS eDP anti-glare display, manufacturer is SHARP.

I too know Maxwell cards support both eDP and LVDS (this is verified, it worked on 8560w with lvds display). So I hope there is a vbios there that enables eDP or somebody here is knowledgeable how to tweak existing vbios if there aint ready available.

P.S. If you're going to suggest I get 1050Ti or P1000 graphic cards, please provide links where I can buy them. I would prefer to stick to the 965m for now, if above issue can be fixed!
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Did you read my first post in its entirety? I have to disagree with both of you and actually provide arguments, not guesses:

1) HP Bios does not throw any errors upon startup. For example it throws bios errors when u install unsupported WWAN or WLAN card in mSATA port.
2) GTX 965m has been proven to work on Zbook G2, there are multiple examples, including the video I shared in first post
3) The card is correctly recognized in BIOS, shows VBIOS version and date
4) The card is correctly recognized in Windows and works on external monitor. So it works with the MainBoard without any problems obviously!

@king of swag187: already been there, read everything related and tried everything suggested besides flashing new VBIOS to the card - I simply don't know which to flash, I don't want to brick the card. I've opened a thread there as well - so far no actual help. But I like you suspect it has to be an issue with the display. It is LED-backlit QHD+ UWVA IPS eDP anti-glare display, manufacturer is SHARP.

I too know Maxwell cards support both eDP and LVDS (this is verified, it worked on 8560w with lvds display). So I hope there is a vbios there that enables eDP or somebody here is knowledgeable how to tweak existing vbios if there aint ready available.

P.S. If you're going to suggest I get 1050Ti or P1000 graphic cards, please provide links where I can buy them. I would prefer to stick to the 965m for now, if above issue can be fixed!
You are not the only one who has came here asking a question like this, the others wound up hitting the same wall at full speed like you did and it is because of hardware blacklisting.

Well get a SPI flasher to get a motherboard bios dump, learn how to interpret Hexadecimal addressing, get a Hex Reader and read on the net how to modify your motherboard bios. Laptops have blacklisting to prevent stupid users from putting in an overpowered card that kills the laptop and then they try to RMA it. No matter if you try to bios mod a gpu it wont stop the motherboard from shutting it down.

You are on your own.

/thread.
 
Joined
Jul 5, 2013
Messages
8,069 (3.38/day)
Did you read my first post in its entirety? I have to disagree with both of you and actually provide arguments, not guesses:
They're not guesses, they're experiences. I'll explain what is happening;
1) HP Bios does not throw any errors upon startup. For example it throws bios errors when u install unsupported WWAN or WLAN card in mSATA port.
But does the builtin display light up at all during boot? You've said no, but can still get an image with an external display. This is the HP VBios seeing the installed card but not finding the HP code strings and thus refusing to light up the LCD. This has happened.
2) GTX 965m has been proven to work on Zbook G2, there are multiple examples, including the video I shared in first post
Of course it did. The Zbook does not actively block cards it supplies and is very unlikely to block cards from other makers like HP is known to do.
3) The card is correctly recognized in BIOS, shows VBIOS version and date
With an external display, of course it would.
4) The card is correctly recognized in Windows and works on external monitor. So it works with the MainBoard without any problems obviously!
Again, the only problem is that the HP Vbios refuses to start the builtin display routines. Windows will still display through another output.

The only thing you haven't told us, is whether or not the system works as it should with the Quadro put back in. If it does, there's your proof that HP is actively blocking cards not made/supplied by them. This is a known problem. It's shady as all hell and one of the many reasons I'm not a fan of HP.

Just a bit of advice, next time you ask for help and several people chime in offering the same information, ask a few questions instead of popping off and telling us how wrong we must be or how we didn't pay attention or understand. YOU might just learn something from professionals with decades of experience who took time out of their day to answer your questions/problems.
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
@eidairaman1 @lexluthermiester I did not want to come up as ungrateful for trying to help, I just assumed a lot of teenagers or people who just don't do their homework, come here asking stupid questions. So my first thought was, you considered me one of those .. and judging by your next answers, I might as well be.

@eidairaman1 Thanks for the suggestion to use SPI flasher and so on. This is way beyond my skills, nor it is something that attracts me as hobby. I just don't understand how a video card could be blacklisted and still work with that same mainboard. If I am that stupid user trying to fry the board, how exactly did HP prevents me from doing that, if the configuration works in a dock station?!?

@lexluthermiester I don't understand this answer

2) GTX 965m has been proven to work on Zbook G2, there are multiple examples, including the video I shared in first post
Of course it did. The Zbook does not actively block cards it supplies and is very unlikely to block cards from other makers like HP is known to do.
If it works with other Zbook G2, then it just works, isn't that right .. it is the same motherboard, just different display and different connector to it. Why would they NOT blacklist this video card on a Zbook G2 with Full HD display, but blacklist it on Zbook G2 with QHD+ display? It doesn't make any sense to me. Btw the GTX 965m I have is HP made, it is not a 3rd party vendor.

I haven't put back the quadro back in, but there isn't any reason why it shouldn't work as it did originally. Don't see how this is a proof for the above.

Isn't the VBIOS actually contained within the video card? If I flash a bios that is for eDP displays, shouldn't it work?

Regards
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
@eidairaman1 @lexluthermiester I did not want to come up as ungrateful for trying to help, I just assumed a lot of teenagers or people who just don't do their homework, come here asking stupid questions. So my first thought was, you considered me one of those .. and judging by your next answers, I might as well be.

@eidairaman1 Thanks for the suggestion to use SPI flasher and so on. This is way beyond my skills, nor it is something that attracts me as hobby. I just don't understand how a video card could be blacklisted and still work with that same mainboard. If I am that stupid user trying to fry the board, how exactly did HP prevents me from doing that, if the configuration works in a dock station?!?

@lexluthermiester I don't understand this answer

<quote> 2) GTX 965m has been proven to work on Zbook G2, there are multiple examples, including the video I shared in first post
Of course it did. The Zbook does not actively block cards it supplies and is very unlikely to block cards from other makers like HP is known to do. </quote>

If it works with other Zbook G2, then it just works, isn't that right .. it is the same motherboard, just different display and different connector to it. Why would they NOT blacklist this video card on a Zbook G2 with Full HD display, but blacklist it on Zbook G2 with UHD+ display? It doesn't make any sense to me. Btw the GTX 965m I have is HP made, it is not a 3rd party vendor.

I haven't put back the quadro back in, but there isn't any reason why it shouldn't work as it did originally. Don't see how this is a proof for the above.

Isn't the VBIOS actually contained within the video card? If I flash a bios that is for eDP displays, shouldn't it work?

Regards
Basically in a hp laptop, the firmware that is encoded in the motherboard, monitor and gpu have to all have certain protocol to work.

Laptops are proprietary and not all vbios are on the gpu but hidden in the mainboard.

Since the spi flasher is beyond your skill level it would be best to put the laptop back to stock and get one that performs better.

Example the screen on a samsung phone wont work on a pixel phone.
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
Laptops are proprietary and not all vbios are on the gpu but hidden in the mainboard.
@eidairaman1 Bear with me a little more, I might be more thick than anticipated, but it just doesn't make sense to me that:

1) The same generation Zbook 15 G2 works with the exact same HP GTX 965m video card. The only difference is the display. Why would the vbios on the Zbooks with QHD+ screen be more limiting than the ones with Full HD.

2) The video card works with that mainboard and it outputs (I would assume lvds signal) to external monitor via the docking port of that laptop.

Based on those 2, isn't it more logical that the issue is simply with motherboard expecting video card to output eDP signal, and my card outputs lvds right now?![/QUOTE]
 
Last edited:
Joined
Feb 11, 2012
Messages
1,418 (0.49/day)
Location
Anchorage Alaska
System Name Matter's / Helios 300 Predator
Processor Ryzen 7 2700 / i7 7700HQ
Motherboard B450 Tomahawk / Acer Helios 300 Predator
Cooling Arctic Freezer eSports Duo
Memory Patriot Viper ddr4 32gb / 32gb gskill ddr4
Video Card(s) MSI RTX 2080 Super Ventus OC / GTX 1060 6gb
Storage Patriot Viper nvme M2, crucial MX300 275gb, Samsung 860 qvo 1tb
Display(s) Acer 24" 1080p / 15.6 1080p HD
Case Antec 300 / Acer Helios 300 Predator
Audio Device(s) On Board - Steel Series Arctis Pro Wireless Cans
Power Supply Antec 850watt high current pro
Mouse Steel series Rival 600
Keyboard Corsair K70 / Acer Helios 300 Predator
Software Win 10 Pro / Win 10 Home
isn't it more logical that the issue is simply with motherboard expecting video card to output
no if it were as simple as that then you would everyone swapping video cards out in their laptops like we do in our desktops. But is not that simple, apparently the 8560 you put the 965 in, has the correct firmware to allow it to work. The zbook does not, which also explains why the quadro coming out the zbook does not work in the 8560. I understand the logic if it works in one then it should in the other. Unfortunately is not. The bios is located in the mobo not the vga and there is where it allows it to work or not. I know it is confusing, why does it work in one and not the other. Bios gods be damned but that is the way laptops go. If it were that simple I would upgrade my 660m in my ROG G75VW to a 770m or higher, but that just would not happen. Highest I can go is the 670/680(if they made a 680 mobile).

spi flasher is about your only avenue unless you want to pay someone to do it for you.
 

dorsetknob

"YOUR RMA REQUEST IS CON-REFUSED"
Joined
Mar 17, 2005
Messages
8,441 (1.56/day)
Location
Dorset where else eh? >>> Thats ENGLAND<<<
Mobo bios might have a blacklist.
Have to agree with this. HP is infamous for blacklisting MXM cards in their bios.
This is the HP VBios seeing the installed card but not finding the HP code strings and thus refusing to light up the LCD
You Question people that have Years of experience
Do you understand what a Blacklist is ????
well lets put it another way
Some Manafacture's ie HP and Lenevo have a whitelist stored in the Bios that permit Certain Hardware to be inaitilised and used.
Not on the Stored List = will not work

PS the whitelist is what the others refer to as the Blacklist is smaller than a So called black list because there is a small list of approved hardware
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
You Question people that have Years of experience
Do you understand what a Blacklist is ????
well lets put it another way
Some Manafacture's ie HP and Lenevo have a whitelist stored in the Bios that permit Certain Hardware to be inaitilised and used.
Not on the Stored List = will not work

PS the whitelist is what the others refer to as the Blacklist is smaller than a So called black list because there is a small list of approved hardware
Exactly, the part he is trying to install has been blacklisted.
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
spi flasher is about your only avenue unless you want to pay someone to do it for you.
@flmatter Is someone here actually doing it and how much does it cost?

. I know it is confusing, why does it work in one and not the other.
Exactly, this part is real head banger. Why would it work on the same gen laptop, but different display. Why whitelist the card on the FullHD screens, but do not whitelist it on the QHD+? Any particular reason or I should not search for any logic here?

You Question people that have Years of experience
Do you understand what a Blacklist is ????
I am obviously new here, don't know any of you or your experience and I do not question you people, I am trying to make sense, why in the world the same card would work on the same gen laptop with FullHD screen. This fact is about the only reason why I purchased this laptop, because I saw other people before me verify it worked. I never thought I would hit this issue. Yes, I know what blacklist/whitelist is.

Exactly, the part he is trying to install has been blacklisted.
Please somebody explain to me in layman's terms, why does this configuration work when the laptop is docked. If it is not whitelisted, why does the board work with that video card and allows you to use the laptop in docking station?

Thanks for everyone jumping to help!
 
Last edited:
Joined
Feb 11, 2012
Messages
1,418 (0.49/day)
Location
Anchorage Alaska
System Name Matter's / Helios 300 Predator
Processor Ryzen 7 2700 / i7 7700HQ
Motherboard B450 Tomahawk / Acer Helios 300 Predator
Cooling Arctic Freezer eSports Duo
Memory Patriot Viper ddr4 32gb / 32gb gskill ddr4
Video Card(s) MSI RTX 2080 Super Ventus OC / GTX 1060 6gb
Storage Patriot Viper nvme M2, crucial MX300 275gb, Samsung 860 qvo 1tb
Display(s) Acer 24" 1080p / 15.6 1080p HD
Case Antec 300 / Acer Helios 300 Predator
Audio Device(s) On Board - Steel Series Arctis Pro Wireless Cans
Power Supply Antec 850watt high current pro
Mouse Steel series Rival 600
Keyboard Corsair K70 / Acer Helios 300 Predator
Software Win 10 Pro / Win 10 Home
You do not have a location posted so I can only guess. US? UK? Down under?
It basically comes down to white/black list on mobo, it could be due to different mobo or chipset on it that makes a difference. No offense but I would never buy a laptop because other have swapped out gpu's. I buy them according to what I intend to use them for.
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
@silverchair Your ZBook 15 G2 can not use that card, it's blacklisted as the others here have said.

https://support.hp.com/us-en/product/hp-zbook-15-g2-mobile-workstation/6978814/document/c04503657

Look for item 14, these are the cards (GPU's) that will work in the ZBook 15 G2.
Sorry mate, you don't know what you're talking about. This card might not work with this laptop, but it's not because it is not present in that list.

@flmatter I bought the laptop because of the QHD+ screen and also because it is the last Zbook to support the old type of docking stations. Three members of my family already have HP laptops that use the same docking station, so it is super convenient to be able to attach it and work on external monitors when u need to.

I just googled a bit and found that HP sign their firmware, so it cannot be tinkered with. Is it really possible to make changes to it and have it reflashed? I am from Eastern Europe, but travel to London frequently.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Sorry mate, you don't know what you're talking about. This card might not work with this laptop, but it's not because it is not present in that list.

@flmatter I bought the laptop because of the UHD+ screen and also because it is the last Zbook to support the old type of docking stations. Three members of my family already have HP laptops that use the same docking station, so it is super convenient to be able to attach it and work on external monitors when u need to.

I just googled a bit and found that HP sign their firmware, so it cannot be tinkered with. Is it really possible to make changes to it and have it reflashed? I am from Eastern Europe, but travel to London frequently.
In this case no, you would need the signage from hp and they wont give it to you.
 

STSMiner

New Member
Joined
Oct 28, 2018
Messages
16 (0.04/day)
VBIOS: 84.06.52.00.27 (https://www.techpowerup.com/vgabios/1...) hybrid graphics must be enabled. if disabled screen got black.

In that video you linked ----- He's using a modified VBIOS for that card.


Notes from the poster of this Video linked above...

soundoflenses
Published on Nov 21, 2015


OEM GRAPHIC MODULE MXM FORM FACTOR BUT VBIOS NOT MXM COMPLIANT 2 GB GDDR5 note compatibility circumstance is not simply in the Quadro K2100M card 80.06.68.00.03 is probably HP ZBook VBIOS I was tested this VBIOS on 8560w (non DC) confirmed not working (laptop screen blank but analog VGA output ok also NVFlash via FreeDOS works fine) on 8570w I not tested 80.06.61.00.08 is Dell VBIOS works fine on non DC 8570w 80.06.69.00.06 is MSI VBIOS I personally not tested on 8570w don't know results several chinese forums reported works ok on 8560w
 
Joined
Nov 24, 2018
Messages
17 (0.04/day)
Tried running in native UEFI, but besides the vbios now showing as GPU UEFI driver instead of the firmware numbers from before, there was no other change i.e. screen, still no go.

@eidairaman1 would flashing a vbios to the GPU which is for the same chip G206, but with 2 GB Ram instead of 4, brick the card for sure?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Tried running in native UEFI, but besides the vbios now showing as GPU UEFI driver instead of the firmware numbers from before, there was no other change i.e. screen, still no go.

@eidairaman1 would flashing a vbios to the GPU which is for the same chip G206, but with 2 GB Ram instead of 4, brick the card for sure?
Yes, you will not get anywhere with this so stop before it gets screwed up even further.
 
Last edited:
Joined
Jul 5, 2013
Messages
8,069 (3.38/day)
@eidairaman1 would flashing a vbios to the GPU which is for the same chip G206, but with 2 GB Ram instead of 4, brick the card for sure?
Yeah, you'll brick that card. Your only solution will be to find another, better spec'd HP branded MXM Quadro. Ebay is a great place for that, but they're a bit pricey though they should still be affordable.
 

3ryl

New Member
Joined
Dec 15, 2018
Messages
2 (0.01/day)
@silverchair
I'm still a newbie around this kind of tinkering but I guess I can help a bit.

The reason you need hybrid mode when installing unsupported cards in the Zbook is: Nvidia Optimus.
It makes the laptop display be controlled by the HD 4600 igpu which acts as a bridge for the video signal of the 965M.
I guess lexluthermiester's 7# post is on point explaining why the monitor backlight wont turn on.
So the 965m sort of works but is unable to activate the backlight. In hybrid mode the HD 4600 is still supported to activate the backlight and the 965m does the 3d rendering. And that's what makes the screen work.
Well, you might consider getting a 1080p monitor,cable and motherboard not for a huge amount. Hope you find a solution for your problem.

Also would like to ask some questions about your Zbook when running the 965m, hope you don't mind it. Just got a zbook 15 recently.
First How do fan speeds work after the upgrade? are they ramping up according to gpu temp? (That one guy who installed a gtx 1070 on his Zbook 15 had them maxed out everytime). Also, how hot does it get? And if you have tested it, how is performance on battery versus plugged in? Thank you.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,920 (6.31/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
@silverchair
I`m still a newbie around this kind of tinkering but I guess I can help a bit.

The reason you need hybrid mode when installing unsupported cards in the Zbook is: Nvidia Optimus.
It makes the laptop display be controlled by the HD 4600 igpu which acts as a bridge for the video signal of the 965M.
I guess lexluthermiester`s 7# post is on point explaining why the monitor backlight wont turn on.
So the 965m sort of works but is unable to activate the backlight, and in hybrid mode the HD 4600 is still a supported gpu to activate the backlight so it`s able to work.
Well, you might consider getting a 1080p monitor,cable and motherboard not for a huge amount. Hope you find a solution for your problem.

Also would like to ask some questions about your Zbook when running the 965m, hope you don`t mind it.
First How do fan speeds work after the upgrade? are they ramping up according to gpu temp? (That one guy who installed a gtx 1070 on his Zbook 15 had them maxed out everytime). Also, how hot does it get? And if you have tested it, how is performance on battery versus plugged in? Thank you.
So where did you pull some of this from?
 

3ryl

New Member
Joined
Dec 15, 2018
Messages
2 (0.01/day)
So where did you pull some of this from?
I've been messing around with eGPUs since 2015 on my old Vostro 3550, getting it to work on internal screen required some reading and testing. I have no experience with vBioses though.

Wikipedia has a nice explanation for optimus if one wants to take a look:
"A typical platform includes both a lower-performance integrated graphics processor by Intel and a high-performance one by Nvidia. Optimus saves battery life by automatically switching the power of the discrete graphics processing unit (GPU) off when it is not needed and switching it on when needed again." ... "When an application is being launched that is determined to benefit from the performance of the discrete GPU, the discrete GPU is powered up and the application is served by a rendering context via that GPU. Otherwise the application is served by a rendering context that uses the integrated GPU."
 
Last edited:
Status
Not open for further replies.
Top