• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

HD2900 bad flash (working but no fan control)

Apr 21, 2009
1 (0.00/day)
Processor T5500
Motherboard ASUS N4L-VM-DH
Memory 4gb DDR2 667
Video Card(s) HD2900 GDDR4
Storage 320 maxtor
Power Supply 700W
Hi guys, im new to this forum but have got loads of advice by just reading through the posts in the past. I flashed my HD2900 (stuipidly) in vista x64 the newest version works sometimes anyway I was unlucky and it didnt work twice so when i rebooted my computer, blank screen and GPU fan would not spin. I followed the advice on this forum and installed a pci graphics card which then allowed me to reflash my pcieHD2900.

Now my problem is that my graphics card works absolutly find in everyway except the fan will no longer spin not even if i try to use rivatuner (which gives me the option to change the fan speed). The main reason I believe im in over my head here is that the fan does not spin even when i only put in one 6pin power adaptor (Im sure the fan should go to 100% and blank screen with only one power adaptor installed)?

Also when i did get HD2900 to reflash it worked in so far as i could go into windows, but windows could not recognise what it was, also i saved the bios with gpuz and loaded it into RBE which told me it had a bad checksum and sure enough the files size was 128k, so i reflashed with winflash (I know) but it worked, now fan still wont spin but it knows its a HD2900

Since then i have reflashed with atiflash and tried a number of bioses from the techpowerup bios databases to no avail, anyone any ideas plz?