1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

HD5870 changing clocks wont stick

Discussion in 'RBE' started by TwistedBE, Apr 22, 2010.

  1. TwistedBE New Member

    Apr 22, 2010
    2 (0.00/day)
    Thanks Received:

    I wanted to change my 3D clock on my new Sapphire Vapor-x hd5870 (it a rev.2 blue board no volt changing in the bios)
    Ive extracted the bios with gpu-z and used RBE to change the clock setting that said 850/1200 to lets say for example 875/1250 (the vapor-x oc)
    Saved the bios and flashed it (atiflash from a bootable usb key)
    But when im checking gpu-z the clocks in 3D are still 850/1200 and not the 875/1250 you would expect.
    When i extract the newly flashed bios from the card i can verify that the speeds are indeed 875/1250.

    Also ive downloaded the vapor-x v.2 bios from the download section (witch has the same clocks as in my example)
    When i flash that on the card (also from bootable stick) it wont go any higher then 850/1200 in 3D mode.
    Although the clocks page in RBE show the correct (higher) clocks programmed.

    What am i doing wrong here ? I'm using the atiflash -p 0 hd5870.rom command to flash the cards (no other ati cards in my system)

    btw: the card clocks higher then that when im using CCC but im just trying to get different clocks on there then stock.

    I'm kinda experienced with this stuff as ive been flashing my gfx cards ever since the geforce 4600ti days.
    And believe me ive had a few cards in my hands since then :)
    But im new to the ati scene (although in essence its the same)

    Any idea whats causing this ? Is it the new v2 board from sapphire or does RBE not support this card yet.
  2. cadaveca

    cadaveca My name is Dave

    Apr 10, 2006
    16,425 (3.90/day)
    Thanks Received:
    Parkland County, Alberta
    atiflash -f -p 0 xxxxxxxx.xxx

    dunno if that's the issue, but that's what I do, and no issues with bioses, unless like you say, for some reason RBE is broken with that vbios...

    Also, you must uninstall-re-install driver for it to work right. I typically uninstall driver, remove all registry entries, then flash the card(twice before reboot, here), and then isntall driver after that. Works for me 100%.
    10 Year Member at TPU
  3. TwistedBE New Member

    Apr 22, 2010
    2 (0.00/day)
    Thanks Received:
    You just add the 'force' command witch in my case will not be needed (but ive tryed that anyway same results)
    Is reinstalling the drivers really needed when you only change some clocks ?!?
    This was never the case with all the other cards ive flashed... (unless you change more then just some clocks ofc)
  4. Asylum


    Jul 18, 2008
    2,866 (0.85/day)
    Thanks Received:
    South Carolina
    Heres the way i flash my reference 5870 with asus BIOS as a example.

    Install the usb flash drive you want to use.

    Then run the hp, usb tool to make it a bootable flash drive

    copy the files in the "boot files" folder to the drive - put them in a folder called BOOTFILES

    Then you'll want to copy the two atiflash files into the flash drive along with the new bios you want..... Don't put them in a folder

    Restart and make sure you're set up, in your bios, to boot from the flash drive

    It will flash a windows 98 screen briefly and then it will go to a dos screen

    at the DOS promtp... here are the atiflash commands:

    atiflash -s 0 backup.rom (this will back up the bios on the card and name it "backup")
    atiflash -f -p 0 asus.rom (this will force flash the card with the bios named "asus")
  5. BAGZZlash

    BAGZZlash RBE Author

    Mar 9, 2008
    587 (0.17/day)
    Thanks Received:
    Did you disable overdrive? Overdrive overrides the BIOS' clock rates.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)