• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Help! MSI rx-470 gaming X 4 GiB Need a missing component name/voltage

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
Hello
Please help me to fix the card with missing component right after 8 pin connector (u1000) & also a missing capacitor there (c507)
There is 2 broken pad for that component too (u1000)

Card power up & gpu getting hot & not detect, also fans not spinning

I've 3.3 volt at top right leg
Looks like down left leg is ground

Any help? I'm thinking of applying missing voltage with some external buck convertor since i have no same component

Thanks in advance

20210513_020027.jpg20210513_020103.jpg20210513_020114.jpg
 
Last edited:
Joined
Apr 22, 2021
Messages
125 (2.02/day)
Hello
I do not have rx470 but i own an RX 580 also from MSI.
I have same situation like you about the missing component (also u1000)
I discovered the piece missing from a guy who was kind enough to make a close up picture with zoom.
So i attach the picture to see the missing piece.
i hope it will help you repair your video card
Cheers
 

Attachments

  • MSI RX 580 faulty.jpg
    MSI RX 580 faulty.jpg
    662.2 KB · Views: 42
  • Missing piece U1000.jpg
    Missing piece U1000.jpg
    194.7 KB · Views: 45

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
Hello
I do not have rx470 but i own an RX 580 also from MSI.
I have same situation like you about the missing component (also u1000)
I discovered the piece missing from a guy who was kind enough to make a close up picture with zoom.
So i attach the picture to see the missing piece.
i hope it will help you repair your video card
Cheers
Thanks very much, you are kind too
It will help, thanks
Did u fix your card?
I think missing component should be a "logic ic", i think it's name is "and/multiplier logic ic"

3 legs have 3.3 volt, 1 is ground, 1 is no voltage
If 2 legs from left have voltage or pulse it will allow voltage through to 2nd leg at right side

I applied 3.3 volt to that pad but didn't help, maybe i missed something or card wants the whole ic function
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
At the moment i did not found out who is the producer of this piece , more than this you are the 1st who told me what is supposed to be.
So i wait for you to find out what is the "mission" of this piece in order to search in the producers database.
if you find 1st be so kind and share it. if i find i will share it.
cheers
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
At the moment i did not found out who is the producer of this piece , more than this you are the 1st who told me what is supposed to be.
So i wait for you to find out what is the "mission" of this piece in order to search in the producers database.
if you find 1st be so kind and share it. if i find i will share it.
cheers
Does your card works without that component? Fan spins?

SN74LVC1G08DCKR
Or at this address

I think this is it, I've found same component shape with same voltages in rx-460 board, i can't touch it right now but I'll try to buy it from another city if they can supply & send, actually I can't buy from the above link

I attached a photo of rx-460 I've taken & two datasheet of the component which i think match our mission, it should have max voltage support over 3.3 volt which have 5 volt support so it's ok and the 2.7 volt max component is not suit for this board you know

I'm not much experienced user but it looks like true
There is no reason to have an ic which all legs have 3.3 volt, it should be like a smart key, if two legs have something then pass something to other leg otherwise they could use a jumper or wire to pass the 3.3 volt to the target leg.
3 legs have 3.3 volt, 1 leg is ground, 1 leg is the target leg

If i can't find the ic I'll try to make a "multiplier logic ic" by transistor before i pick it from rx-460. The shape gonna be bigger & have to glue to to the board
 

Attachments

  • 20210513_031143.jpg
    20210513_031143.jpg
    920.3 KB · Views: 15
  • 00414045.pdf
    2.7 MB · Views: 14
  • SN74LVC1G08DCK (1).pdf
    122 KB · Views: 14
Last edited:
Joined
Apr 22, 2021
Messages
125 (2.02/day)
Hello again
Well my card is working ...at least until one point it is.
Win10 boots up, and i have that nasty error 43.(fans spin and they don't stop as they should when driver loads)
So basically the win10 drivers load but do not function well because the IC (our electronic missing piece) is not present.
In my case i found out from this forum that was a whole lot of missing piece video cards or soldered wrong.
Anyway MSI does not accept this video card as a production malfunction so i must solve the case on my own.
In other words i am stuck on my head with it :)
About what you said earlier
"There is no reason to have an ic which all legs have 3.3 volt, it should be like a smart key, if two legs have something then pass something to other leg otherwise they could use a jumper or wire to pass the 3.3 volt to the target leg.
3 legs have 3.3 volt, 1 leg is ground, 1 leg is the target leg"
I agree about nonsense to have 3,3 on all legs - so basically we must find out what is the purpose of this IC - what is his mission . And if we find it on some shop list from where we can buy it.
Cheers mate
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
Hello again
Well my card is working ...at least until one point it is.
Win10 boots up, and i have that nasty error 43.(fans spin and they don't stop as they should when driver loads)
So basically the win10 drivers load but do not function well because the IC (our electronic missing piece) is not present.
In my case i found out from this forum that was a whole lot of missing piece video cards or soldered wrong.
Anyway MSI does not accept this video card as a production malfunction so i must solve the case on my own.
In other words i am stuck on my head with it :)
About what you said earlier
"There is no reason to have an ic which all legs have 3.3 volt, it should be like a smart key, if two legs have something then pass something to other leg otherwise they could use a jumper or wire to pass the 3.3 volt to the target leg.
3 legs have 3.3 volt, 1 leg is ground, 1 leg is the target leg"
I agree about nonsense to have 3,3 on all legs - so basically we must find out what is the purpose of this IC - what is his mission . And if we find it on some shop list from where we can buy it.
Cheers mate
Very good diagnosis.
I think that target line needs two line up & working for example if gpu have power & memory have power then let pass the voltage to & bring up fan because they produced heat

In my case missing part is at back side & a pad connected to front side multi leg ic which looks like a driver near gpu mosfets.

The output voltage may be a signal to other ic which means enabling it for something else, like a simple chain.

Also Some component can be use for general purpose if voltage & current (Amper) meets requirements.

For your case i think something doesn't receive required signal to leave the fan to driver, a talk between driver & sensor should begin but doesn't happen.
Linux has two types of gpu drivers, open source & oprietary, they may be a temporary fix until finding the missing part.

Also look at youtube for multiplier logic , you can build a simple prototype to test it out
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
true about linux.
i already did tested both variant of drivers, w/o luck.
but after rain sun will always shine....so i am patient.
about the missing piece, for sure what you wrote above is true, i figured out that IC will be like a detector of voltage presence in which case IC will do something for the rest of the board.
In my case the IC is located on the back of the pcb near the plugin cable for power.
I bet that the IC must have a function about voltage.(signalling the presence of voltage&current)
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
Mostafaz any news bro ?
Sorry for late response
I saw another guy have same card like u, he said I've picture but no memory frequency info in gpuz because of that component, then he replaced & told me all good. All he know it's a memory power related component.

It's is in back side of rx460 near the pci-express slot. I'm sure it's an AMD card thingy.
atm I'm sure it's same with rx460.

Today I'll probe another rx-470 by sapphire & post the result here
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
I have same problem as you mentioned above. My card does start, but in windows 10 i do not have memory frequency info in GPU-z.
You say that it should be related to memory power ?
Hmm.....ok i will dig further.
Thanks mate

When you finish the tests, be so kind and put results here
Thanks
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
I have same problem as you mentioned above. My card does start, but in windows 10 i do not have memory frequency info in GPU-z.
You say that it should be related to memory power ?
Hmm.....ok i will dig further.
Thanks mate
So you have error 43 ,right?
The driver will not start ...
It's memory related error, if the missing component is in charge of memory then u should be good if replacing it
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
i took one piece from another card, i soldered it in place and after that the video card did not start at all.
Kinda blocked the memory or something.
The missing piece from my card was an error from MSI production line.
A lot of people had this problem, so i was not alone.
In my case the piece was missing, other guys was just wrong soldered and so on.
I will try again in the next days to find a cure :)

Interesting part : i soldered back the electronic piece where it should be, and after that the card do not start anymore.
What i mean is : before soldering the card start, driver loads, and i get error 43
After soldering card does not start anymore, and in windows i do not see it under device manager at all (only at hidden devices)
pfffffff
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
i took one piece from another card, i soldered it in place and after that the video card did not start at all.
Kinda blocked the memory or something.
The missing piece from my card was an error from MSI production line.
A lot of people had this problem, so i was not alone.
In my case the piece was missing, other guys was just wrong soldered and so on.
I will try again in the next days to find a cure :)

Interesting part : i soldered back the electronic piece where it should be, and after that the card do not start anymore.
What i mean is : before soldering the card start, driver loads, and i get error 43
After soldering card does not start anymore, and in windows i do not see it under device manager at all (only at hidden devices)
pfffffff
Sorry for that.
Can you measure voltage from it's pad without the component?
I may didn't get it correctly, someone else soldered it & it was wrong?
U have found the component from other device but it's a wrong one?
 
Last edited:
Joined
Apr 22, 2021
Messages
125 (2.02/day)
Ok, let me explain.
I have 2 identical video cards from same manufacturer. (MSI)
Both are same model with same type of memory chips.
That makes easier to measure voltages on them and to identify some missing pieces.
But the donor card which had all the pieces on it does not start at all.
So what i did : i took that IC with 5 legs and practically i soldered on the other vtdeo card where it was missing. I repeat two identical cards in all points of view.
The receiver card was bought and i have tested it. It start, it loads drivers, but in windows under device manager i receive error43 (memory errors).
I discovered after many hours of digging on the web that a lot of MSI cards were produced with same error (missing part or soldered wrong).
So i presumed if i move that IC on the receiver card should function. But it did not. More than this after i put piece on it it does not start at all
So this is the whole movie :)
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
Hello.
You found out what is that piece ? Or at least what is the function of it ?
You tried with transistors to see?
Please be so kind and share with us.
Cheers
 

Mostafaz

New Member
Joined
May 12, 2021
Messages
8 (0.19/day)
Hello.
You found out what is that piece ? Or at least what is the function of it ?
You tried with transistors to see?
Please be so kind and share with us.
Cheers
Hello
I've found 2 guys with missing component board, they replaced & done.
I'm waiting for another guy to confirm.

Btw i no longer have the card but eager to know about it yet.
 
Joined
Apr 22, 2021
Messages
125 (2.02/day)
Hello there.
Ok they replaced with what ?
I need to buy that piece but i do not what it is.
Cheers

Mostafaz, please be so kind and share with us what IC those guys used to replace the missing piece?
I mean i need some serial or a model to know what i am looking for.
Or at least i need the function of that IC
Thanks
 
Top