• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Help Resurrect RX5700XT

Ennoch

New Member
Joined
Jul 31, 2021
Messages
5 (0.08/day)
So about a month and a half ago My GPU (Sapphire Nitro+ RX5700XT) stop posting in the bios. I have a MSI gaming edge wifi that shortly after updating bios stopped reading my card. I was hoping it was an issue with the bios and tried rolling back the bios and changing the settings on the MB but to no avail. I have to secondary MB to test this VGA on but I do know the GPU fans/lights do turn on and the GPU core still heats up even though the MB is not detecting it. I have tried air blowing cleaning the card and have lastly cleaned with alcohol and am waiting for thermal paste and pads I ordered to come in before retesting again. There is no sign of any apparent corrosion or short/blown circuit/fuse. This I couldn't really tell until I had thoroughly cleaned off all the paste and pads. I Would just buy a Nvidia 3070/3080 to replace as those are around the same price point when I bought this one almost 2 years ago. But with market as it is I cant justify buying a card not only over the price of what I lost to be comparable but as muck as 200% msrp. Any ideas that could help me at least get the MB detecting the card?
 
Joined
Feb 17, 2010
Messages
821 (0.19/day)
System Name Borg Cube
Processor R5 3600
Motherboard X470 Taichi
Cooling Water
Memory 32GB @3800CL16
Video Card(s) RX Vega 64
Storage Silicon Power A80 1TB x2
Display(s) Samsung UE590
Case HAF XB
Audio Device(s) Logitech Z623
Power Supply LEADEX III
Mouse Cooler Master MM710
Keyboard Logi G105
Software 10 Pro
Benchmark Scores https://hwbot.org/user/damric/
Less than 2 years old then RMA.
 

Ennoch

New Member
Joined
Jul 31, 2021
Messages
5 (0.08/day)
Less than 2 years old then RMA.
I don't have any of the original packaging which I bought through amazon so I do have the receipt but wouldn't dismantling card and cleaning it void the warranty? Besides that, I have rarely had a positive experience with any form of warranty and found that there is always some reason they give as to why they would not honor or assist with a given issue. If at all possible I would like to fix my self. I have experience with repairs from vehicles to cell phones and AC units. Just looking for some insights as to what may be the cause given it still turns on but doesn't post.
 
Joined
Feb 17, 2010
Messages
821 (0.19/day)
System Name Borg Cube
Processor R5 3600
Motherboard X470 Taichi
Cooling Water
Memory 32GB @3800CL16
Video Card(s) RX Vega 64
Storage Silicon Power A80 1TB x2
Display(s) Samsung UE590
Case HAF XB
Audio Device(s) Logitech Z623
Power Supply LEADEX III
Mouse Cooler Master MM710
Keyboard Logi G105
Software 10 Pro
Benchmark Scores https://hwbot.org/user/damric/
I don't have any of the original packaging which I bought through amazon so I do have the receipt but wouldn't dismantling card and cleaning it void the warranty? Besides that, I have rarely had a positive experience with any form of warranty and found that there is always some reason they give as to why they would not honor or assist with a given issue. If at all possible I would like to fix my self. I have experience with repairs from vehicles to cell phones and AC units. Just looking for some insights as to what may be the cause given it still turns on but doesn't post.
Not a problem unless you botched it. RMA if you think it's the card and not anything else like mobo or PSU. I imagine you paid good money for that card and it came with a warranty.
 

Ennoch

New Member
Joined
Jul 31, 2021
Messages
5 (0.08/day)
this is from sapphires site

(The limited warranty does not cover products that the user has disassembled. GPU or ASIC devices (VGA) are sensitive to thermal (heat) issues. The heat sink has been designed to meet the requirements to ensure reliability of the product. Any warranty is rendered invalid if the product has been dismantled or the heat sink has been removed as this may cause damage to the GPU or ASIC device. Non-compliance will cause the warranty of the product to be void and repair will be at the users cost.)
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,283 (6.21/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
this is from sapphires site

(The limited warranty does not cover products that the user has disassembled. GPU or ASIC devices (VGA) are sensitive to thermal (heat) issues. The heat sink has been designed to meet the requirements to ensure reliability of the product. Any warranty is rendered invalid if the product has been dismantled or the heat sink has been removed as this may cause damage to the GPU or ASIC device. Non-compliance will cause the warranty of the product to be void and repair will be at the users cost.)

Ok RMA the card then, dont take it apart.
 
Joined
Feb 6, 2021
Messages
730 (3.12/day)
Location
Germany
Processor AMD Ryzen 9 5950X (and a LOT of other CPUs)
Motherboard MSI B550 Tomahawk
Cooling Corsair H150i RGB Pro XT
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) All Ampere, two 6900XTs and other RDNA2, all Turing, all Pascal, Vegas, 980 Tis and older.
Storage Corsair MP 600 Pro 1TB, 2x Samsung 870 QVO 4TB, Samsung 870 Evo 500GB (Backup)
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
VR HMD Oculus Rift S
sapphire is the absolute worst when it comes to RMA.
the sticker on a screw (even if the other one is still fully intact) has a TINY scratch?
better get a lawyer... we ain't gonna give you a single cent and you pay for the shipping.

i'd just send a mail with the date of purchase and explaining that the card is still "intact" and you never accidentally touched a sticker with a single skin cell.
maybe they even bother answering...
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
17,316 (3.32/day)
Location
UK\USA
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 X570 Pro 4
Memory Samsung low profile 2x8GB \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB Sabrent 1TB Rocket
Display(s) Samsung 1080P \ LG 43UN700
Case HTPC400 \ Thermaltake Armor case ( VE2000BWS ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000\Paradigm P Studio 20, Blue Yeti
Power Supply Seasonic Focus 650w \ Seasonic 750w MKII
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
My question is were is the OP from ?, if the US isn't the sticker against the law to use to void a warranty ?.
 

Ennoch

New Member
Joined
Jul 31, 2021
Messages
5 (0.08/day)
So I found one of the fuses with a bad solder on it idk, if it blew or not but I had some other older GPU's on hand and replaced the fuse. The issue now is when the GPU is installed the pc doesn't even turn on. This is most likely a safety issue as when the fuse is disconnected the PC turns on with no post from GPU. And, when the fuse is installed the PC wont even start to boot. That rules out the power supply as when other cards are installed the PC does Boot. Also boots with no GPU. I am guessing to figure it out I would need to get a test bench, an OHM-meter and figure out what all the reading should be to be able to actually fix it. Most likely it is a short somewhere on the GPU board. I am in Tampa FL btw. Sapphire would not RMA it. Thinking I might just wait till next year when GPU's are a reasonable price again.
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
17,316 (3.32/day)
Location
UK\USA
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 X570 Pro 4
Memory Samsung low profile 2x8GB \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB Sabrent 1TB Rocket
Display(s) Samsung 1080P \ LG 43UN700
Case HTPC400 \ Thermaltake Armor case ( VE2000BWS ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000\Paradigm P Studio 20, Blue Yeti
Power Supply Seasonic Focus 650w \ Seasonic 750w MKII
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
32,283 (6.21/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I am guessing you didn't read the OP....

Yes I did fyi, if you have the OG reciept that is your proof. Box it up in a antistatic bag and bubble wrap.

sapphire is the absolute worst when it comes to RMA.
the sticker on a screw (even if the other one is still fully intact) has a TINY scratch?
better get a lawyer... we ain't gonna give you a single cent and you pay for the shipping.

i'd just send a mail with the date of purchase and explaining that the card is still "intact" and you never accidentally touched a sticker with a single skin cell.
maybe they even bother answering...

Really!? Ive never had a problem with Sapphire RMA dept. Ffs they give out bios files when requested.
 
Top