• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Help with my WD MyBook Pro...

Exavier

New Member
Joined
Dec 12, 2007
Messages
981 (0.27/day)
Likes
78
Location
Bath, UK
Processor Q6600 G0 Stepping @3.4
Motherboard DFI LanParty DK P45 T2RS-PLUS
Cooling Fitseries3 Edition Fuzion v1, XSPC Razor X2, XSPC RS320, Hydor L30
Memory Crucial Ballistix @972mhz CL5
Video Card(s) Sapphire 4870X2 2GB
Storage Samsung Spinpoint F1 1TB x2 (I need another OS drive LOL)
Display(s) Sony Bravia 40L4000 40" HDTV :D
Case Silverstone TJ07 (Mod is a WIP)
Power Supply Corsair HX620w
Software Windows Vista
#1
my WD MyBook started refusing to show up in My Computer or Computer Management; no drive letter.

The "USB plugged in/taken out" sounds happen, but it prompts me to "install my new hardware" and comes up as "Generic USB Device."

The WD Forums are complete shite; thanks for the 3-year warranty you probably won't honour.

So I have a conundrum - my ext. HDD is not showing up, it has all my files on it which are irreplaceable, and I've only had this HDD about two-three months.

It's just not showing up, and WD won't help anyone...:cry:
any help on how to completely delete its drivers and stuff so that I can try to reinstall it?
Or other tips?
-Ex
 

Exavier

New Member
Joined
Dec 12, 2007
Messages
981 (0.27/day)
Likes
78
Location
Bath, UK
Processor Q6600 G0 Stepping @3.4
Motherboard DFI LanParty DK P45 T2RS-PLUS
Cooling Fitseries3 Edition Fuzion v1, XSPC Razor X2, XSPC RS320, Hydor L30
Memory Crucial Ballistix @972mhz CL5
Video Card(s) Sapphire 4870X2 2GB
Storage Samsung Spinpoint F1 1TB x2 (I need another OS drive LOL)
Display(s) Sony Bravia 40L4000 40" HDTV :D
Case Silverstone TJ07 (Mod is a WIP)
Power Supply Corsair HX620w
Software Windows Vista
#2
Actually, nevermind :D

I just took the power cable out, replugged it in, and it works - I know it wasn't loose, so WTFLOL

ne'ermoind :)
 
Joined
Dec 16, 2007
Messages
836 (0.23/day)
Likes
48
Location
Canadia
System Name Blood
Processor Intel Core 2 Quad Q6600 @ 2.4Ghz
Motherboard ASUS P5Q PRO @ stock settings
Cooling Antec Case fans (max) OCZ Vandetta 2 CPU cooler with a Kaze Jyuni 120mm fan 1200RPM+-100RPM 67.5CFM
Memory Patriot Viper Series 4GB 2x2GB DDR2 800Mhz 5-5-5-15
Video Card(s) BFG NVIDIA GeForce GTX 260 OC MAXCORE 896MB PCIe 2.0 Core 216 @ stock settings
Storage Seagate Barracuda 500GB SATA 3.0Gb/s
Display(s) Acer AL2616Wd 25.5" 1920x1200 800:1 178degrees viewing angle 5ms S-IPS Panel
Case Antec Nine Hundred
Audio Device(s) Auzentech X-Plosion 7.1 with a coaxial cable connected to a Logitech z5500
Power Supply BFG ES-800 800W
Software Windows Vista (soon to be Windows Xp, Vista, and Windows 7 triple boot)
#3
I bought my g25 Logitech steering wheel and it didnt work, it appears you needed to plug the ps2 cable into another cable and that into the wall. I was told it was the steering sensor or something was broken. Good thing I found that out.