• We've upgraded our forums. Please post any issues/requests in this thread.

How do you know for a fact that a sound card is causing performance issues?

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#1
I recently installed a sound blaster audigy se pci card and now i "think" i notice the game to perform a little oddly.

In bad company 2 I still get the frames i usually get but it just feels a little odd and kinda twerky now.

Is it possible that the sound card could be causing this?

Other than uninstalling, removing and playing without it is there a way I can see if the sound card is causing issues?

Thanks
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
18,529 (4.58/day)
Likes
3,162
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i5 2400 :: Athlon II x4 630
Motherboard MSI H67-G43-B3 :: GIgabyte GA-770T-USB3
Cooling Corsair H70 :: Thermaltake Big Typhoon
Memory 4x2GB DDR3 1333 :: 2x1GB DDR3 1333
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Plextor M5s 128GB, WDC Black 500GB :: Mushkin Enhanced 60GB SSD, WD RE3 1TB
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) X-Fi Titanium Fatal1ty Pro - iLive IT153B Soundbar (optical) :: None
Power Supply Corsair CX600w :: Unknown
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
#2
Maybe disable it in the device manager...
 

travva

New Member
Joined
Aug 25, 2008
Messages
349 (0.10/day)
Likes
55
Location
Hampton, VA USA
System Name ambalamps
Processor i7 980 @ 4.15 GHZ
Motherboard Gigabyte x58a UD3R
Cooling Corsair h70
Memory 12 GB Dominator DDR3 1600
Video Card(s) GTX580'S in SLI
Storage OCZ Vertex Turbo 60GB WD Velociraptor 300GB Seagate Barracuda XT 2 TB
Display(s) Asus 27" LCD
Case HAF-X
Audio Device(s) X-FI Titanium HD
Power Supply Coolermaster Real Power Pro 1kw Non Modular
Software Windows 7 x64 Pro
Benchmark Scores pwning n00bs like you
#3
didn't leave the onboard sound on by accident did you?
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#4
didn't leave the onboard sound on by accident did you?
i keep seeing people mention that, and i never know why.

i never disable my onboard audio or other devices - i technically have 5 sound cards running atm (onboard, auzentech, front audio (shows seperately), USB headset and a bluetooth headset.

No compatibility issues or performance problems from doing so.
 

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#5
yes onboard is disabled.

it's hard to say what the problem is.. i might have to do some process of elimination type work.

Its not unplayable but I am just noticing some type of video lag or intermittent skipping although I am always over 80fps and mostly around 100.

On a side note, does anyone know of an EQ ap that allows you to tweak/adjust overall sound on a sound card? The drivers for mine does not include anything.
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#6
well, it'd be nice if you filled out your PC specs like you were supposed to when you signed up :p
 

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#7
Eh I'm sorry but I don't want my system listed there and I always forget to mention when I am asking for help.

i5 750
foxconn inferno katana
4gb ddr3
sb audigy se 7.1
samsung f3 raid0
5870 stock on 10.13 (fresh win 7 install last week so no old drivers prior)
win 7 x64
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#8
there is no 10.13 drivers :p


as for the rest, ack! old creative on vista/7 x64 = sad face :( you get none of the software (and no hardware accel), so it might as well be onboard.
 

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#9
typo i meant 10.3

Really, so I knew I was buying a basic card but it's even worse bec its old school!!??

LOL.. Man, Id love to hear these headphone on a good sound card then.

Basically this sound card is louder and clear and allows 5.1 for me but I notice the sound is kinda flat, which I know is a software issue or something.

Ah well, I guess I better look for another sound card. thanks for the headsup.. i figure the sound card was lacking but Ive been hunting for a way to get something to install the beef it up.
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
18,529 (4.58/day)
Likes
3,162
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i5 2400 :: Athlon II x4 630
Motherboard MSI H67-G43-B3 :: GIgabyte GA-770T-USB3
Cooling Corsair H70 :: Thermaltake Big Typhoon
Memory 4x2GB DDR3 1333 :: 2x1GB DDR3 1333
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Plextor M5s 128GB, WDC Black 500GB :: Mushkin Enhanced 60GB SSD, WD RE3 1TB
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) X-Fi Titanium Fatal1ty Pro - iLive IT153B Soundbar (optical) :: None
Power Supply Corsair CX600w :: Unknown
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
#10
Why wouldn't you want your system specs listed?
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#12
typo i meant 10.3

Really, so I knew I was buying a basic card but it's even worse bec its old school!!??

LOL.. Man, Id love to hear these headphone on a good sound card then.

Basically this sound card is louder and clear and allows 5.1 for me but I notice the sound is kinda flat, which I know is a software issue or something.

Ah well, I guess I better look for another sound card. thanks for the headsup.. i figure the sound card was lacking but Ive been hunting for a way to get something to install the beef it up.
i have teh same issues with my audigy 4, without the software i get nada. very flat, no bass. i needed some modded x-fi drivers to get an EQ and bass boost happening, was terrible on headphones.

Why wouldn't you want your system specs listed?
+1 to that. its there for more than bragging, its so that we know how to help you, and people can ask you questions about your hardware when they need help.
 

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#13
Okay, I won't be the black sheep of the community and I will fill my specs out again.

I really appreciate the help, so Mussels, is there any chance you can PM me a little info on how to get my audigy working better? (modded drivers)

I just installed all the aps from the disk, EAX, EQ, SS mixer, etc and none of the applications will open due to an error that says hardware not supported by software.
 

hat

Enthusiast
Joined
Nov 20, 2006
Messages
18,529 (4.58/day)
Likes
3,162
Location
Ohio
System Name Starlifter :: Dragonfly
Processor i5 2400 :: Athlon II x4 630
Motherboard MSI H67-G43-B3 :: GIgabyte GA-770T-USB3
Cooling Corsair H70 :: Thermaltake Big Typhoon
Memory 4x2GB DDR3 1333 :: 2x1GB DDR3 1333
Video Card(s) 2x PNY GTX1070 :: GT720
Storage Plextor M5s 128GB, WDC Black 500GB :: Mushkin Enhanced 60GB SSD, WD RE3 1TB
Display(s) Acer P216HL HDMI :: None
Case Antec SOHO 1030B :: Old White Full Tower
Audio Device(s) X-Fi Titanium Fatal1ty Pro - iLive IT153B Soundbar (optical) :: None
Power Supply Corsair CX600w :: Unknown
Software Windows 10 Pro - Plex Server on Dragonfly
Benchmark Scores >9000
#14
google "Audigy Support Pack 3.7"
 
Joined
Dec 18, 2008
Messages
356 (0.11/day)
Likes
64
Location
Werribee, Victoria, Australia
Processor core i7 860 @ 4.02ghz (201x20)
Motherboard Gigabyte p55a-ud5
Cooling swiftech 240 rad and Apogee GTZ XT water block
Memory g skill ripjaws @ 1910 cas 9
Video Card(s) inno3d GTX570 820/1640 core shaders 2000 memory
Storage 120gb G-Skill phoenix Pro SSD (Sandforce 1200) 500gb + 750gb storage drives
Display(s) LG 27' 1920x1080
Case Thermaltake V9
Audio Device(s) onboard
Power Supply CoolerMaster 650w
Software 7 Ultimate x64
#15
i keep seeing people mention that, and i never know why.

i never disable my onboard audio or other devices - i technically have 5 sound cards running atm (onboard, auzentech, front audio (shows seperately), USB headset and a bluetooth headset.

No compatibility issues or performance problems from doing so.
don't forget the sound card in your 4870 as well
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#16

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#17
Wow thanks fellas, these drivers I landed on are awesome so far. I was able to change to 24bit and 96khz

I now have all the Xfi features and it actually works... for now anyway.. This is sweet.

Time to check out BC2 sounds now! I notice EAX works and 3D works, but the bass boost managment and Eq are listed in features but there isnt anywhere to adjust them.. ah well.

Thanks!
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,130 (9.57/day)
Likes
13,562
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + bob marley zion's
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#18
Wow thanks fellas, these drivers I landed on are awesome so far. I was able to change to 24bit and 96khz

I now have all the Xfi features and it actually works... for now anyway.. This is sweet.

Time to check out BC2 sounds now! I notice EAX works and 3D works, but the bass boost managment and Eq are listed in features but there isnt anywhere to adjust them.. ah well.

Thanks!
now you know why we all hate creative...
 

Kursah

Moderator
Staff member
Joined
Oct 15, 2006
Messages
10,956 (2.68/day)
Likes
5,076
Location
Missoula, MT, USA
System Name Kursah's Gaming Rig - Haswell Edition | Spartan Home Server 2015
Processor i7 4790k 4.0/4.8 @ 1.26v | i7 4790k 4.0/4.4 @ 1.18v - Both delidded w/CLU
Motherboard Asus Z87-Pro - BIOS 2103 | Asus Z87-Pro - BIOS 2103
Cooling Noctua NH-U14S Push-Pull | Cooler Master 212 EVO Stock - Using NT-H1 and AC MX-4
Memory 16GB (2x8) Corsair Dominator DDR3 2400 CL11 | 32GB (4x8) G.Skill DDR3-1600 CL9
Video Card(s) MSI GTX980 Ti Gaming 6G LE @ Stock | Onboard Intel HD 4600
Storage 850EVO 250GB SSD, 960GB SSD, 1x2TB | 840 120GB SSD, RAID10 6x2TB (6TB) + 8TB Backup
Display(s) Samsung 32" TV IPS 1080p, Dell 23" U2312HM IPS 1080p | 19" 4:3 Dell LCD..mostly RDP.
Case Corsair 600C - Stock Fans on Low | Lian Li Lancool PC-K7 - Cougar fans
Audio Device(s) Aune T1 mk1 > AKG K553 Pro + HiFiMAN HE-350 (Equalizer APO + PeaceUI) | Realtek ALC1150
Power Supply EVGA 750G2 Modular + APC 1500VA UPS | EVGA KR500 80+ Bronze + CyberPowerPC 1000VA UPS
Mouse Logitech G502 | Dell USB Laser Mouse
Keyboard Logitech G15 rv2 | Dell USB Keyboard
Software Windows 10 Pro x64 | Windows Server 2012 R2 (GUI Core,Hyper-V + VMs)
#19
Wow thanks fellas, these drivers I landed on are awesome so far. I was able to change to 24bit and 96khz

I now have all the Xfi features and it actually works... for now anyway.. This is sweet.

Time to check out BC2 sounds now! I notice EAX works and 3D works, but the bass boost managment and Eq are listed in features but there isnt anywhere to adjust them.. ah well.

Thanks!
If you're using X-Fi features, can you trick the X-Fi Console and Console Launcher to work then? I haven't researched the Audigy modded drivers or any of that, nor need to, but both X-Fi cards I used probably benefited most from being able to use the EQ and other settings the Console has that other parts of the software don't show.
 

shevanel

New Member
Joined
Jul 27, 2009
Messages
3,464 (1.13/day)
Likes
396
Location
Leesburg, FL
#20
Sound is around the same, as far as I can tell anyway. What's more important I suppose is that these drivers may have remedied my original complaint since I am not noticing ANY of the lag or jerkiness in BC2 any longer. A+!

Now I just need to find a windows 7 gadget or an ap that is a EQ or SS 5.1 level mixer... then I'd be set

EDIT:

kursah, youre a genious. I took your lead and looked and found the audio console installed and it in fact works! SWEET!

I can still tell a difference bwteen this audigy and the xfi titanium fatality I had, but at least now I have more control over the sound settings.

Edit:

After tweaking EQ and 5.1 levels, I am happy... Thanks again! X100M

edit:

DUDES!11 This is awesome, I am so aprreciative you guys came in and helped. I was just playing BC2 and lol, these turtle beach HPX 5.1's are now INSANE!!!!!!!!!!!!!!!

now that the 5.1 levels are right all 8 speakers in both cups are balanced, the bass from the subwoofer is rattling my head and this is just incredible! :)

Time to find a game!
 
Last edited: