• We've upgraded our forums. Please post any issues/requests in this thread.

How to test escape key?

OrbitzXT

New Member
Joined
Mar 22, 2007
Messages
1,969 (0.50/day)
Likes
59
Location
New York City
System Name AX-01
Processor Intel Core i5-2500K @3.7 GHz
Motherboard ASRock Z68 Extreme3 Gen3
Cooling Zalman 9700
Memory Kingston HyperX T1 Series 8GB DDR3 1600 MHZ
Video Card(s) GTX 590
Storage Intel X25-M
Display(s) 42" Samsung LED HDTV
Case Antec Twelve Hundred
Audio Device(s) HT | OMEGA STRIKER 7.1
Power Supply Kingwin 1000W
Software Windows 7 64-Bit
#1
I've been playing a game where I access the menu with the escape key, and it's not working. I can't think off the top of my head how else to test if the key is working or not.
 
Joined
Jul 20, 2007
Messages
640 (0.17/day)
Likes
286
Processor Intel i5 3550
Motherboard ASRock Z77 Pro4-M
Cooling Thermaltake Performer 2.0 AIO Liquid Cooler
Memory 32GB Corsair Vengeance DDR3 1600mhz
Video Card(s) EVGA GTX 960
Storage Corsair Neutron 256gb Boot drive, ~7tb storage combined on other drives
Display(s) AOC 27" 1920x1080 IPS and Wacom Cintiq 13" HD
Case Fractal Design Node 804
Audio Device(s) Realtek HD audio, Pyle Pro PTA2 Amp, Sony SS-B3000 Speakers, Sennheiser HD595 headphones
Power Supply Antec 750W "High Current Gamer"
Mouse SteelSeries Diablo 3
Keyboard Rosewill Mechanical with cherry black keys
Software Windows 7 Ultimate 64
#2
make a youtube video go full screen, and hit escape to return it to normal.
 
Joined
May 21, 2009
Messages
4,966 (1.59/day)
Likes
1,511
System Name i7-PC / HTPC / iMac
Processor i7 3820 / Phenom II 940
Motherboard GIGABYTE G1.ASSASSIN2 / M3A79-T Deluxe
Cooling Corsair Hydro H100i / Scythe II (HS only)
Memory G.SKILL Trident X Series 8GB (2 x 4GB) DDR3 1600mhz / 4GB DDR2 1066 (@800) Corsair Dominator
Video Card(s) GB Radeon HD 7950s 3GB / GB Radeon HD 7950s 3GB
Storage 2x 80GB Intel X-25, 2x600gb SATA, 1x1tb 5400RPM storage /1x600GB, 3x500GB,1x160,1x120 SATA
Display(s) 1x 27" Yamakasi / Vizio 42" HDTV
Case Lian Li Lancool PC-K58 / Antec 900
Audio Device(s) HT Omega Striker 7.1 / Onboard and HDMI from ATi Card
Power Supply PC Power & Cooling 750W / 610W
Software Ubuntu / Windows 8.1 Pro / OS X / PHPStorm / Gaming
#3
just start any page loading , escape should stop it.
 

OrbitzXT

New Member
Joined
Mar 22, 2007
Messages
1,969 (0.50/day)
Likes
59
Location
New York City
System Name AX-01
Processor Intel Core i5-2500K @3.7 GHz
Motherboard ASRock Z68 Extreme3 Gen3
Cooling Zalman 9700
Memory Kingston HyperX T1 Series 8GB DDR3 1600 MHZ
Video Card(s) GTX 590
Storage Intel X25-M
Display(s) 42" Samsung LED HDTV
Case Antec Twelve Hundred
Audio Device(s) HT | OMEGA STRIKER 7.1
Power Supply Kingwin 1000W
Software Windows 7 64-Bit
#4
Interesting, it's not working. It's the only key not working and nothing spilled. The keyboard is only a couple months old. Could I have disabled it somehow?
 
Joined
Jul 20, 2009
Messages
284 (0.09/day)
Likes
79
Location
Wales, Uk
Processor AMD PHENOM 9950BE x4 (140W)
Motherboard ASUS CROSSHAIR II (BIOS 2003)
Cooling ZALMAN 9700L
Memory 4GB CORSAIR DOMINATOR 1066 (2x2GB)
Video Card(s) XFX 9600GT XXX (740/1000)
Storage WD250x2 RAID0/Maxtor 500GB STORAGE
Display(s) SAMSUNG 23"/ACER 20"
Case COOLMASTER 690 CUSTOM
Audio Device(s) SUPREME FX II
Power Supply OCZ 700W
Software WINDOWS 7 64
#5
Could be some dust/dirt on the contact or stopping it making contact. If you feel brave just take the thing apart, give it a clean and re-assemble.
 

OrbitzXT

New Member
Joined
Mar 22, 2007
Messages
1,969 (0.50/day)
Likes
59
Location
New York City
System Name AX-01
Processor Intel Core i5-2500K @3.7 GHz
Motherboard ASRock Z68 Extreme3 Gen3
Cooling Zalman 9700
Memory Kingston HyperX T1 Series 8GB DDR3 1600 MHZ
Video Card(s) GTX 590
Storage Intel X25-M
Display(s) 42" Samsung LED HDTV
Case Antec Twelve Hundred
Audio Device(s) HT | OMEGA STRIKER 7.1
Power Supply Kingwin 1000W
Software Windows 7 64-Bit
#6
I opened it up and tried pressing directly on the contact myself, it worked fine. I'm not sure what the issue was, there was no dirt, everything was laid out fine, no spill damage. Oh well, it's working again so I'm pleased =)