• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

How to use a Nvidia card as Physx w/ATi

Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
Okay is it supposed to uninstall ati stream/open cl for ati cards?

Also GPU-z has no boxes at all ticked for the nv card.
 
Joined
Aug 11, 2009
Messages
6,823 (1.81/day)
Location
Viking Land
System Name Ivy Biatch
Processor i5 3570K
Motherboard ASSRockzz z77TOTHEEXTREME!!!!
Cooling bleh
Memory 2x4gb crucial 1866
Video Card(s) HD7770, yes it does BF3
Storage 120gb Vertex
Display(s) 226BW
Case whats that, oh my table
Audio Device(s) stock onboard thing
Power Supply HX850W
Software 7
have you restarted?
 
Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
have you restarted?

Yes.

After reading the read-me with 1.04 hack turns out it doesn't support the drivers I've been told to download here :laugh:

Latest nv drivers are needed : ]


Brb driver sweeping and trying again! :D
 
Joined
Aug 11, 2009
Messages
6,823 (1.81/day)
Location
Viking Land
System Name Ivy Biatch
Processor i5 3570K
Motherboard ASSRockzz z77TOTHEEXTREME!!!!
Cooling bleh
Memory 2x4gb crucial 1866
Video Card(s) HD7770, yes it does BF3
Storage 120gb Vertex
Display(s) 226BW
Case whats that, oh my table
Audio Device(s) stock onboard thing
Power Supply HX850W
Software 7
cool :D tell us how it turns out :D
 
Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
Ouch, think the 8600 is a lil week for physx, default settings I very quickly dip down to 14fps in fluidmark, with 20,000 particles I get 34 fps.

In games what sort of physx setting could I have? I don't mind playing at 30 fps.




Edit:

Using a nvidia card as second gpu dissables ATI stream, 4k videos on youtube now play like shit for me :[



Edit two : tried mirrors edge, holy fuck damn what a waste of time today was, glass breakthroughs take me down to 5 possibly even less fps D:

Cloth works fine though.

8600gt, not suitable for physx!
 
Last edited:
Joined
Sep 29, 2004
Messages
906 (0.16/day)
Location
La Quinta, CA
System Name The Shroomiest One!
Processor AMD Ryzen 7 1700
Motherboard ASRock x370 Taichi
Cooling BeQuiet Dark Rock TF
Memory 2x8gb Team Dark Pro 3200C14
Video Card(s) Evga Rtx2070 Black
Storage Samsung 960 Evo 500GB / 840 Pro 256GB / Western Digital 2Tb Black
Display(s) LG 42" HDTV LED 1080p
Case Corsair Carbide Series 400R Graphite Grey
Audio Device(s) SoundBlasterX AE-5
Power Supply EVGA 1000w Supernova
Mouse Razor Deathadder Elite
Keyboard Logitech G15
Software Windows 10 Home 64bit
Go into your Mirror's Edge install location, and then go into the binaries folder.
(Usually C:\Program Files\EA Games\Mirror's Edge\Binaries or C:\Program Files (x86)\EA Games\Mirror's Edge\Binaries)

Delete the following:
PhysXcore.dll
PhysXDevice.dll
and the folder called PhysXLocal

DO NOT DELETE PHYSXEXTENSION.DLL. The game will not run without it.
 
Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
Go into your Mirror's Edge install location, and then go into the binaries folder.
(Usually C:\Program Files\EA Games\Mirror's Edge\Binaries or C:\Program Files (x86)\EA Games\Mirror's Edge\Binaries)

Delete the following:
PhysXcore.dll
PhysXDevice.dll
and the folder called PhysXLocal

DO NOT DELETE PHYSXEXTENSION.DLL. The game will not run without it.
What the hell did that do man, running much much smoother now!

Thanks :D
 
Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
I picked up a 9800gt low pwr today and I can't get it to work in physx.

I used the 3 step method with the 196.21 drivers and the 1.4 patch and it didn't work. The physx software didn't show up in the control panel.

I also tried the 257 beta drivers that allowed the use of ATI cards and that didn't work.

Now, i'm gonna try the 258.96 drivers with the 1.4 patch and see if that works.

Does the 1.4 patch have a cake button as well? Cause it doesn't on my version.
 
Joined
Aug 18, 2007
Messages
896 (0.20/day)
Location
The Lone Star State
System Name Bench Box/Daily Driver
Processor i7 3930k / i7 3770k
Motherboard Asus R4E / Asus M5E
Cooling SS & Water
Memory G.SKILL 8GB 2133 / G.SKILL 16GB 2133
Video Card(s) Asus HD7970 / EVGA GTX Titan's SLI
Power Supply Corsair HX1200W/ Enermax Platimax 1350W
I just got it working on win7 64bit using 257.15 drivers and 14 patch.
I idn't see a cake button just press apply.

 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
258.96 drivers with the 1.4 patch!!!!



MetalRacer, what version of Fluidmark are you using?

And next time you take a screenshot make sure we can see the girl.
 
Joined
Aug 18, 2007
Messages
896 (0.20/day)
Location
The Lone Star State
System Name Bench Box/Daily Driver
Processor i7 3930k / i7 3770k
Motherboard Asus R4E / Asus M5E
Cooling SS & Water
Memory G.SKILL 8GB 2133 / G.SKILL 16GB 2133
Video Card(s) Asus HD7970 / EVGA GTX Titan's SLI
Power Supply Corsair HX1200W/ Enermax Platimax 1350W
Good to see you got it working HossHuge.:toast:

I'm using FluidMark version 1.2.
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
Just a heads-up for everyone. I ran the Mafia II benchmark tool and it up-dated my physx software. It also disengaged the physx. So I booted into safe mode and ran the patch again with success.
 
Joined
Aug 11, 2009
Messages
6,823 (1.81/day)
Location
Viking Land
System Name Ivy Biatch
Processor i5 3570K
Motherboard ASSRockzz z77TOTHEEXTREME!!!!
Cooling bleh
Memory 2x4gb crucial 1866
Video Card(s) HD7770, yes it does BF3
Storage 120gb Vertex
Display(s) 226BW
Case whats that, oh my table
Audio Device(s) stock onboard thing
Power Supply HX850W
Software 7
i added link to this thread in the Crossfire Clubhouse , hope thats okay with you Brandon
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
I don't think I have mine set up right. During the Fluidmark benchmark, the the usage on my 9800gt goes up to 76%. However, when I run the Mafia II and Dark Void benchmarks my usage stays at 0. Also, in the Nvidia control panel, I can't find anything about physx at all.

^^ Four posts up it shows physx checked in GPU-Z.

Are these things happening to anyone esle?
 
Joined
Jun 6, 2007
Messages
423 (0.09/day)
Location
Manchester, UK
System Name Colin
Processor i7 2600K @ 4.2GHz - Still going strong!
Motherboard Gigabyte Z77X-UD4H
Cooling Coolermaster Hyper 212 EVO, 5xArctic F12s on Zalman ZM-MFC1 Plus controller
Memory 4x4Gb Corsair Vengeance DDR3 2133 9-11-10-30-1T 1.5v
Video Card(s) MSI GTX 980 Ti Gaming 6G
Storage 1x256GB Samsung 830, 2x250GB Samsung 840 EVO, 4x500gb Seagate in RAID 10
Display(s) Acer XB280HK 4K GSYNC
Case Zalman Z9 U3
Audio Device(s) Onboard Realtek of some sort
Power Supply 750W XFX PRO
Mouse Zalman ZM GM1
Keyboard Zalman ZM K400G
Software Windows 10 Home x64
The patched worked for me without using safe mode in win7 x64. Also, I could have both graphics cards installed from the start. So, in summary, this is what I did:

Installed both graphics cards

Installed latest ATI drivers

Rebooted normally (not into safe mode)

Installed latest nvidia Drivers

Installed latest Physx Drivers

Installed 1.4 patch
 
Joined
Oct 8, 2009
Messages
1,912 (0.51/day)
Location
Republic of Texas
Processor Ryzen 3900x
Motherboard Asus ROG Strix x470-F Gaming
Cooling NZXT Kraken X62 with CableMod
Memory 32gb Corsair Vengeance LPX @3200MHz
Video Card(s) Asus GTX 1080 Ti Strix OC
Storage Samsung 960 EVO Series - 500GB NVMe | Intel 660p 2TB NVMe
Display(s) Acer Predator X34 Curved IPS 3440x1440 G-Sync | Acer XB270H Abprz 27" G-Sync | Oculus Rift
Case Phanteks Enthoo Evolv TG
Audio Device(s) Objective2 Amp/DAC | AKG K612PRO and Beyerdynamic DT880 (600-ohm) | Blue Yeti Mic
Power Supply Seasonic Prime 750W with CableMod
Mouse Razer DeathAdder Elite
Keyboard Corsair K95 Platinum RGB "Cherry MX Brown"
Software Win 10 pro
The patched worked for me without using safe mode in win7 x64. Also, I could have both graphics cards installed from the start. So, in summary, this is what I did:

Installed both graphics cards

Installed latest ATI drivers

Rebooted normally (not into safe mode)

Installed latest nvidia Drivers

Installed latest Physx Drivers

Installed 1.4 patch

yeah OP need lil bit of updating

Did excatly wat u did and no issues
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
I'm showing that it works, but I don't know why I'm not getting any usage at all during those benchmarks (Mafia II, Dark Void).



Are you guys able to see the physx part of the Nvidia control panel?
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
rodneyhchef, I'm gonna try what you did and see if it works.
 
Joined
Aug 13, 2010
Messages
4,519 (1.33/day)
use fluidmark, if it works fine there use the fluidmark bench. ur 9800GT suppose to get around 8600-8800 fluidmarks
 
Joined
Jun 6, 2007
Messages
423 (0.09/day)
Location
Manchester, UK
System Name Colin
Processor i7 2600K @ 4.2GHz - Still going strong!
Motherboard Gigabyte Z77X-UD4H
Cooling Coolermaster Hyper 212 EVO, 5xArctic F12s on Zalman ZM-MFC1 Plus controller
Memory 4x4Gb Corsair Vengeance DDR3 2133 9-11-10-30-1T 1.5v
Video Card(s) MSI GTX 980 Ti Gaming 6G
Storage 1x256GB Samsung 830, 2x250GB Samsung 840 EVO, 4x500gb Seagate in RAID 10
Display(s) Acer XB280HK 4K GSYNC
Case Zalman Z9 U3
Audio Device(s) Onboard Realtek of some sort
Power Supply 750W XFX PRO
Mouse Zalman ZM GM1
Keyboard Zalman ZM K400G
Software Windows 10 Home x64
I think with the latest drivers the physx options in nv cp are invisible but it definately works. I've tested using fluid mark, 3DMark vantage and Arkham Asylum.
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
Do these numbers look OK?



Everything on high, AA on, physx on med


Everything on high, no AA, physx on med


Everything on high, no AA, physx off


And in Dark Void it asks me to turn physx on in the control panel which I can't.
 
Joined
Jun 26, 2008
Messages
2,388 (0.57/day)
Location
EDM, AB, CAN
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Memory GSkill 8GB Dual Channel DDR4-2800
Video Card(s) MSI GamingX RX580 4GB
Storage Kingston V300 240GB SSD + WD Green 2TB
Display(s) ACER K212HL 27" + Haier 55" + Lenovo Explorer Mixed Reality Headset
Case Enermax Ostrog (Red)
Power Supply EVGA SuperNOVA B2 750W
Software Win10 64bit
After looking at other people's Mafia II fps's, It looks like it's about right.
 
Joined
Jan 2, 2009
Messages
9,773 (2.45/day)
Location
Suffolk/Essex, England
System Name Joseph's Laptop Clevo P771ZM
Processor 4970k @4/4.4ghz
Motherboard *shrugs*
Cooling About 2 kilos of copper fins and pipes.
Memory 2x 8gb
Video Card(s) GTX 970m 6gb
Storage 500gb Msata SSD 2x 2TB storage drives
Display(s) Built in
Power Supply 300w power brick
Mouse Steam controller
Software Windows ten
Any one know how to get phsyx running on the NV card but openl-cl running on the ATI card?

I want decent video decoding again!
 
Top